I NEED someone with a "unsoftmodable" Wii

Discussion in 'Wii - Hacking' started by icefireicefire, Mar 20, 2009.

Mar 20, 2009
  1. icefireicefire
    OP

    Member icefireicefire GBATemp Fails.

    Joined:
    Dec 19, 2008
    Messages:
    961
    Country:
    United States
    I'm going to re-compile YAWND to run off of IOS16, so I need someone with one of these "new" wii's to PM me so we can work through this together. I'd prefer a PM at wadder.net, or getting on IRC, but here will do.

    Lets work out whats really going on.
     
  2. WiiPower

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    Did you test it at your own Wii? Sorry i ask, but when writing a patchmii clone that used IOS16, i had even problems to decrypt files. The ES functions for decryption didn't work, so i had to use the common key and aes commands manually. I wouldn't be surprised if there are other details not working.
     
  3. nicksasa

    Member nicksasa GBAtemp Maniac

    Joined:
    Oct 25, 2008
    Messages:
    1,410
    Country:
    Belgium
    eh use my dumper to run off ios 16 you will get trouble to recompile yawnd like i did [​IMG]
     
  4. icefireicefire
    OP

    Member icefireicefire GBATemp Fails.

    Joined:
    Dec 19, 2008
    Messages:
    961
    Country:
    United States
    nicksasa I don't understand what you said [​IMG]. Do you mean I should recompile yours as it is easier than YAWND?

    BTW, the ES_ functions DO work, as that is what WAD Manager uses.
     
  5. nicksasa

    Member nicksasa GBAtemp Maniac

    Joined:
    Oct 25, 2008
    Messages:
    1,410
    Country:
    Belgium
    use my dumper
    as you will get TROUBLE recompiling yawnd even i couldnt compile it
     
  6. icefireicefire
    OP

    Member icefireicefire GBATemp Fails.

    Joined:
    Dec 19, 2008
    Messages:
    961
    Country:
    United States
    I doubt its _that_ hard, but theres no reason for me not to use yours [​IMG].
     
  7. WiiPower

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    Well installation works yes, but at least ES decryption does not. WAD Manager just takes whatever is inside the .wad files and installs it, patchmii clones take that, decrypt it, patch it, and then encrypt it again.
     
  8. Jacobeian

    Member Jacobeian GBAtemp Advanced Maniac

    Joined:
    May 15, 2008
    Messages:
    1,879
    Country:
    Cuba

    might be something related to the encryption keys that are passed as paremeter ?
     
  9. WiiPower

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    Well i'm not an expert at this, i just had problems to use it. A changed index for the common key would explain the issues i had.
     
  10. Bent

    Member Bent GBAtemp Regular

    Joined:
    Nov 6, 2002
    Messages:
    162
    Country:
    United States
    I had some troubles related to this too. My Wii is fully updated to 4.0, with cIOS Rev8 and cIOS USB2 v2 installed. I thought I had the correct cIOS USB2 installed to use WiiND until I read the Readme :/ Apparently IOS202 doesn't work right and IOS222 is needed. And since 4.0 is installed I can't seem to instale IOS222. Oh well, I tried to modify both YaWnD and WiiND to use IOS249 (I don't NEED the USB2 feature, can use SD). YaWnd refuses to compile, and WiiND's source appears to be from v1 of the program, and it creates the dump but extract just crashes with a stack dump. I was wondering if anyone got YaWnd to recompile, or if there was a more recent source for WiiND available.
     
  11. Bent

    Member Bent GBAtemp Regular

    Joined:
    Nov 6, 2002
    Messages:
    162
    Country:
    United States
    Double post.
     

Share This Page