I need a new flashcard....

Discussion in 'NDS - Flashcarts and Accessories' started by Hoschi, Dec 8, 2009.

Dec 8, 2009

I need a new flashcard.... by Hoschi at 8:56 PM (996 Views / 0 Likes) 7 replies

  1. Hoschi
    OP

    Newcomer Hoschi Member

    Joined:
    Jul 1, 2005
    Messages:
    22
    Country:
    Albania
    Hi dudes

    so with my old trusty supercard SD Slot2 again failing to run a game i liked to play i decided to get a new flashcard.... but since im not too much into all this flashcard stuff i need your advice.

    I got a old phat NDS and lots of SD memory cards. What new flashcard would work with my phat NDS and run all newer games without complications. Plz tell me what you suggest?

    thanks in advance
    Hoschi
     
  2. ProtoKun7

    Global Moderator ProtoKun7 GBAtemp Time Lord Regenerations: 3

    Joined:
    Jan 3, 2009
    Messages:
    7,480
    Location:
    Gallifrey
    Country:
    United Kingdom
    CycloDS Evolution still has strong official support. It's been out since 2007 and is still going strong. Team Cyclops have been doing some behind the scenes stuff recently, working on a DSi cart, which makes people worry that they've abandoned everyone. It's slightly more expensive, but a firm choice if money isn't an issue.

    After that, maybe Acekard with AKAIO. Keep in mind AKAIO is unofficial, and I've heard that Acekard's official firmware isn't that great.
     
  3. Davess

    Member Davess On the list :D (Thanks Haflore)

    Joined:
    Mar 15, 2009
    Messages:
    693
    Location:
    __________________ Posts: 9326
    Country:
    Canada
    Acecard, with akaio its like 15 dollars on dealextreme [​IMG]
     
  4. YayMii

    Member YayMii hi

    Joined:
    Jun 24, 2009
    Messages:
    4,881
    Location:
    that place
    Country:
    Canada
    I'd go with either the Supercard DS Two when it comes out. Or if you don't want to wait, go for the Acekard 2i. It has the best options, it's really cheap, and it works with the DSi (just in case you want to upgrade).
    Acekard doesn't update it's firmware anymore. In fact, they recommend AKAIO rather than their own firmware.
     
  5. Hoschi
    OP

    Newcomer Hoschi Member

    Joined:
    Jul 1, 2005
    Messages:
    22
    Country:
    Albania
    and they all work with a old phat DS? Or do i need something else like the "superkey" i needed for my supercard?
     
  6. Schizoanalysis

    Member Schizoanalysis From somewhere inside the rabbit hole...

    Joined:
    Jun 23, 2009
    Messages:
    2,782
    Location:
    ...
    Country:
    Australia
    Acekard2i or M3 Real...
     
  7. YayMii

    Member YayMii hi

    Joined:
    Jun 24, 2009
    Messages:
    4,881
    Location:
    that place
    Country:
    Canada
    Why would you need a superkey for something that goes into the slot that the superkey goes into?

    Well, you don't need anything additional, just the memory card (microSD).


    And all current DSi cards work on every DS.
     
  8. Hoschi
    OP

    Newcomer Hoschi Member

    Joined:
    Jul 1, 2005
    Messages:
    22
    Country:
    Albania
    thanks. As i said i bought my Supercard + superkey ages ago and never bothered to inform myself about all the new flashcard stuff just dont want to spend money on something and realise that i need something else to get it working ;-)
     

Share This Page