How to resign a save using rebug 4.70.1?

Discussion in 'PS3 - Hacking & Homebrew' started by ng80092a, Aug 16, 2015.

  1. ng80092a
    OP

    ng80092a Advanced Member

    Newcomer
    86
    0
    Jul 4, 2007
    I have a old demon souls save that was working perfectly fine on a previous 4.XX rebug version (4.30 i guess)

    I extracted all the saves in the userid/savedata via ftp from the console hdd, updated to rebug 4.70, and formated the hard drive after 4 years of use.

    Now i'm trying to use bruteforce to resign all of my saves, but a few ones, like demon souls never get to work. I've been using the following process:

    Used a param.sfo created after the format as a template (which has no account ID, none of the ones i tried)

    1-> decrypt, 2-> update account ID and copy params, 3-> disable copy protection, 4-> encrypt again, 5-> rebuild.

    On rebuilding i get hash errors. for demon souls, but most of the copy protected saves are working.
    I'm guessing it's because of the online features, and that now, param.sfo doesn't provide any account ID. But i've read around that rebug has a fake id, how can i use it and go back to my game?

    Any help matters.. thank you
     
  2. tbb043

    tbb043 Member

    Member
    1,046
    461
    Jan 30, 2008
    United States
    Just thinking out loud, could you go back to the CFW where it worked, load the save in the game, resave either over it or in a new slot, then reinstall 4.70.1?

    I realize this is a highly convoluted thing to do if you just want a save or two, but if it was something very important to you, it might be worth trying. Hopefully someone else will come along with a better approach.
     
  3. vijankush

    vijankush Advanced Member

    Newcomer
    73
    23
    Jun 26, 2015
    United States
    Bro, change your console to DEX.
    Then in Debug Settings, Turn on "Fake Save Data Owner"
    It will make any save work on your console :)

    If you don't know how to do it...PM me XD