How do you install your Game Updates?

Discussion in '3DS - Homebrew Development and Emulators' started by kinvira, Feb 13, 2016.

  1. kinvira
    OP

    kinvira Member

    Newcomer
    41
    2
    Dec 4, 2015
    Gambia, The
    Since the eshop blocks the Game Updates from lower system versions completely our possibilities to install Game Updates are limited and most people don't know how to enjoy new content brought by patches.

    I am interested in your experiances with Game Updates.

    Is there a homebrew way without CFW?
    What ways are you using?

    My N3DS is on 10.1.0-27 E but had no success installing Game Updates for the Legit CIAs with NASA or FBI.

    What about you?
     


  2. pofer

    pofer GBAtemp Fan

    Member
    326
    104
    Jan 4, 2016
    Spain
    Somewhere around the corner
    Is there a homebrew way without CFW?

    FBI / Big Blue Menu / DevMenu should do it on any FW below 9.2 and NASA for 9.2+

    What ways are you using?

    10.5 emunand o3DS, so I just press Y after it asks me to update, unless I have a game from another region, which I lack of
     
    Last edited by pofer, Feb 13, 2016
    kinvira likes this.
  3. gnmmarechal

    gnmmarechal Kirigiri > Naoto

    Member
    GBAtemp Patron
    gnmmarechal is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    4,473
    2,663
    Jul 13, 2014
    Portugal
    https://gs2012.xyz
    You can update NVER and friends-module, and then access the eShop through Hans with spoof. You can update from there.

    Check this:
    https://www.reddit.com/r/3dshacks/comments/430l7j/tutorialaccessing_eshop_on_outdated_firmwares/
     
    kinvira likes this.
  4. kinvira
    OP

    kinvira Member

    Newcomer
    41
    2
    Dec 4, 2015
    Gambia, The
    Thank you for the useful posts so far.

    For 9.3-10.3 Users:
    It seems it isn't that easy or possible right now without editing your Nand.

    Maybe we should think about an app solution that's only for updating our Games.
    Or we might wait for our "CIA installers" dealing with the task of installing Game Updates since Rinnegatamante mentioned that it should theoretically work.
     
  5. Quantumcat

    Quantumcat Dead and alive

    Member
    9,780
    5,106
    Nov 23, 2014
    Australia
    Canberra, Australia
    There's not really any need to spoof eShop at the moment. If you are on 9.2 or below with no emuNAND you can install them with a CIA manager, if you have an emuNAND, all CFW now support 10.5, and if you are 9.3-10.3 and don't want to downgrade you should just update to 10.5.
     
  6. kinvira
    OP

    kinvira Member

    Newcomer
    41
    2
    Dec 4, 2015
    Gambia, The
    Actually I think lots of people stay on 9.3-10.3 because of the anounced Gateway support.
    With gateway you will have your emunand as well.

    But the solution for now is missing imo. Because nobody knows how long they will need for their release.
    Also people might stay on 9.3-10.3 because they are waiting for a saver way to downgrade or whatever.
     
  7. DesuIsSparta

    DesuIsSparta GBAtemp Advanced Fan

    Member
    540
    174
    Oct 13, 2015
    United States
    Weaboo land
    Why do you use NASA for 9.2+? I'm wondering because I still use Big Blue Menu for everything , and i'm running emunand 10.5.
     
  8. kinvira
    OP

    kinvira Member

    Newcomer
    41
    2
    Dec 4, 2015
    Gambia, The
    The Problem is. I have just the sysnand of my N3DS 10.1E right now. Options are limited. NASA grants you LEGIT CIA installation support. And I am just wondering why I can't install updates like legits as well. I think there should be an easy solution without downgrading (or upgrading) or messing with sysnand right now.
     
  9. Quantumcat

    Quantumcat Dead and alive

    Member
    9,780
    5,106
    Nov 23, 2014
    Australia
    Canberra, Australia
    I use NASA for network installation (saves having to remove the back plate). I hear other CIA installers can do this as well but NASA was the first network installer I tried and it works so I don't feel the need to try a different one now.
     
    DesuIsSparta likes this.
  10. pofer

    pofer GBAtemp Fan

    Member
    326
    104
    Jan 4, 2016
    Spain
    Somewhere around the corner
    Is there a homebrew way without CFW?
     
  11. Quantumcat

    Quantumcat Dead and alive

    Member
    9,780
    5,106
    Nov 23, 2014
    Australia
    Canberra, Australia
    You have the choice of downgrading, upgrading, messing with sysNAND to spoof eShop or waiting for Gateway support. No other options I'm afraid :-) Don't be too ungrateful - until incredibly recently your only choice would have been Sky3DS or nothing.

    — Posts automatically merged - Please don't double post! —

    Um you quoted one of them ... NASA.3dsx.
     
  12. DarkFlare69

    DarkFlare69 GBAtemp Psycho!

    Member
    4,624
    2,456
    Dec 8, 2014
    United States
    Ohio
    I use CIAs to update. Iuse v1.0 MK7 CIA + the update data as a cia.
     
  13. pofer

    pofer GBAtemp Fan

    Member
    326
    104
    Jan 4, 2016
    Spain
    Somewhere around the corner
    I wasn't asking the question hahaha
     
  14. Quantumcat

    Quantumcat Dead and alive

    Member
    9,780
    5,106
    Nov 23, 2014
    Australia
    Canberra, Australia
    Haha sorry .. I actually went up the post to see who mentioned the list of CIA installers to quote it and then saw it was you and got confused, then you posted this :-p
     
  15. kinvira
    OP

    kinvira Member

    Newcomer
    41
    2
    Dec 4, 2015
    Gambia, The
    Ty for your help. So I gonna stay without Bayonetta etc. on Smash Bros until Gateway will release their update. :)
    I am patient this time. Got my small Zelda o3ds with 4.3 I think. So I will use it for now. I am just curious about playing all those Games on my N3DS XL. :P
     
  16. gnmmarechal

    gnmmarechal Kirigiri > Naoto

    Member
    GBAtemp Patron
    gnmmarechal is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    4,473
    2,663
    Jul 13, 2014
    Portugal
    https://gs2012.xyz
    upgrades aren't legit CIAs.
     
  17. spacelaces

    spacelaces Member

    Newcomer
    31
    6
    Jan 10, 2016
    Gambia, The
    yup, updates are not legit CIAs. Also make sure the regions of your game and the update match, you can't use the USA update on the EUR version of the game and vice versa.
     
  18. yacepi15

    yacepi15 GBAtemp Advanced Fan

    Member
    868
    167
    Aug 15, 2015
    eShop.
    EDIT: I didnt read the first post.
     
  19. Burakidiosu

    Burakidiosu Member

    Newcomer
    39
    8
    Dec 30, 2015
    France
    With FBI or BBM
     
  20. z3ro

    z3ro Advanced Member

    Newcomer
    54
    20
    Oct 26, 2015
    United States
    Ohio
    I update through eShop. I'm dreadfully boring.