1. UltraSUPRA

    OP UltraSUPRA Masks don't work.
    Member

    Joined:
    May 4, 2018
    Messages:
    1,423
    Country:
    United States
    My little sister recently found the old GBA, and I don't know how to use the flashcart that we have with it. I have the plug and the software, but nothing seems to work.
     
  2. UltraSUPRA

    OP UltraSUPRA Masks don't work.
    Member

    Joined:
    May 4, 2018
    Messages:
    1,423
    Country:
    United States
  3. kuwanger

    kuwanger GBAtemp Advanced Maniac
    Member

    Joined:
    Jul 26, 2006
    Messages:
    1,510
    Country:
    United States
    You say you have the plug. Do you mean this or this? If so you can use a GBA and a computer with the f2a tools from that guide to flash the cart.
     
  4. UltraSUPRA

    OP UltraSUPRA Masks don't work.
    Member

    Joined:
    May 4, 2018
    Messages:
    1,423
    Country:
    United States
    Yeah, I have the second one. Should I use a VM?
     
  5. kuwanger

    kuwanger GBAtemp Advanced Maniac
    Member

    Joined:
    Jul 26, 2006
    Messages:
    1,510
    Country:
    United States
    If you're having problems with the software detecting your GBA when trying to flash, then yes. Just to be clear to use the F2A tool software you'll need to plug the f2a link cable into your gba, have your f2a in your gba, and hold start+select while turning on the GBA (you'll hear a jingle and the "Nintendo" logo will fade out) to put it into multiboot mode. At that point you can try using the f2a tool (you'll have to go into the options and select ilinker or something (whatever is not ltp/parallel port).
     
  6. alexander1970

    alexander1970 Thank you,Santa.
    Member

    Joined:
    Nov 8, 2018
    Messages:
    11,872
    Country:
    Austria
    Hello.:)

    Maybe this software helps you also.I´ve tried it under Windows 7 32bit and Windows 10 64bit.

    Good luck.
     

    Attached Files:

  7. migles

    migles All my gbatemp friends are now mods, except for me
    Member

    Joined:
    Sep 19, 2013
    Messages:
    8,034
    Country:
    China
    If you can't make it to work (sadly i don't own one and dont have experience with that card)
    don't put it to trash or destroy it
    IIRC the usb cable is rare and its an item people would like to get. i remember someone here looking for the cable but i dont remember who
     
    alexander1970 likes this.
  8. r0ni

    r0ni Advanced Member
    Newcomer

    Joined:
    Nov 5, 2002
    Messages:
    86
    Country:
    United States
    The software is very finicky. Last I used one I ran it on a 32bit winxp VM. You will need the libusb dll in the directory of the software for it to work as well.


    Sent from my iPhone using Tapatalk
     
  9. UltraSUPRA

    OP UltraSUPRA Masks don't work.
    Member

    Joined:
    May 4, 2018
    Messages:
    1,423
    Country:
    United States
    Which folder do I get the LibUSB DLL from? MS32, MS64, MipGW32, or MipGW64? Do I need to compile it somehow? Do I have to rename it? Does this apply to f2a-usb11? I need more info than "you need this".

    Initial ULA ...
    Could not find xLA system !!
    Checking ULA....
    USB or driver error
    No Adaptor Found!
     
  10. r0ni

    r0ni Advanced Member
    Newcomer

    Joined:
    Nov 5, 2002
    Messages:
    86
    Country:
    United States
    You need the one corresponding to what your OS is. If you have 32bit windows, you need either of the 32bit named ones. Same for 64 bit. I would recommend the mingw ones. No compiling, just move the file to where the f2a app exe is. Before pressing the “flash” button in the application, you need to make sure your gba is turned on and in multi-boot mode press power while holding select+start). If all is well it will find the driver and your gba will make a chime sound. The flash your games.


    Sent from my iPhone using Tapatalk
     
  11. acrocosm

    acrocosm GBAtemp Regular
    Member

    Joined:
    Jul 1, 2004
    Messages:
    180
    Country:
    I digged out my old gear recently and tried to flash my cart. I used the same drivers and software I was using back then, the same f2a_usb11 posted above and the hacked f2ausbdriver. I remember that combo was working good.

    I tried it in a VM with xp sp3 but when I run the flasher the device gets disconnected. I unplug and replug and it gets recognized again. When I click the write button it gets disconnected again and I have to unplug and replug. At that time the software hangs.

    Any insights?
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - Flash2Advance,