Homebrew on 2.2

Discussion in '3DS - Homebrew Development and Emulators' started by Milo5789, Jun 24, 2016.

  1. Milo5789
    OP

    Milo5789 Member

    Newcomer
    27
    1
    May 7, 2016
    Cote d'Ivoire
    Title.

    I've found no means to do it. Any help out there? Is it even possible?
     


  2. Robz8

    Robz8 Coolest of TWL

    Member
    6,803
    2,872
    Oct 1, 2010
    United States
    Aside from the internet browser exploit, nope.
     
  3. GerbilSoft

    GerbilSoft GBAtemp Addict

    Member
    2,081
    2,304
    Mar 8, 2012
    United States
    This is an interesting one. Assuming your system was never upgraded from 2.2 (that is, it hasn't been downgraded), you need to first obtain your OTP ROM using OTPHelper, then use cartridges to upgrade to 9.0/9.1/9.2, and finally install arm9loaderhax. You can't simply install A9LH from 2.2, since you won't be able to boot the system. (No current CFW supports 2.2.)

    EDIT: This is assuming you want to use arm9loaderhax in general. Since you're already at 2.2, most of the hard work is out of the way, so all you need to do is dump the OTP ROM and then cart-upgrade, as I already mentioned.
     
  4. Jiro2

    Jiro2 GBAtemp Advanced Fan

    Member
    760
    185
    Mar 28, 2011
    United States
    On 2.2, you will need Cubic Ninja to dump the OTP. If not, you'll have to do it the hard way (upgrade to 9.2, downgrade to 2.1).
     
    zoogie likes this.
  5. zoogie

    zoogie simple pimp tool

    Member
    6,321
    7,993
    Nov 30, 2014
    United States
    We need your full firm version # OP.
    Spoiler: if the last number is a zero, you've got some extra work ahead of you.

    edit
    Even then, I think native firm was changed from 2.1 -> 2.2, so you'll likely need to update anyway, unless some generous hacker elite ports the 2xrsa sploit to 2.2 just for you.
     
    Last edited by zoogie, Jun 24, 2016
  6. Jiro2

    Jiro2 GBAtemp Advanced Fan

    Member
    760
    185
    Mar 28, 2011
    United States
    I don't think the last number makes any difference to using Cubic Ninja. It's an exploit that directly retrieves the OTP; it is not Ninjhax.
     
  7. Milo5789
    OP

    Milo5789 Member

    Newcomer
    27
    1
    May 7, 2016
    Cote d'Ivoire
    Whoa, actually, i'm trying to upgrade to 9.2 to put a CW.

    I'm too nancy to try alh9
     
  8. Lia

    Lia is this the real life

    Member
    1,556
    3,034
    Jan 29, 2016
    United Kingdom
    caught in a landslide
    Get your OTP even if you aren't installing a9lh.
    It'll help a lot in the future, if you do decide to go down that route.
     
  9. Robz8

    Robz8 Coolest of TWL

    Member
    6,803
    2,872
    Oct 1, 2010
    United States
    Actually, SafeA9LHInstaller can get the OTP and then install A9LH.
     
  10. I pwned U!

    I pwned U! GBAtemp Advanced Fan

    Member
    833
    1,117
    Jun 14, 2013
    United States
    If you are using a NA 3DS, then I will sell you a copy of Freakyforms Deluxe. This will allow you to safely update to 4.3 with the game card update, where you can then launch a CFW with MSET for updating to 9.2.
     
    The Cringe likes this.
  11. Lia

    Lia is this the real life

    Member
    1,556
    3,034
    Jan 29, 2016
    United Kingdom
    caught in a landslide
    For the low low price of $999.99 plus shipping!
    Naw, @Milo5789 i would recommend grabbing your otp, updating via plaisysupdater to 9.2 and installing a cfw/emunand or a9lh

    If you want me to help, just pm me (4th link in my signature). Aalternatively I do a9lh installs for £5 (second link in my signature) pm me for more details.
     
    I pwned U! likes this.
  12. I pwned U!

    I pwned U! GBAtemp Advanced Fan

    Member
    833
    1,117
    Jun 14, 2013
    United States
    Do not worry, I will not be charging anywhere near that much!:rofl2:
     
    The Cringe and Lia like this.
  13. GerbilSoft

    GerbilSoft GBAtemp Addict

    Member
    2,081
    2,304
    Mar 8, 2012
    United States
    The problem is you then need to restore a 9.x+ SysNAND, since no CFW currently supports 2.x. Since the system was already on 2.2, there's no 9.x SysNAND to restore.
     
  14. TheVinAnator

    TheVinAnator GBATemp's Greatest Vin

    Member
    3,567
    2,583
    Jan 10, 2016
    Canada
    NO COFFEI!
    If you want a cfw just install a9lh, it's better and since your on 2.2 will most likely be easier in the long run trust me!
     
  15. Milo5789
    OP

    Milo5789 Member

    Newcomer
    27
    1
    May 7, 2016
    Cote d'Ivoire
    I'd give it a shot if found a noob's tutorial, haven't found one around here. Did I search wrongfully?
     
  16. Lia

    Lia is this the real life

    Member
    1,556
    3,034
    Jan 29, 2016
    United Kingdom
    caught in a landslide
    PM me, I can guide you through it
     
  17. TheVinAnator

    TheVinAnator GBATemp's Greatest Vin

    Member
    3,567
    2,583
    Jan 10, 2016
    Canada
    NO COFFEI!
    Minnow likes this.
  18. Lia

    Lia is this the real life

    Member
    1,556
    3,034
    Jan 29, 2016
    United Kingdom
    caught in a landslide
    Tha won't work as milo is on version 2.2 and cannot restore a nand backup. He will brick if he follows that guide.
     
    I pwned U! likes this.
  19. TheVinAnator

    TheVinAnator GBATemp's Greatest Vin

    Member
    3,567
    2,583
    Jan 10, 2016
    Canada
    NO COFFEI!
    thats why i said do as said above first
     
  20. Lia

    Lia is this the real life

    Member
    1,556
    3,034
    Jan 29, 2016
    United Kingdom
    caught in a landslide
    Yeah, but you don't want to go wrong. In this istnace, I wouldn't recommend that guide to @Milo5789