Homebrew menu not working anymore

Discussion in '3DS - Homebrew Development and Emulators' started by Chrisssj2, Mar 4, 2016.

  1. Chrisssj2
    OP

    Chrisssj2 GBAtemp Maniac

    Member
    1,303
    108
    Feb 12, 2008
    Netherlands
    Allow me to explain. I was fiddling around with home menu hax and ctrboot manager. But couldn't quite get it to work like I wanted to. Menu hax was working however.

    Now home menu hax isn't working.. When I press L when gateway or the console is booting. or when I press the home menu button in gateway nothing is happening.

    Tried removing, and re-install but same result. Also re-applied the startkit.. same result.
    How can I fix this?
     
  2. Joom

    Joom  ❤❤❤

    Member
    3,701
    2,470
    Jan 8, 2016
    United States
    Have you been hex editing your payload in order to get it to boot something else?
     
  3. Chrisssj2
    OP

    Chrisssj2 GBAtemp Maniac

    Member
    1,303
    108
    Feb 12, 2008
    Netherlands
    I haven't used a hex editor for such purpose I am quite sure.
     
  4. joyoshi

    joyoshi ICUP

    Member
    329
    590
    Oct 9, 2015
    Netherlands
    Shoved up your nose
    Did you edit your ctr config, or edit the name of your homebrew payload?
     
  5. Chrisssj2
    OP

    Chrisssj2 GBAtemp Maniac

    Member
    1,303
    108
    Feb 12, 2008
    Netherlands
    Never mind it seems to autoload now.. when i start ndsprofile/gateway.
    To return to emunand I have to run Gateway I guess from the homemenu.
    Question about hans, is it possible to make it run with .3ds files or only cia?

    EDIT:
    Actually that seems to get me into a deadloop if I run gateway from there. since gateway is actually already run?!
     
    Last edited by Chrisssj2, Mar 4, 2016
  6. Joom

    Joom  ❤❤❤

    Member
    3,701
    2,470
    Jan 8, 2016
    United States
    Well, then what "fiddling" have you been doing? Details help.
     
  7. Chrisssj2
    OP

    Chrisssj2 GBAtemp Maniac

    Member
    1,303
    108
    Feb 12, 2008
    Netherlands
    Forgot kinda actually. I remember I had to mess around with menuhax_padcfg because the buttons wouldn't register in the homemenu config buttons section when installing.
    So the Topic creator of CTR boot manager gave me his menuhax_padcfg.

    This is what I just replaced mine with. and caused home menu hax to boot. However I cant seem to get back to emunand.
    Unless I replace my menuhax_padcfg with the old one, which does not seem to boot menuhax at all.
     
  8. Chrisssj2
    OP

    Chrisssj2 GBAtemp Maniac

    Member
    1,303
    108
    Feb 12, 2008
    Netherlands
    Hmm somehow I made it so homebrewmenu autoloads when I start gateway. and when I press L it won't boot, and I will return to emunand.
    Which is fine I guess.. Would be better otherway around but o well.