Question Highest on cartridge available FW update?

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by lordelan, Jul 17, 2019.

  1. lordelan
    OP

    lordelan GBAtemp Psycho!

    Member
    11
    Jan 4, 2015
    Germany
    Is it still the case that FW updates are on cartridges? Even for very high FWs?
    If yes, what's the highest FW available on a cartridge now?

    Reason I'm asking is: I'm about to setup an old (hopefully "clean") NAND dump while I move my current "hacky" one to an emuEMMC partition.
    The thing is: I made that old clean backup before I updated then to 4.1 or 5.1 (not completely sure) so when restoring it now I would have to update it via ChoiDujourNX. Otherwise Ninty would know I've been online with 4.1 or 5.1 (again, not sure) but am online again with 3.0.0 in order to update.

    Also as a general question: Do you guys update your clean sysNAND with ChoiDujourNX as well or via the official way?
     
  2. Kafluke

    Kafluke GBAtemp Guru

    Member
    13
    May 6, 2006
    United States
    If you've been online with a higher firmware than your backup then you've burned fuses. Dont downgrade!
     
  3. lordelan
    OP

    lordelan GBAtemp Psycho!

    Member
    11
    Jan 4, 2015
    Germany
    Fuses are only burnt when booting without hekate/argon/sxos and since I don't plan not to use hekate at any point my fuses should be safe. ;)

    @downgrading: Since my "clean" NAND dump is from a lower FW than my current sysnand (which I used for hacks/homebrews and which I'll turn into an emuEMMC) I have no other choice but to downgrade or did I miss something?
    As long as I restore BOOT0/1 and the full RAW NAND dump and keep using hekate to boot (even for stock sysNAND) there shouldn't be any problems I thought?
     
  4. Kafluke

    Kafluke GBAtemp Guru

    Member
    13
    May 6, 2006
    United States
    That's not the only issue. If you've ever taken your switch online after you made your clean nand backup Ninty has a records of your logs and telemetry. If you now restore your clean nand before all that none of that telemetry is going to match. Ban incoming.
     
    PHiLiPZ and lordelan like this.
  5. lordelan
    OP

    lordelan GBAtemp Psycho!

    Member
    11
    Jan 4, 2015
    Germany
    That's what I figured and I guess that's the risk I have to live with since I wasn't wise enough back then to do another backup after the last time I've been online. :(
    Guess I'll have to find out.
     
  6. eyeliner

    eyeliner Has an itch needing to be scratched.

    Member
    7
    Feb 17, 2006
    Portugal
    I update officially, so if Nintendo is able to know how one updates, at least I'm clear.
    Make the restore, update and hope for the best. I'm here for you, my friend.
     
    lordelan likes this.
  7. Garou

    Garou GBAtemp Maniac

    Member
    7
    Jan 13, 2015
    to answer your question, I haven't found cart with updates higher than 6.2.0
    even games that supposed to require higher firmware like MK11 still only has firmware 6.0.0 in the cart update partition, and I have no clue what will happen if someone with firmware below 7.0 plug the cart in and try to play the game. maybe it'll force a "this game requires day one update" thing, no idea
     
    lordelan likes this.
  8. lordelan
    OP

    lordelan GBAtemp Psycho!

    Member
    11
    Jan 4, 2015
    Germany
    I see. Thanks. So there's no way I could have updated offline past 6.0.0 but that's alright.
    I'm almost sure now I've been on 4.1 when I stopped going online so I have to try to restore my 3.0.0 NAND dump and update it with ChoiDujourNX to 4.1.0, then update the official Ninty way to most recent (8.1.0) and pray for not getting banned.

    Edit: The bad thing about this is ... I really want to subscribe to Ninty's online service but even if I'm not banned immediately I don't know how many weeks I would have to wait to be sure I won't get banned so I can subscribe. At least I can't ever be sure.
    Looks like the worst case would be having me burning 20 bucks.
     
    Last edited by lordelan, Jul 17, 2019
  9. fadx

    fadx Filthy Cheater

    Member
    6
    GBAtemp Patron
    fadx is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Sep 15, 2016
    United Kingdom
    I think you'll be okay (atleast I think the update its self wouldn't ban you). I updated officially then restored an old backup then updated officially again while in CFW using incorrect fuses so I'd be surprised if they take any of that stuff into consideration unless that's changed recently.
     
    lordelan likes this.
  10. lordelan
    OP

    lordelan GBAtemp Psycho!

    Member
    11
    Jan 4, 2015
    Germany
    You're raising my hopes buddy. ;)
     
  11. Garou

    Garou GBAtemp Maniac

    Member
    7
    Jan 13, 2015
    why not use cart to update to 4.1.0 if you really want to be safe by not running any homebrew
    I updated mine to 4.1.0 back in the day using mario tennis aces so that game should work
     
  12. lordelan
    OP

    lordelan GBAtemp Psycho!

    Member
    11
    Jan 4, 2015
    Germany
    Good point but I updated online from 3.0.0 to 4.1 back then and if they detect the way I used to update, it shouldn't matter whether I used a cartridge or homebrew as I'm doomed anyway since it's not online as back then. I can only hope they didn't log the way I updated but only logged that I actually updated. So if I'm again on 4.1 and go online from there I might be fine (or not, we'll see).
    Without any question I have to update to 4.1 at least since I'm almost sure Ninty would be wondering how I could go online with a 3.0.0 Switch after I updated it officially to 4.1 in the past. :D
     
  13. Garou

    Garou GBAtemp Maniac

    Member
    7
    Jan 13, 2015
    okay how about this
    update to firmware 5.0 or above using cart

    unless the system keeps history of its updates, then nintendo should have no issue with that. they won't ban users who updated to 4.1.0 online then update to 5.0 using cart
     
    lordelan likes this.
  14. lordelan
    OP

    lordelan GBAtemp Psycho!

    Member
    11
    Jan 4, 2015
    Germany
    Good point!
    Now I need to find someone with a copy of Mario Tennis. :)
     
  15. ZachyCatGames

    ZachyCatGames GBAtemp Advanced Maniac

    Member
    8
    Jun 19, 2018
    United States
    Hell
    Mario Maker 2 has 7.0.1 iirc
     
    Garou likes this.
  16. Garou

    Garou GBAtemp Maniac

    Member
    7
    Jan 13, 2015
    lol my bad. I was looking at the wrong files all these times :lol:
    mario maker 2 indeed is having 7.0.1 update
     
  17. lordelan
    OP

    lordelan GBAtemp Psycho!

    Member
    11
    Jan 4, 2015
    Germany
    Hi! Just wanted to let you guys know that I successfully created an emuNAND and restored my old 3.0.0 NAND backup.
    Since I'm almost sure I was on 4.1 the last time I went online I installed that FW with ChoiDujourNX since I updated my 3.0.0 that early that the cartridge controller firmware update thing wasn't even possible to avoid so I wasn't able to use cartridges in 3.0.0 (to update).
    From 4.1.0 I used Super Mario Party to update to 5.1.0, went online, connected to my Nintendo Account again (I hope Nintendo did not track that I was connected back then once and now needed to reconnect lol) and right now I'm downloading Fortnite which you can play without an online subscription.
    I'll play this from time to time just to see if a ban might hit me or not in the coming weeks and if not I guess I will go on and subscribe and have fun online. :)
    Thanks for all your help.
     
    hippy dave likes this.
  18. namad

    namad GBAtemp Regular

    Member
    2
    Sep 1, 2015
    United States
    Where are you guys seeing a list of which cartridges have which updates? I'm currently looking for a list of cartridges with 4.0.1 or 4.1.0 updates on them. I need to update from 3.0.1 (which my virgin console is on) in order to warmboot. It seems like something no else is interested in, but the only thing stopping me right now seems to be not knowing which cartridges have which of these specific very old firmwares. Thanks.

    edit:
    So is this the thread you guys are using?
    https://gbatemp.net/threads/list-games-required-firmware-version.485959/
    It seems like it hasn't been updated in a while?
    I assume though that this means.... any game which requires a specific firmware also contains the files to update to that firmware? so that people without internet aren't screwed? is this universally true for any cartridge with a firmware requirement? It almost sounds too easy to be true....
     
    Last edited by namad, Jul 30, 2019
  19. ZachyCatGames

    ZachyCatGames GBAtemp Advanced Maniac

    Member
    8
    Jun 19, 2018
    United States
    Hell
    I dump the sysupdate files from my cartridges and check the version number. And you should probably stay on 3.0.1
     
  20. namad

    namad GBAtemp Regular

    Member
    2
    Sep 1, 2015
    United States
    Happen to know of any cartridges that include an update to 4.0.1 or 4.1.0 specifically? I can't think of any from that era I'd actually want to play. I don't know why, but a pure warmboot solution appeals to me, even if costs me 1 fuse. Seems like 4.1.0 supports more exploits than 3.0.1 somehow, just from the exploits I've seen in the wild so far.
     
Loading...