Hexen 2 PSP 1.1 Issue

Discussion in 'PSP - Hacking & Homebrew' started by deathboy, May 23, 2013.

  1. deathboy
    OP

    deathboy Member

    Newcomer
    16
    0
    Aug 15, 2012
    United States
    I am trying to play Hexen 2 PSP Version 1.1 and when I reset, the control configuration I set up doesn't save. The next time I try to play it, I get key not bound errors and have to redo my setup. Any Ideas?

    PSP-2001 running 6.60 Pro-C2, btw.
     
  2. VatoLoco

    VatoLoco Don't crush that dwarf, hand me the pliers.

    Member
    2,267
    277
    Jan 29, 2008
    United States
    Ya Cant Get There From Here
    are you setting the controls in-game or editing the config.cfg via pc?
    its been a while but im certain i customized the controls for hexen 2.
    may not be your cup of tea as to how the buttons are set, but heres what my config looks like.

    Code:
    bind "TAB" "+showinfo"
    bind "ENTER" "invuse"
    bind "ESCAPE" "togglemenu"
    bind "SPACE" "+crouch"
    bind "'" "zoom_in"
    bind "+" "sizeup"
    bind "," "+moveleft"
    bind "-" "sizedown"
    bind "." "+moveright"
    bind "/" "+jump"
    bind "0" "impulse 0"
    bind "1" "impulse 1"
    bind "2" "impulse 2"
    bind "3" "impulse 3"
    bind "4" "impulse 4"
    bind "5" "impulse 5"
    bind "6" "impulse 6"
    bind "7" "impulse 7"
    bind "8" "impulse 8"
    bind ";" "+mlook"
    bind "=" "sizeup"
    bind "[" "invleft"
    bind "\" "impulse 44"
    bind "]" "invright"
    bind "`" "toggleconsole"
    bind "a" "+lookup"
    bind "c" "+movedown"
    bind "d" "+moveup"
    bind "q" "+showdm"
    bind "t" "messagemode"
    bind "z" "+lookdown"
    bind "~" "toggleconsole"
    bind "UPARROW" "+forward"
    bind "DOWNARROW" "+back"
    bind "LEFTARROW" "+left"
    bind "RIGHTARROW" "+right"
    bind "ALT" "+strafe"
    bind "CTRL" "+attack"
    bind "SHIFT" "+speed"
    bind "F1" "help"
    bind "F2" "menu_save"
    bind "F3" "menu_load"
    bind "F4" "menu_options"
    bind "F5" "menu_multiplayer"
    bind "F6" "echo Quicksaving...; wait; save quick"
    bind "F7" "demos"
    bind "F9" "echo Quickloading...; wait; load quick"
    bind "F10" "quit"
    bind "F12" "menu_keys"
    bind "INS" "+klook"
    bind "DEL" "+lookdown"
    bind "PGDN" "+lookup"
    bind "END" "centerview"
    bind "MOUSE1" "+attack"
    bind "MOUSE2" "+forward"
    bind "MOUSE3" "+mlook"
    bind "PAUSE" "pause"
    sys_delay "0"
    m_side "0.8"
    m_forward "1"
    m_yaw "0.022"
    m_pitch "0.022"
    sensitivity "3"
    lookstrafe "0"
    lookspring "0"
    cl_backspeed "200"
    cl_forwardspeed "200"
    _cl_playerclass "2.000000"
    _cl_color "0"
    _cl_name "player"
    dm_mode "1"
    leak_color "251"
    r_transwater "1"
    r_wholeframe "1"
    viewsize "100"
    _snd_mixahead "0.1"
    bgmtype "cd"
    bgmvolume "0"
    volume "0.7"
    _windowed_mouse "0"
    vid_stretch_by_2 "1"
    vid_config_y "600"
    vid_config_x "800"
    _vid_default_mode_win "3"
    _vid_default_mode "0"
    _vid_wait_override "0"
    vid_nopageflip "0"
    sv_sound_distance "800"
    _config_modem_hangup "AT H"
    _config_modem_init ""
    _config_modem_clear "ATZ"
    _config_modem_dialtype "T"
    _config_com_modem "1"
    _config_com_baud "57600"
    _config_com_irq "4"
    _config_com_port "0x3f8"
    max_temp_edicts "30"
    saved4 "0"
    saved3 "0"
    saved2 "0"
    saved1 "0"
    savedgamecfg "0"
    sys_adaptive "1"
    developer "0"
    sys_quake2 "1"
    gamma "1"
    crosshair "0"
     
  3. soundbuoy

    soundbuoy Newbie

    Newcomer
    4
    0
    Dec 4, 2007
    New Zealand
    Hi guys, old thread I know, and off topic slightly, but I'm running 6.60 pro c2 on a psp 3000, all fine with psx games, hexen, heretic and doom but I cant get hexen 2 to run. At all. I followed the guide that was for older cfw, (game150 folder etc), I have the 2 folders etc and thewads folder from my steam hexen 2 but nothing.
    Any tips, or links to useful and up to date guides?
    I have tried google and some forums, but this was the most promising result.
    Cheers
     
  4. TecXero

    TecXero Technovert

    Member
    2,814
    909
    Apr 13, 2014
    United States
    Mainframe
    Generally shouldn't dig up old threads, a new one would have sufficed, but I'm not a mod so it doesn't matter to me that much.

    Anyway, put it in the GAME folder instead of GAME150. I'm fairly certain newer firmwares don't try to access those directories, anyway. If it still doesn't work, you could try eLoader by N00bz. I haven't the slightest clue how well it'll work on newer firmwares.
     
  5. soundbuoy

    soundbuoy Newbie

    Newcomer
    4
    0
    Dec 4, 2007
    New Zealand
    Cheers dude, I tried game folder too, but I'll try eloader. If I get no luck I'll start a new thread.
    Bit of a noob at forums, been lurking and modding consoles for years but this is the first time the solution hasn't been really obvious to me with a few searches.
     
  6. TecXero

    TecXero Technovert

    Member
    2,814
    909
    Apr 13, 2014
    United States
    Mainframe
    With eLoader, I do believe you need Hexen in the GAME150 folder. Try both just to be sure. I haven't messed with the PSP's kernels or kernel loaders in a long time, so I'm not 100% sure which. If it doesn't work with eLoader at all, I can't really think of anything. There is downgrading, but on a 3000 model, I'm not sure how far you can downgrade or if it's even safe. 3000s tend to be a nightmare to work with for older homebrew. Good luck.
     
  7. VGA

    VGA Member

    Newcomer
    29
    2
    Mar 29, 2014
    Isn't there a mod of Hexen to make it run on the PS Vita ? I guess it works on PSPs, too.
     
  8. TecXero

    TecXero Technovert

    Member
    2,814
    909
    Apr 13, 2014
    United States
    Mainframe
    You might be able to run eLoader through the Vita's homebrew loader. I'm not entirely sure, I don't have a Vita yet so I haven't really looked at the homebrew for it.