Hacking Oldies Help with DK64 Wad injection

FrankBlack22

Member
OP
Newcomer
Joined
Aug 13, 2023
Messages
17
Trophies
0
Age
28
XP
90
Country
Canada
Hello everyone,

About a week ago, I've posted a help message on this tutorial page : (Since I can't post a link yet, here's the title instead)

How to use Single ROM Loaders for make your own Wii VC channels of your favorite retro games :D - Wii, by @SaulFabre, last updated on Oct 11, 2022 at 12:53 PM

Sadly, I had no luck getting a response so far, so I'm re-posting that message on a new thread just in case. Any help is appreciated. Also, feel free to ask for any missing detail.

Excuse-me @SaulFabre I've followed your tutorial to a T, but when I try to install the wad I created, I end up with this error:

Installing content #00...Error: (-1022) Content did not match hash in TMD. Try with AHBPROT mode or an IOS with the correct permissions.

I've read and re-read the instructions related to wad manipulation and can't figure out what I did wrong. The only thing I can see is that the base wad I used was somewhat wrong.

I've tried a wad named "Static Base" that had AHBPROT first from the repo you referenced, then I tried the snes vc wad you suggested in this thread's 16th message that has AHBPROT and IOS58. Both failed and gave the same problem. My WiiModLite is set to IOS58 as I've been installing some VC games lately. My DOL Forwarder is functional when booted directly from homebrew. The game I'm trying to install is DK64.

Any insight would be appreciated.
 
  • Like
Reactions: SaulFabre

SaulFabre

I like Yoshis and the Wii/Wii U scene.
Member
Joined
Feb 6, 2019
Messages
3,270
Trophies
2
Age
25
Location
Ecuador
Website
saulfabreg-wiivc.blogspot.com
XP
8,205
Country
Ecuador
Hello everyone,

About a week ago, I've posted a help message on this tutorial page : (Since I can't post a link yet, here's the title instead)

How to use Single ROM Loaders for make your own Wii VC channels of your favorite retro games :D - Wii, by @SaulFabre, last updated on Oct 11, 2022 at 12:53 PM

Sadly, I had no luck getting a response so far, so I'm re-posting that message on a new thread just in case. Any help is appreciated. Also, feel free to ask for any missing detail.

Excuse-me @SaulFabre I've followed your tutorial to a T, but when I try to install the wad I created, I end up with this error:

Installing content #00...Error: (-1022) Content did not match hash in TMD. Try with AHBPROT mode or an IOS with the correct permissions.

I've read and re-read the instructions related to wad manipulation and can't figure out what I did wrong. The only thing I can see is that the base wad I used was somewhat wrong.

I've tried a wad named "Static Base" that had AHBPROT first from the repo you referenced, then I tried the snes vc wad you suggested in this thread's 16th message that has AHBPROT and IOS58. Both failed and gave the same problem. My WiiModLite is set to IOS58 as I've been installing some VC games lately. My DOL Forwarder is functional when booted directly from homebrew. The game I'm trying to install is DK64.

Any insight would be appreciated.
Hi, sorry for not reading that in my thread. I sincerously dont know what is causing that but...
1. Did you enable AHBPROT to Wii Mod Lite? (add <ahb_access/> between <app> and </app> in Wii Mod Lite's meta.xml file)
2. Can you try using Multi-Mod Manager (MMM) or Some YAWMM Mod for see if this exact same issue occurs?
 
  • Like
Reactions: FrankBlack22

FrankBlack22

Member
OP
Newcomer
Joined
Aug 13, 2023
Messages
17
Trophies
0
Age
28
XP
90
Country
Canada
Hi, sorry for not reading that in my thread. I sincerously dont know what is causing that but...
1. Did you enable AHBPROT to Wii Mod Lite? (add <ahb_access/> between <app> and </app> in Wii Mod Lite's meta.xml file)
2. Can you try using Multi-Mod Manager (MMM) or Some YAWMM Mod for see if this exact same issue occurs?
Thank you for the reply, I'll try these solutions when I get back home and will feed you back on the outcomes.
Post automatically merged:

Hi, sorry for not reading that in my thread. I sincerously dont know what is causing that but...
1. Did you enable AHBPROT to Wii Mod Lite? (add <ahb_access/> between <app> and </app> in Wii Mod Lite's meta.xml file)
2. Can you try using Multi-Mod Manager (MMM) or Some YAWMM Mod for see if this exact same issue occurs?

Alright so, the <ahb_access/> tag was already in my WiiModLite's meta.xml file

I tried the other managers you suggested. This is their output:

Multi-Mod Manager :

Ticket (-2011)

(#) Final Status - 1 did not complete

YAWMM :

Installing content #00... ERROR! (ret = -1022)
Post automatically merged:

Thank you for the reply, I'll try these solutions when I get back home and will feed you back on the outcomes.
Post automatically merged:



Alright so, the <ahb_access/> tag was already in my WiiModLite's meta.xml file

I tried the other managers you suggested. This is their output:

Multi-Mod Manager :

Ticket (-2011)

(#) Final Status - 1 did not complete

YAWMM :

Installing content #00... ERROR! (ret = -1022)
Just in case my last update didn't ping you @SaulFabre
 
Last edited by FrankBlack22,
  • Like
Reactions: SaulFabre

SaulFabre

I like Yoshis and the Wii/Wii U scene.
Member
Joined
Feb 6, 2019
Messages
3,270
Trophies
2
Age
25
Location
Ecuador
Website
saulfabreg-wiivc.blogspot.com
XP
8,205
Country
Ecuador
Thank you for the reply, I'll try these solutions when I get back home and will feed you back on the outcomes.
Post automatically merged:



Alright so, the <ahb_access/> tag was already in my WiiModLite's meta.xml file

I tried the other managers you suggested. This is their output:

Multi-Mod Manager :

Ticket (-2011)

(#) Final Status - 1 did not complete

YAWMM :

Installing content #00... ERROR! (ret = -1022)
Post automatically merged:


Just in case my last update didn't ping you @SaulFabre
Maybe your WAD is corrupted... could you try making another forwarder WAD of your SRL for confirm that is the problem? :/
 
  • Like
Reactions: FrankBlack22

FrankBlack22

Member
OP
Newcomer
Joined
Aug 13, 2023
Messages
17
Trophies
0
Age
28
XP
90
Country
Canada
Maybe your WAD is corrupted... could you try making another forwarder WAD of your SRL for confirm that is the problem? :/
Alright. Here I am making my third attempt at doing this WAD. I will log every single step that I'm doing in this message. If you spot ANY mistake in those steps, make sure to tell me:

base wad => USB-Loader-GX-UNEO_Forwarder_5_1_AHBPROT-Wii.wad
original wii wad => Super Mario 64 (USA) (N64) (Virtual Console).wad

1 : I drag-dropped "original wii wad" onto "__wwunpacker.bat" and renamed the resulting folder "VC_banner_unpack"

2 : I drag-dropped "base wad" onto "__wwunpacker.bat" and renamed the resulting folder "base_WAD_SRL_unpack"

3 : I copy-pasted the 00000000.app file from "VC_banner_unpack" (mario 64) to "base_WAD_SRL_unpack"

4 : I deleted the "VC_banner_unpack" folder

5 : I drag-dropped the "base_WAD_SRL_unpack" folder onto "_wwpacker-NoMod.bat". I now have "base_WAD_SRL_unpack [NoMod].wad"

6 : I've opened CustomizeMii as an administrator.

7 : In the "Source Wad" box, I've selected "base_WAD_SRL_unpack [NoMod].wad"

8 : In the "Titles" tab, I erased the translations and typed "Donkey Kong 64" in the "All Languages" Box.

9 : In the "Options" tab. According to GameTDB, DK64's title id is NAAE, so I changed it for that. The IOS is already 58 by default.

10 : At "New DOL", I clicked "Browse" and I select the DOL file I named "sfg_n64_dk64" in my ModMii\COPY_TO_SD\DOLS folder

11 : For the "NAND Loader" option, I left "comex"

12 : In the "Banner" tab. I replaced the VCPic.tpl image for my DK64 screencapture. Format: RGBA8

13 : In the "Icon" tab. I replaced the IconVCPic.tpl image for my DK64 screencapture. Format: RGBA8

14 : In the "Layout" tab. I extracted "banner.brlyt"

15 : I run vcbrlyt.exe as an administrator and opened "banner.brlyt"

16 : I changed the name to "Donkey Kong 64", left the system as is, the number of players to 4, the year to 1999 and added the ESRB rating "Everyone with Mild Animated Violence" in ENG

17 : I clicked "Set All" and "Set" where applicable and then clicked "Save Changes"

18 : In CustomizeMii, I replace the old "banner.brlyt" with the new one.

19 : I clicked "Create WAD", then "Yes". I named the file "DonkeyKong64_N64_SRL_forwarder.wad"

20 : After closing CustomizeMii, I get ready to test this third wad on WiiModLite...

And... the same error occurred. Well, if you've spotted anything, tell me.
 
  • Like
Reactions: SaulFabre

SaulFabre

I like Yoshis and the Wii/Wii U scene.
Member
Joined
Feb 6, 2019
Messages
3,270
Trophies
2
Age
25
Location
Ecuador
Website
saulfabreg-wiivc.blogspot.com
XP
8,205
Country
Ecuador
added the ESRB rating "Everyone with Mild Animated Violence" in ENG
Maybe that is causing the problem, because you're saying that you were using Super Mario 64 banner. And SM64 Wii VC banner doesn't have ESRB rating text, so i think that's "corrupting" the brlyt and the WAD.

Do everything again but don't edit the ESRB rating text. :v
 
  • Like
Reactions: FrankBlack22

FrankBlack22

Member
OP
Newcomer
Joined
Aug 13, 2023
Messages
17
Trophies
0
Age
28
XP
90
Country
Canada
Maybe that is causing the problem, because you're saying that you were using Super Mario 64 banner. And SM64 Wii VC banner doesn't have ESRB rating text, so i think that's "corrupting" the brlyt and the WAD.

Do everything again but don't edit the ESRB rating text. :v
Unfortunately, it did not solve the issue. Welp... :/
I don't know if you intended to add DK64 to your wad repo? Cuz I think that's my only option left.

Thanks for the help anyways.
 
  • Like
Reactions: SaulFabre

Site & Scene News

Popular threads in this forum

General chit-chat
Help Users
  • K3Nv2 @ K3Nv2:
    He's drawing a line in the sand
  • Veho @ Veho:
    That makes it harder to snort.
  • Veho @ Veho:
    Can't he do a line on the table?
  • K3Nv2 @ K3Nv2:
    Are you against or for
  • Veho @ Veho:
    Coke? I'm all for it.
  • Veho @ Veho:
    Weird song. "Yeah use whatever pronoun you want but women are still bitches and whores. Also, midgets funny."
    +1
  • K3Nv2 @ K3Nv2:
    Psi will love that song
    +1
  • Veho @ Veho:
    Not gonna get psycho anal about his state of mind because I don't give a fuck.
  • Veho @ Veho:
    But like come up with some new material, you did this in the 90s.
  • K3Nv2 @ K3Nv2:
    He claims it's a concept album but I don't really get how it all lined up just what you'd expect
  • Veho @ Veho:
    Maybe it's just that, death of Slim Shady, birth of the new adult mature Marshall Mathers Whatever. Very concept, much
    meta.
    +1
  • K3Nv2 @ K3Nv2:
    Yeah the media stand point we miss his old material but shit on new songs so much it was just pretty mid
  • K3Nv2 @ K3Nv2:
    Few good singles kamikaze was still better imo
  • Psionic Roshambo @ Psionic Roshambo:
    He will wind up like Ice Cube selling depends and rolaids lol
  • Psionic Roshambo @ Psionic Roshambo:
    "I wear depends because my bladder leaks sending me off the deep end!!!"
  • Veho @ Veho:
    Better than ending up like Kid Rock who should be called Senile Grampa Cuntry now.
    +1
  • Veho @ Veho:
    "I'm still edgy!" Yeah yeah, time for your prune juice and pills.
    +1
  • K3Nv2 @ K3Nv2:
    Kid rock ft jelly roll I'm not old!
  • Psionic Roshambo @ Psionic Roshambo:
    My dentures are fake my joints ache my feet are cold I'm not old! Lol
  • K3Nv2 @ K3Nv2:
    Hold my budweiser
  • Psionic Roshambo @ Psionic Roshambo:
    Nursing home nursery rhyme, Eminem is running out of time!
  • Psionic Roshambo @ Psionic Roshambo:
    It's hard to rap when your dentures flap, make sure you use poly grip and don't confuse your preparation H with the gel that grips!
  • Psionic Roshambo @ Psionic Roshambo:
    Owe my hip
  • K3Nv2 @ K3Nv2:
    This is why Eminem got clean and shady didn't
    +1
  • K3Nv2 @ K3Nv2:
    He said mean awful things to me I need a new record
    +1
    K3Nv2 @ K3Nv2: He said mean awful things to me I need a new record +1