Help! Rxtools keeps getting blackscreen

Discussion in '3DS - Flashcards & Custom Firmwares' started by itai1996, Oct 11, 2015.

  1. itai1996
    OP

    itai1996 Member

    Newcomer
    45
    1
    Mar 13, 2010
    Iceland
    I have a N3DS XL firmware 9.0E I tried to update my rxtools I tried to install the firmware with BBM (tried with sysupdater and it failed too) after it finished it showed me 9.5.0-23 but after a reset I got black screen again when lauching rxTools with homebrew launcher. Is it because my rxTools might not be updated to the latest version? I have used this guide:
    https://gbatemp.net/threads/tutorial-how-to-install-a-cfw-on-a-9-0-9-2-n3ds-without-cn-oot.398394/
    What do I do? By the way, I have noticed that after I check my version with the settings (to make sure it runs on emunand) and after I exit,most of the time, it resets to my sysnand
     


  2. Quantumcat

    Quantumcat Dead and alive

    Member
    9,910
    5,229
    Nov 23, 2014
    Australia
    Canberra, Australia
    Not most of the time, all the time. This is expected behaviour. If you went into Settings then back out, and then tried to update, you will have updated your sysNAND.
     
    Last edited by Quantumcat, Oct 11, 2015
  3. itai1996
    OP

    itai1996 Member

    Newcomer
    45
    1
    Mar 13, 2010
    Iceland
    Oh I see. Do you have an answer for the "always brick problem" :/
     
  4. Quantumcat

    Quantumcat Dead and alive

    Member
    9,910
    5,229
    Nov 23, 2014
    Australia
    Canberra, Australia
    No I don't sorry :-( check your settings when in sysNAND though and double check you didn't update it. If you didn't, then I'm not sure what the problem is but hopefully somebody will help you out.
     
  5. itai1996
    OP

    itai1996 Member

    Newcomer
    45
    1
    Mar 13, 2010
    Iceland
    No. My sysnand is fine I am making sure that I update emunand.
     
  6. Quantumcat

    Quantumcat Dead and alive

    Member
    9,910
    5,229
    Nov 23, 2014
    Australia
    Canberra, Australia
    I have noticed a few other people having similar problems to you - it might be related to themehax. Have a look round the forum. When I get home I'll find the threads and tag you in them if you haven't replied to them already.
     
  7. itai1996
    OP

    itai1996 Member

    Newcomer
    45
    1
    Mar 13, 2010
    Iceland
    Thanks that would be great :)
     
  8. bluke

    bluke GBAtemp Regular

    Member
    107
    21
    Feb 2, 2010
    You have N3DS so you need to do this : Go to [Drive]:\rxTools\data\ and delete 0004013820000002.bin leave 0004013820000002orig.bin
    Then I think your problem will be fix. It not go to rxtools/sys and delete firmware.bin also.
     
  9. itai1996
    OP

    itai1996 Member

    Newcomer
    45
    1
    Mar 13, 2010
    Iceland
    What do you mean? I've got only one file there which is 0004013820000002orig.bin after I've changed the file name from firmware.bin (that I got from Reinand 2.1)
     
  10. -Xin-

    -Xin- Advanced Member

    Newcomer
    70
    12
    Jul 26, 2015
    Macau
    i think it's because brahma isn't implemented in themhax
     
  11. bluke

    bluke GBAtemp Regular

    Member
    107
    21
    Feb 2, 2010
    Do you check MD5 Hash of Firmware.bin is it exact with "006559E2567DC7DF6C0F1AF17EDD9CE8". Or tried to install rxTools again.
     
  12. itai1996
    OP

    itai1996 Member

    Newcomer
    45
    1
    Mar 13, 2010
    Iceland
    I have no idea what is the MD5 Hash.
    And I formatted like 4 times already :/
     
  13. itai1996
    OP

    itai1996 Member

    Newcomer
    45
    1
    Mar 13, 2010
    Iceland
    Anyone can help me? Or I'm lost?
     
  14. Neptune

    Neptune GBAtemp Advanced Maniac

    Member
    1,588
    531
    Dec 7, 2003
    United States
    Internet
    You screwed up by updating emunand while using themehax. You should have booted into emunand then factory reset the emunand to separate them. You have to restore an older emunand to your SD card to boot (or disable themehax by changing your theme)
     
  15. VerseHell

    VerseHell GBAtemp Psycho!

    Member
    3,067
    1,067
    Jun 29, 2014
    France
    He need to format his sysnand, not his emunand, or he will have no way to install a cia manager on it.
     
  16. itai1996
    OP

    itai1996 Member

    Newcomer
    45
    1
    Mar 13, 2010
    Iceland
    So what do I need to do? I will start over everything when I get home (or I don't need to?). At what stage do I need to update then? Before installing themehax?
     
  17. 75mak

    75mak GBAtemp Fan

    Member
    389
    111
    Nov 10, 2011
    I did the same thing on one old3ds. Just boot into sysnand, change theme.

    Then boot into rxtools however you do.
     
  18. itai1996
    OP

    itai1996 Member

    Newcomer
    45
    1
    Mar 13, 2010
    Iceland
    But I need themehax. I don't have a wifi connection available at all time I am usually not at home so how will I manage to boot my rxtools?
     
  19. VerseHell

    VerseHell GBAtemp Psycho!

    Member
    3,067
    1,067
    Jun 29, 2014
    France
    Uninstall themehax, unlink your nands, reinstall themehax. You are not supposed to use themehax with linked nands.
     
  20. itai1996
    OP

    itai1996 Member

    Newcomer
    45
    1
    Mar 13, 2010
    Iceland
    How do I know whether they are linked or not? And how do I unlink them?