[Help] ezshare SD can only read .htm not .html?

Discussion in 'Wii U - Hacking & Backup Loaders' started by [^Blark^], Apr 23, 2016.

  1. [^Blark^]
    OP

    [^Blark^] GBAtemp Fan

    Member
    465
    131
    Dec 19, 2012
    United States
    Ok so I recently purchased a ezshareSD card. I bought an 8GB with an on and off switch. not the microSDadapter adapter. I was planning to selfhost files since before ordering many have stated it's worked great for them. so I figured I'd try it out to keep my WiiU off the grid. but I can't run payloads or index files due to the card not being able to handle 4 letter enxtensions is my guess based on what I found out below last night after hours of mind boggling attempts and still nothing.


    I can't load anything with the extension .html without being redirected to the ez cards GUI.
    (so I can't run homebrew launcher or any self hosted .html files)

    However if I rename payloads or index's to "××××××.htm" it will load the page /payload normally but if I choose a hack like the osdriver-aio from the homebru menu from the defenitive wiiu pack it will redirect to that stupid UI to transfer pics. so again clarification if I change the index.html to index.htm it loads the page but goes no further. I get redirected if I choose or a hack or use homebrew launcher. either way nothing is working100%

    I've tried using homebrew launcher but got the same issue. I try changing the index from "index.html" to "index.htm" I browse to

    ezshare.card/index.htm (not html)
    it says detected wiiu firmware 5.3.2
    (so it successfully loaded the .htm)

    then when trying to load next file or whatever the exploits trying to do it cant. and I get redirected to the GUI. all because the card cant except .HTML ( 4 letter extensions) I think it's looking for a .html to load which it cant so in return I get redirected as the card doesn't know what to load or can't load it.

    and I also changed the .html extensions to .htm inside the .index files so it's looking for .htm not .html

    #CARD info#
    ------------------------
    my ezshare is the non microSD it's just the 8GB SD with the on and off switch but both should do the samething ones just an adapter to put in microsd and the other ones for if you don't plan to buy micro sd and just prefer the one card. maybe I'm wrong and that's why this won't work. as the "microsd" has been confirmed but this one hasn't? but I thought they both are ezshare WiFi cards so why should that matter if I buy the adapter or not.

    I'm afraid to waste money now and have a toshiba air 1 2 3 or ezshare microsd adapter have the same outcome and not be able to load .html files

    Idk why some users have had success while I can't load .html files but have no problem with .htm and changing the .html to .htm doesn't work.

    any help will be appreciated in advance.

    Thanks
    (I'm losing my mind I just wanna self host already.... and routers/blocking updates out of question with my setup as the router doesn't allow blocking unless I use open DNS as a partner... and I think NOT haha)
     
  2. CableLeecher

    CableLeecher 640K ought to be enough for anyone

    Member
    158
    137
    Feb 15, 2016
    Gambia, The
    EARTH | SOL-SYSTEM | SECTOR 001 | ALPHA QUADRANT
    works here without any problem with .html

    Never heared of anyone who has the same issue as you, sorry.
     
    KiiWii likes this.
  3. KiiWii

    KiiWii GBAtemp Psycho!

    Member
    3,869
    1,391
    Nov 17, 2008
    United Kingdom
    Mine works as HTML fine.

    Dunno whats happening with yours mate.

    EDIT @CableLeecher I'm going to update again the HBL (1.2 RC1) and nightly loadiine_gx2_251fcc6.zip. I will post up links when its sorted.
     
    Last edited by KiiWii, Apr 23, 2016
  4. [^Blark^]
    OP

    [^Blark^] GBAtemp Fan

    Member
    465
    131
    Dec 19, 2012
    United States
    The only other thing I can think of is the generation of my card.

    mine says it's the 2nd generation and has
    v2.2b in the bottom left corner. possibly something ezshare did differently with the new cards?

    can either of you guys test your card by typeing ez into the web browser and see if the file loaded ends with html or htm the file should be "welcome.xxxx" I just wanna see if your cards are loading an .htm or .html in the ezshare software gui.

    Here's a Picture of the one I have:
    Warning: Spoilers inside!
     
  5. KiiWii

    KiiWii GBAtemp Psycho!

    Member
    3,869
    1,391
    Nov 17, 2008
    United Kingdom
    Mine says .html
     
  6. [^Blark^]
    OP

    [^Blark^] GBAtemp Fan

    Member
    465
    131
    Dec 19, 2012
    United States
    mines .htm

    appreciate the help :)

    so I guess different firms on our cards and generation differences. I'm going to order a different card. probably just order that one from the link from the other thread that's confirmed working.

    thanks again.
     
    KiiWii likes this.
  7. worm28

    worm28 GBAtemp Advanced Fan

    Member
    702
    131
    Jun 2, 2013
    United States
    I had a an issue like that using xampp i fixed it by deleting cookies and resetting save data in the internet browser settings.