HDD not recognized by USB Loader,

Discussion in 'Wii - Hacking' started by SpaceJump, Apr 11, 2009.

Apr 11, 2009
  1. SpaceJump
    OP

    Member SpaceJump Where's my new 2D-Metroid?

    Joined:
    Aug 18, 2005
    Messages:
    3,648
    Location:
    Zebes
    Country:
    Germany
    I have an 1TB Fujitsu-Siemens HDD partitioned with 850GB and 150GB (approx.). I formated the 150GB partition with WBFS Manager without problem. I can add games with it to the WBFS partition. But when I hook the HDD to the Wii and launch USB Loader, it doesn't recognize the HDD. I used the same method for my 1,5TB Maxtor HDD and that worked.

    Any idea?
     
  2. FenrirWolf

    Member FenrirWolf GBAtemp Psycho!

    Joined:
    Nov 19, 2008
    Messages:
    4,343
    Location:
    Beaverton, OR
    Country:
    United States
    Have you tried using the Wii to format it instead?
     
  3. SpaceJump
    OP

    Member SpaceJump Where's my new 2D-Metroid?

    Joined:
    Aug 18, 2005
    Messages:
    3,648
    Location:
    Zebes
    Country:
    Germany
    As I said, the USB Loader doesn't seem to find the HDD at all.
     
  4. wchill

    Member wchill Resident chillxpert

    Joined:
    Jun 12, 2008
    Messages:
    1,407
    Country:
    United States
    The Wii only works with some USB devices at the moment.
    It makes sense that your PC can recognize the drive, since PCs use these drives.
    The Wii wasn't designed for USB I/O and such, so support is limited.
     
  5. FenrirWolf

    Member FenrirWolf GBAtemp Psycho!

    Joined:
    Nov 19, 2008
    Messages:
    4,343
    Location:
    Beaverton, OR
    Country:
    United States
    I mean to say you should format the partition to FAT32 or NTSC or whatever from your PC, then use the Wii to format it to WBFS. After that, see if your PC can detect it.
     
  6. SpaceJump
    OP

    Member SpaceJump Where's my new 2D-Metroid?

    Joined:
    Aug 18, 2005
    Messages:
    3,648
    Location:
    Zebes
    Country:
    Germany
    Tried formating with USB Loader with no luck (same as with formating with WBFS tools):

    Error: Could not initialize USB subsystem! (ret = -1).

    There's actually a Western Digital WDC WD10 EAVS in the Fujitsu-Siemens. Aren't WD HDDs supposed to work with USB Loader?
     
  7. FenrirWolf

    Member FenrirWolf GBAtemp Psycho!

    Joined:
    Nov 19, 2008
    Messages:
    4,343
    Location:
    Beaverton, OR
    Country:
    United States
    In truth, almost any drive will work with the loader. The problem is with the enclosure and not the hard disk.
     
  8. SpaceJump
    OP

    Member SpaceJump Where's my new 2D-Metroid?

    Joined:
    Aug 18, 2005
    Messages:
    3,648
    Location:
    Zebes
    Country:
    Germany
    So is there anything I can do to make it work?
     
  9. Predator04

    Newcomer Predator04 Advanced Member

    Joined:
    Oct 17, 2007
    Messages:
    74
    Country:
    United States
    stupid question but did u install the cios ver9? not sure the exact name but try install/reinstalling that. does ur hdd use a external power source?
     
  10. frankomio

    Newcomer frankomio Member

    Joined:
    Apr 9, 2009
    Messages:
    33
    Country:
    Germany
    @spacejump

    try the usbloader from LoPST,
    there ist a better version to initialize the hdd (my opinion, and experience)

    i implemented this routine in every loader i tested , and find it always better
     
  11. hanshansaen

    Newcomer hanshansaen Newbie

    Joined:
    Apr 11, 2009
    Messages:
    2
    Country:
    Germany
    I have tested a FujitsuSiemens Siemens Storagebird 1000GB and it was recognized and works well.

    I created 2 partitions with GParted (Ubuntu) as FAT32 and converted one of them with the wii to wbfs and it works nearly perfect.
    Sometimes I got the same error (ret-1 could not initialize...), but trying again and again helped so far.
     
  12. SpaceJump
    OP

    Member SpaceJump Where's my new 2D-Metroid?

    Joined:
    Aug 18, 2005
    Messages:
    3,648
    Location:
    Zebes
    Country:
    Germany
    Can you give me a link to the LoPST version?

    Btw, of course cIOS36 rev9 is installed on my Wii. My Maxtor 1,5TB works flawlessly with it.
     
  13. giantpune

    Member giantpune GBAtemp Addict

    Joined:
    Apr 10, 2009
    Messages:
    2,860
    Country:
    United States
    I had the same issue with my 1TB HDD. Here's how I fixed it...
    1 Backup everything from the big NTFS partition.
    2 Erase and delete both partitions
    3 I used Vista's tool to create a fat partition first (assign a drive letter), then the NTFS
    4 Put all your data back on the NTFS
    5 Use the Wii to format the WBFS partition
     
  14. manias

    Member manias GBAtemp Maniac

    Joined:
    Aug 7, 2007
    Messages:
    1,258
    Country:
    Netherlands
  15. SpaceJump
    OP

    Member SpaceJump Where's my new 2D-Metroid?

    Joined:
    Aug 18, 2005
    Messages:
    3,648
    Location:
    Zebes
    Country:
    Germany
    I got it to sometimes work with Lopst and WiiShizza's versions. The problem is that the HDD seems to be recognized very slowly, so WiiShizza's loader cannot find it first, so the screen writings turn red and no covers are shown. Any idea how to fix this?

    Edit: And can anyone give me a working link to Lopst Edition 2? This doesn't work.
     
  16. frankomio

    Newcomer frankomio Member

    Joined:
    Apr 9, 2009
    Messages:
    33
    Country:
    Germany
    @spacejump: maybe this works ? LOPST


    and here ist the code, that i ALWAYS inserted in other usbloaders for my HDD:
    (this worked best for me , cause my platinum mydrive 320GB needs ~15 sec. :-( )

    CODEs32 WBFS_Init(void)
    {
    ÂÂÂÂs32 ret;
    ÂÂÂÂint i=0;
    ÂÂÂÂprintf("\nPlease insert USB device.\n");
    ÂÂÂÂprintf("ÂÂ (try to connect and disconnect USB)\n");
    ÂÂÂÂprintf("\nTrying to load USB (delay 40 sec. max.)");
    ir:
    ÂÂÂÂi++;
    ÂÂÂÂprintf(">");
    //ÂÂÂÂsleep(1);
    ÂÂÂÂret = IOS_ReloadIOS(249);
    //ÂÂÂÂsleep(5);
    ÂÂÂÂ/* Initialize USB storage */
    ÂÂÂÂret = USBStorage_Init();
    ÂÂÂÂif (i==40)
    ÂÂÂÂ{
    ÂÂÂÂÂÂÂÂWpad_Init();
    ÂÂÂÂÂÂÂÂprintf("\n No USB device.\n\n");
    ÂÂÂÂÂÂÂÂ/* Restart */
    ÂÂÂÂÂÂÂÂRestart_Wait();
    ÂÂÂÂ}
    ÂÂÂÂif (ret < 0)
    ÂÂÂÂÂÂÂÂgoto ir;
    //ÂÂÂÂÂÂÂÂreturn ret;


    ÂÂÂÂWpad_Init();
    ÂÂÂÂ

    ÂÂÂÂ/* Get USB capacity */
    ÂÂÂÂnb_sectors = USBStorage_GetCapacity(&sector_size);
    ÂÂÂÂif (!nb_sectors)
    ÂÂÂÂÂÂÂÂreturn -1;

    ÂÂÂÂreturn 0;
    }
     
  17. SpaceJump
    OP

    Member SpaceJump Where's my new 2D-Metroid?

    Joined:
    Aug 18, 2005
    Messages:
    3,648
    Location:
    Zebes
    Country:
    Germany
    frankomio, can you compile me a dol with that code snippet included?
     
  18. rooskie54

    Member rooskie54 GBAtemp Regular

    Joined:
    Jan 4, 2009
    Messages:
    282
    Country:
    United States
    I'd be interested in one as well.
     
  19. roswellian

    Newcomer roswellian Member

    Joined:
    Apr 2, 2009
    Messages:
    11
    Country:
    United States
    same thing happened here...it would be great to see above code compiled in.
     
  20. frankomio

    Newcomer frankomio Member

    Joined:
    Apr 9, 2009
    Messages:
    33
    Country:
    Germany
    boot.dol with hdd timeout from lopst


    here´s the version of an usb loader with the source from lobst with longer hdd timeout

    the original coder for the loader was BRISMA & SORG
     

Share This Page