hardware/sofeware help

Discussion in 'R4 DS' started by anwa, Mar 17, 2009.

  1. anwa
    OP

    anwa Newbie

    Newcomer
    3
    0
    Mar 17, 2009
    United States
    The story:

    I got my R4 Revolution like 2-3 years back. the system file on the microSD has a 2007 date. =P

    Lately, I got a bunch of ROM for the latest game, and it start giving me errors like data file not found, etc. So I decided to do a few google searches and see what I can do about it. (this is how I find this forum btw.)

    lord and behold, I read instructions like upgrading to 1.18 (I have no clue what version I am on to begin with), downloading the cheats, etc. But upon turning on my NDS, the R4 tells me something like the hardware isnt compatible with the sofeware in chinese.


    Question: How do I find out what I actually bought a few years back. and determine the correct way to fix the problem at hand, so I can play the games I gotten recently?

    Thanks for any help. and sorry for the very open ended question.
     
  2. tedmg09130913

    tedmg09130913 GBAtemp Regular

    Member
    215
    0
    Aug 23, 2007
    United States
  3. Eternity`

    Eternity` GBAtemp Regular

    Member
    107
    0
    Feb 14, 2009
    Netherlands
    Holland
    What tedmg09130913 is trying to say; the r4ds team is disbanded. One of the reasons was because all the fakes/clones so the last firmware version is allready 1 year old. Wich means the 'newer' games wont work on it. You can try YSMenu instead as its a firmware replacement for your card. YSMenu is getting updates wich means those games work on the r4. If you whant to use the official firmware with the newer games you have to manually Arm7 patch them.

    Hope that made some things clear.

    -Eternity

    Posts merged

    What tedmg09130913 is trying to say; the r4ds team is disbanded. One of the reasons was because all the fakes/clones so the last firmware version is allready 1 year old. Wich means the 'newer' games wont work on it. You can try YSMenu instead as its a firmware replacement for your card. YSMenu is getting updates wich means those games work on the r4. If you whant to use the official firmware with the newer games you have to manually Arm7 patch them.

    Hope that made some things clear.

    -Eternity
     
  4. anwa
    OP

    anwa Newbie

    Newcomer
    3
    0
    Mar 17, 2009
    United States
    thanks. i will try it out. come back if i cant figure out how to get ysmenu working. =)
     
  5. anwa
    OP

    anwa Newbie

    Newcomer
    3
    0
    Mar 17, 2009
    United States
    wohoooo!! work like a charm. tks for the link!! and tks to the person who made the batch file. =)
     
  6. Eternity`

    Eternity` GBAtemp Regular

    Member
    107
    0
    Feb 14, 2009
    Netherlands
    Holland
    Glad to hear you fixed it, you just revived your r4ds [​IMG]

    -Eternity
     
  7. Speelectronics.n

    Speelectronics.n Newbie

    Newcomer
    2
    0
    Mar 18, 2009
    Netherlands
    You may also try the 1.19 version from www.r4team.com

    This supports even the newer games, 1.18 doesn't

    Only downside is that the reset doesn't work, makes your DS hang up