Getting reF00D errors? Possibly Enso at fault?

Discussion in 'PS Vita - Hacking & Homebrew' started by Dave_Chad, May 7, 2019.

  1. Dave_Chad
    OP

    Dave_Chad GBAtemp Advanced Fan

    Member
    7
    Jun 29, 2016
    Ok this may be a bit of a long post but worth reading if you have reF00D errors you simply cannot fix.

    So first info is i have two Vitas here,

    Vita 1:

    Starts life on 3.18,
    updated to 3.60,
    ran henkaku.xyz/go,
    ran TheFlows 365 enso updater.
    Installed gamesd, nonpdrm, reF00D and shellbat.
    Runs a 3.69 game from PKGj perfectly.

    Vita 2:

    Starts life on 3.70,
    Trinity Exploited,
    downgraded to 3.65,
    ran h-encore,
    installed enso.
    Installed gamesd, nonpdrm, reF00D and shellbat.
    Errors on all 3.66+ games.

    Now i compared config from Vita 1 and Vita 2, they had slight differences so i made Vita 2 match Vita 1 perfectly. Still errors on the games. So now i have an idea i save the config because i KNOW it is right. I start my plan,

    Vita 2 take 2:

    Uninstall enso,
    Run h-encore,
    Downgrade to 3.60,
    ran henkaku.xyz/go,
    ran TheFlows365 enso updater.
    Copied my config back into ur0:tai.
    Runs a 3.69 game from PKGj perfectly.

    Please note in all instances i ALWAYS delete ux0:tai folders, i always run all plugins from ur0:tai.

    Summary?

    I think the installed files and configs must differ between 3.65 enso and the 3.65 enso updater. The other plugins worked all except for reF00D... Not sure if enso or reF00D is to blame but i got it to work int he end.

    EDIT: I'm now wondering if there is any difference these days between 3.60 and 3.65 maybe i should avoid the issue altogether with just downgrading straight to 3.60?
     
    Last edited by Dave_Chad, May 7, 2019
  2. reddragon105

    reddragon105 GBAtemp Regular

    Member
    4
    Aug 10, 2008
    I had a few Vitas on 3.70 that I kept around waiting for the new exploit, so today I downgraded them all basically using the method you describe for VIta 2 (take 1) there - run Trinity, use modoru to downgrade to 3.65, then install Henkaku and Enso and a few plugins, including reF00D. None of them are having any problems running 3.65+ games. I'm definitely using reF00D as I haven't downloaded any patched files for rePatch.

    What are the errors you're getting exactly? Are the games just not launching, or is it an error while running the games? I.e. what would I have to do to reproduce the errors.

    And are you having this problem with just one game in particular or have you tried multiple 3.65+ games?
     
  3. kaymynd

    kaymynd GBAtemp Advanced Fan

    Member
    5
    Sep 19, 2018
    United States
    I think the issue is caused by gamesd, use storagemgr instead.
    And theres not much difference other than 3.60 has more homebrew compatibility than 3.65.
     
  4. Dave_Chad
    OP

    Dave_Chad GBAtemp Advanced Fan

    Member
    7
    Jun 29, 2016
    Hmm very odd. The error is C1-6703-6. I get the error once then if i try the same game again or another i get a reboot.

    I tried multiple 3.65+ games one of which was the same on both test systems... I'm hopefully doing another Vita on 3.70 for a friend from work soon so i'll see if i can reproduce with another now.
     
    Last edited by Dave_Chad, May 8, 2019
  5. reddragon105

    reddragon105 GBAtemp Regular

    Member
    4
    Aug 10, 2008
    So you had one game that didn't work on either Vita?

    I'm going to reiterate kaymynd's advice and say try using storagemgr instead of gamesd.
     
  6. Dave_Chad
    OP

    Dave_Chad GBAtemp Advanced Fan

    Member
    7
    Jun 29, 2016
    No I have 1 game that worked on Vita 1. I have 2 that didn't work on Vita 2. One of which definitely worked on Vita 1.

    I'm not a fan of storage manager... I prefer a simple plugin with no configurations. Didn't storage manager have issues with sleep etc?

    Sent from my VOG-L09/Huawei P30 Pro
     
  7. kaymynd

    kaymynd GBAtemp Advanced Fan

    Member
    5
    Sep 19, 2018
    United States
    From what i recall storagemgr has fixed that issue and it is actually recommend over any of the other storage plugins due to it having more storage options and config is easy if you use autoplugin app to config.
    You can always just try to see if it helps, but your choice if you would like to stay using gamesd as well.
     
  8. Dave_Chad
    OP

    Dave_Chad GBAtemp Advanced Fan

    Member
    7
    Jun 29, 2016
    I appreciate all the suggestions so far and I'll test with the next 3.70 Vita I do as I'm curious if it was a one off bug or something I can reproduce...

    I'll look into storage manager again however I'm not a fan of plugin installers etc I prefer to manually do them :)

    Sent from my VOG-L09/Huawei P30 Pro
     
    kaymynd likes this.
  9. Madridi

    Madridi Card Collector

    Member
    10
    May 9, 2008
    Qatar
    Doha
    Post your config. Maybe we can spot something
     
    Last edited by Madridi, May 9, 2019
  10. reddragon105

    reddragon105 GBAtemp Regular

    Member
    4
    Aug 10, 2008
    Both gamesd and storagemgr had issues with sleep. Both fixed the issue within days of each other.

    Configuration for storagemgr is a simple .txt file but it gives you complete control over where each storage device is mounted.

    So you would have a file called storage_config.txt in your tai folder, alongside storagemgr.skprx, and it would have two lines in it like this -

    GCD=ux0
    MCD=uma0

    Which basically means anything in the gamecard slot would get mounted as ux0: (making an SD2Vita look like an official memory card) and then anything in the official memory card slot would get mounted as uma0: (USB mass storage), so if you have both an SD2Vita and official memory card you could still access the official memory card and use it as extra storage. If you have a Slim Vita you could add a third line that says 'INT=imc0' to mount the 1gb internal storage as imc0:

    So obviously you could change those lines to whatever you want, and the great thing is, if you did have it set up that way, but you took the SD2Vita out and rebooted, the official memory card would then be mounted as ux0: automatically, so you could access that as a 'proper' memory card, but then if you put the SD2Vita back in that would take priority as ux); and the official memory card would go back to uma0: - all without you having to change the config. So it's basically a case of set it and forget it.

    I'd definitely recommend it over gamesd - and if you're having issues it's definitely something you should try, at least to eliminate gamesd as the cause of the problem.
     
    kaymynd likes this.
  11. drake2oo0

    drake2oo0 Newbie

    Newcomer
    1
    Jan 10, 2008
    Canada
    i had the same issue make sure the keys.bin is in the same folder as reF00D.skprx i would post a link but im new just google the github page to find it or just use autoplugin
     
  12. remlei

    remlei GBAtemp Regular

    Member
    2
    Mar 26, 2013
    not sure about this, it works fine to me.

    I downgraded a lot of psv lately, all of them downgraded to 3.60 and install the 3 necessary plugins (sd2vita, nonpdrm and ref00d) using autoplugin, all works fine, tested it with 3.60+ games like Secret of Mana.
     
Quick Reply
Draft saved Draft deleted
Loading...