Genesis Plus GX not working

Discussion in 'Wii - Emulation and Homebrew' started by geordan, Sep 27, 2011.

Sep 27, 2011

Genesis Plus GX not working by geordan at 11:00 PM (3,058 Views / 0 Likes) 6 replies

  1. geordan
    OP

    Newcomer geordan Newbie

    Joined:
    Jan 15, 2004
    Messages:
    3
    Country:
    United Kingdom
    Hi, having had a modded Wii for about 2 weeks now, I've noticed a constant fail, which is that certain emulators and Virtual Console games aren't loading up, but instead lead to a black screen with no response from the controller.

    I've checked all the IOS and seemingly no problem there, I've also read countless topics based on video output interlacing issues, but it's not that either (as my Wii just locks up fully)

    Also, my SNES emulator works fine, and my N64 Emulator works fine, the problem is primarily in loading Genplus GX, however it happens with Brawl's Masterpeice games too, leading me to believe it's something more than that! Below I have listed a SysCheck report.

    I hope this problem is fixable, and I appreciate all help I receive, thank you!


    sysCheck v2.1.0b13 by Double_A and R2-D2199...runs on IOS58 (rev 6175).


    Region: PAL
    System Menu 4.0/4.1E (v54450)
    Priilaoder installed
    Homebrew Channel 1.0.8 running on IOS58
    Hollywood v0x11
    Console ID: 85671440
    Boot2 v4
    Found 77 titles.
    Found 52 IOS on this console. 6 of them are stub.


    IOS3 (rev 65280): Stub
    IOS4 (rev 65280): Stub
    IOS9 (rev 54321): Trucha Bug
    IOS10 (rev 768): Stub
    IOS11 (rev 54321): Trucha Bug
    IOS12 (rev 525): No Patches
    IOS13 (rev 1031): No Patches
    IOS14 (rev 1031): No Patches
    IOS15 (rev 1031): No Patches
    IOS16 (rev 54321): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS17 (rev 1031): No Patches
    IOS20 (rev 54321): Trucha Bug
    IOS21 (rev 1038): No Patches
    IOS22 (rev 1293): No Patches
    IOS28 (rev 1806): No Patches
    IOS30 (rev 54321): Trucha Bug
    IOS31 (rev 3607): No Patches
    IOS33 (rev 3607): No Patches
    IOS34 (rev 3607): No Patches
    IOS35 (rev 3607): No Patches
    IOS36 (rev 54321): Trucha Bug, ES Identify, NAND Access
    IOS37 (rev 5662): No Patches
    IOS38 (rev 4123): No Patches
    IOS40 (rev 3072): Stub
    IOS41 (rev 3606): No Patches
    IOS43 (rev 3606): No Patches
    IOS45 (rev 3606): No Patches
    IOS46 (rev 3606): No Patches
    IOS48 (rev 4123): No Patches
    IOS50 (rev 54321): Trucha Bug
    IOS51 (rev 4864): Stub
    IOS52 (rev 5888): Stub
    IOS53 (rev 5662): No Patches
    IOS55 (rev 5662): No Patches
    IOS56 (rev 5661): No Patches
    IOS57 (rev 5918): No Patches
    IOS58 (rev 6175): USB 2.0
    IOS60 (rev 54321): Trucha Bug
    IOS61 (rev 5661): No Patches
    IOS70 (rev 54321): Trucha Bug
    IOS80 (rev 54321): Trucha Bug
    IOS90 (rev 54321): Trucha Bug
    IOS202[60] (rev 65535, Info: hermes-v5.1): Trucha Bug, NAND Access, USB 2.0
    IOS222[38] (rev 65535, Info: hermes-v4.0): Trucha Bug, ES Identify, NAND Access, USB 2.0
    IOS223[38] (rev 65535, Info: hermes-v4.0): Trucha Bug, ES Identify, NAND Access, USB 2.0
    IOS224[57] (rev 65535, Info: hermes-v5.1): Trucha Bug, NAND Access, USB 2.0
    IOS236 (rev 54321): Trucha Bug, ES Identify, NAND Access
    IOS247[37] (rev 21006, Info: d2x-v6): Trucha Bug, NAND Access, USB 2.0
    IOS248[56] (rev 21006, Info: d2x-v6): Trucha Bug, NAND Access, USB 2.0
    IOS249[38] (rev 21006, Info: d2x-v6): Trucha Bug, ES Identify, NAND Access
    IOS250[57] (rev 21006, Info: d2x-v6): Trucha Bug, NAND Access, USB 2.0
    IOS254 (rev 65281): BootMii
    BC v6
    MIOS v10
     
  2. Jacobeian

    Member Jacobeian GBAtemp Advanced Maniac

    Joined:
    May 15, 2008
    Messages:
    1,879
    Country:
    Cuba
    What are you using to load emulators ? HBC ? forwarder channels ?
    From USB ? SD ?

    I don't think emulators rely on a specific IOS (at least, last versions) so it's probably not an issue with your system, much like a corrupted or missing dol
     
  3. geordan
    OP

    Newcomer geordan Newbie

    Joined:
    Jan 15, 2004
    Messages:
    3
    Country:
    United Kingdom
    Hi, I'm using the HBC to load the emulators, and using my SD card to boot them so I'm figuring that it should just work fine, having not really had much trouble booting things through HBC previously

    Ah, is there any way I could identify which dol I need or is corrupted?

    Thanks!
     
  4. Jacobeian

    Member Jacobeian GBAtemp Advanced Maniac

    Joined:
    May 15, 2008
    Messages:
    1,879
    Country:
    Cuba
    I would try the following things:

    1) delete genplus .ini file in sd:/genplus

    2) download last version and replace sd:/apps/genplus/boot.dol with it
     
  5. geordan
    OP

    Newcomer geordan Newbie

    Joined:
    Jan 15, 2004
    Messages:
    3
    Country:
    United Kingdom
    Ah! Thank you very much! That's worked!
     
  6. Dixiecrystal13

    Newcomer Dixiecrystal13 Newbie

    Joined:
    Jul 29, 2016
    Messages:
    1
    Country:
    United States
    My husband is having the same issue this guy was...what steps do I need to take to delete the first and get the last gen plus file?
     
  7. MaeseJesus

    Member MaeseJesus GBAtemp Regular

    Joined:
    Apr 3, 2013
    Messages:
    185
    Country:
    Spain
    I think he's refering to the INI files that are stored in the Genplus folder of the root of your SD Card.

    Simply insert your card on your PC, and enter the genplus folder that you see. There are two files, Config.ini and history.ini.

    To get a new Boot.dol go here:

    https://bitbucket.org/eke/genesis-plus-gx/commits/575c86e88451229d56fb1f713a002cda45f0e679

    Look for "builds/genplus_wii.dol" and click view file, and then View Raw.

    A file named genplus_wii.dol will pop up. Download it, and rename Boot.dol. Put it on root/apps/genplus folder. If you have already a Boot.Dol there, replace it with the newer one.

    I hope i'm not forgetting anything.
     

Share This Page