File attributes - always marked as readonly

Discussion in 'Computer Software and Operating Systems' started by jgblahblahblah, Jul 7, 2013.

  1. jgblahblahblah
    OP

    jgblahblahblah GBAtemp Regular

    Member
    173
    3
    Jun 14, 2010
    United States
    e
     
    Last edited by jgblahblahblah, Dec 11, 2015
  2. Foxi4

    Foxi4 On the hunt...

    pip Reporter
    23,589
    21,600
    Sep 13, 2009
    Poland
    Gaming Grotto
    Read-Only should not prevent you from copying the files. This might mean that you have some other problems with your HDD. Consider scanning it with chkdsk first before continuing. You could also try using xcopy via the command prompt.
     
  3. jgblahblahblah
    OP

    jgblahblahblah GBAtemp Regular

    Member
    173
    3
    Jun 14, 2010
    United States
    e
     
    Last edited by jgblahblahblah, Dec 11, 2015
  4. Foxi4

    Foxi4 On the hunt...

    pip Reporter
    23,589
    21,600
    Sep 13, 2009
    Poland
    Gaming Grotto
    Are you on the Administrator's account? If not, switch to it and retry. Are the files stored on the ROOT of the C:\ drive, on the Desktop or in any System folder? If so, move them to a separate folder. If all fails, use "attrib -r c:\YourFolderOrFile /s" via the command prompt which will force removing the attribute. The /s switch will apply changes to sub-folders and files in them.

    If even that fails, perform a chkdsk scan with the /f switch to force it and apply fixes, then retry.
     
  5. jgblahblahblah
    OP

    jgblahblahblah GBAtemp Regular

    Member
    173
    3
    Jun 14, 2010
    United States
    e
     
    Last edited by jgblahblahblah, Dec 11, 2015
  6. Foxi4

    Foxi4 On the hunt...

    pip Reporter
    23,589
    21,600
    Sep 13, 2009
    Poland
    Gaming Grotto
    Are you sure you're not trying to copy your past selection from the external HDD? You need to select the files you've just copied (wherever they are now) and attempt copying them - the external HDD has been formatted so the files are indeed not found. :)

    If that's not the case and you're 100% certain that you are copying the files you intend to copy, it may signify a more in-depth problem with the system, which is why I recommended to scan the drive. I know it's a chore, but it usually resolves issues like this one.
     
  7. jgblahblahblah
    OP

    jgblahblahblah GBAtemp Regular

    Member
    173
    3
    Jun 14, 2010
    United States
    e
     
    Last edited by jgblahblahblah, Dec 11, 2015
  8. Foxi4

    Foxi4 On the hunt...

    pip Reporter
    23,589
    21,600
    Sep 13, 2009
    Poland
    Gaming Grotto
    Try individual files? The second command should've worked on the "J" folder just fine (hence no "File not Found" echo).
     
  9. jgblahblahblah
    OP

    jgblahblahblah GBAtemp Regular

    Member
    173
    3
    Jun 14, 2010
    United States
    e
     
    Last edited by jgblahblahblah, Dec 11, 2015
  10. Foxi4

    Foxi4 On the hunt...

    pip Reporter
    23,589
    21,600
    Sep 13, 2009
    Poland
    Gaming Grotto
    How very odd...

    Alright then, to make things quicker, you can use this command (since it seems to work on files) - "attrib -r *.* /s /d" - this should technically unmark all files within the directory tree you're starting it from.

    Here's the complete syntax of the tool for you to fiddle with, maybe you'll manage to unmark the folders as well with it.

    ATTRIB
     
  11. jgblahblahblah
    OP

    jgblahblahblah GBAtemp Regular

    Member
    173
    3
    Jun 14, 2010
    United States
    e
     
    Last edited by jgblahblahblah, Dec 11, 2015
  12. Foxi4

    Foxi4 On the hunt...

    pip Reporter
    23,589
    21,600
    Sep 13, 2009
    Poland
    Gaming Grotto
    Hmm... No idea how to proceed at this point, really. At this point you shouldn't have any problems changing the attribute. The only thing that springs to mind would be using a Live CD/USB of sorts - this shouldn't be as troublesome as it is.
     
  13. Rydian

    Rydian Resident Furvertâ„¢

    Member
    27,883
    8,111
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    Running the command prompt as administrator? Showed hidden+system files?
     
  14. PityOnU

    PityOnU GBAtemp Advanced Fan

    Member
    908
    327
    Jul 5, 2012
    United States
    Jesus Christ weird advice going on in this thread.

    Read-only is not a problem. Windows shows that by default for all directories.

    It's a tri-state check box. Checked means its read-only. Unchecked means it's not read-only. A square box (neither checked nor unchecked) means the directory is not read-only but files in it might be, if they were individually assigned as such.

    Woof, guys. Just... woof.
     
  15. the_randomizer

    the_randomizer The Temp's official fox whisperer

    Member
    22,357
    10,708
    Apr 29, 2011
    United States
    Dr. Wahwee's castle
    It's just Windows being Windows.
     
  16. jgblahblahblah
    OP

    jgblahblahblah GBAtemp Regular

    Member
    173
    3
    Jun 14, 2010
    United States
    e
     
    Last edited by jgblahblahblah, Dec 11, 2015
  17. PityOnU

    PityOnU GBAtemp Advanced Fan

    Member
    908
    327
    Jul 5, 2012
    United States
    Right. If you unchecked the box and hit apply, it would remove the read-only attribute from all files and directories in the directory recursively.

    The next time you open the properties box, though, the checkbox will be filled in again instead of unchecked. Windows does not check for you. I don't work for Microsoft so I can't say why the decision was made to handle it like that, but it probably has something to do with the amount of time it would take to parse all of the attributes (recursively) of all the files and directories underneath the root directory being fairly long for large filing structures, which would have caused perceptible lag when opening the properties window (similar to how long it takes to show the size of all files within in a directory). WIthout any easy way to indicate what the hell is going on to the user, they probably just figured "forget it, just make it a tri-state."
     
  18. Fishaman P

    Fishaman P Speedrunner

    Member
    3,243
    507
    Jan 2, 2010
    United States
    Wisconsin
    Have you tried booting a Linux LiveCD or LiveUSB? Linux shouldn't do this to you.
    You can back up your files, then get yourself a new hard drive.
     
  19. PityOnU

    PityOnU GBAtemp Advanced Fan

    Member
    908
    327
    Jul 5, 2012
    United States
    Again, this is not a problem with read-only.

    SOmething on your PC is messed up. Maybe your drive? You can verify the file system and attempt to fix any issues by using the "chkdsk" command.

    Run "chkdsk /?" do see a list of switches for that command and what they do. Then run it on your drive with the appropriate switches to verify all the files are there and not corrupted, and fix any issues if possible.
     
  20. jgblahblahblah
    OP

    jgblahblahblah GBAtemp Regular

    Member
    173
    3
    Jun 14, 2010
    United States
    e
     
    Last edited by jgblahblahblah, Dec 11, 2015