Failed to read ARM9 payload?

Discussion in '3DS - Flashcards & Custom Firmwares' started by DontShootUp, Jan 8, 2017.

  1. DontShootUp
    OP

    DontShootUp Advanced Member

    Newcomer
    67
    38
    Mar 10, 2013
    United States
    Hey guys, I tried searching but didnt find a solution to this issue. I've followed 3DS.guide to a T, but when I get to the Decrypt9 step, Safehax gives me the "Failed to read ARM9 Payload" error. Yes, ive renamed Decrypt9WIP.bin to arm9.bin and it's on the root of my SD card. I've formatted my SD card and it still doesnt work. Anyone else running into this?

    N3DS XL, 11.2, Soundhax.

    Thank you.
     
    Last edited by DontShootUp, Jan 8, 2017
  2. proflayton123

    proflayton123 悲しみ

    Member
    5,604
    2,051
    Jan 11, 2016
    Japan
    日本
    I did the guide earlier, is it named "arm9" not exactly "arm9.bin" ?

    Also, do you have a cart inserted?
     
  3. DontShootUp
    OP

    DontShootUp Advanced Member

    Newcomer
    67
    38
    Mar 10, 2013
    United States
    Yes, it's specifically named arm9.bin and I have a 3DS cart inserted.
     
  4. zoogie

    zoogie simple pimp tool

    Member
    6,146
    7,721
    Nov 30, 2014
    United States
    DontShootUp likes this.
  5. DontShootUp
    OP

    DontShootUp Advanced Member

    Newcomer
    67
    38
    Mar 10, 2013
    United States
    zoogie likes this.
  6. zoogie

    zoogie simple pimp tool

    Member
    6,146
    7,721
    Nov 30, 2014
    United States
    Probably because the chainloader payload is a tiny 43KB. :P
    Tinivi has stated that error occurs more often for larger payloads.
     
  7. DontShootUp
    OP

    DontShootUp Advanced Member

    Newcomer
    67
    38
    Mar 10, 2013
    United States
    I did notice the file size was different lol
     
    zoogie likes this.
  8. gamerontheline79

    gamerontheline79 Newbie

    Newcomer
    2
    0
    Jun 16, 2017
    United States
    I'm having the same problem. I also installed the .zip file given in this forum which got me a little farther. But it still ended up failing. Anyway to fix this? I'm running browserhax on 9.7.0-4U which is a frankenfirmware. People on reddit recommended that I get CFW to fix my problem but its taken a while since I keep running into errors.

    — Posts automatically merged - Please don't double post! —

    So I found the read me... I moved everything that was on the file to the root of the SD but it still failed. And after moving the .3dsx back in the 3ds folder and replacing the old one. It still failed. So I'm a bit stumped...

    — Posts automatically merged - Please don't double post! —

    Do not reply to this... I noticed there was an incorrectly named file.