F2A Drivers & Writer on Windows 7

Discussion in 'GBA - Hardware, Devices and Utilities' started by Abstract3000, Dec 16, 2009.

  1. Abstract3000

    Abstract3000 Advanced Member

    May 24, 2007
    United States
    Salem, OR
    Has anyone got the F2A GBA USB drivers to work on Windows 7? I tried downloading the XP setup drivers & running setup to no avail as well i have tried to run the USB Writer V102 yet I get DlPortIO.dll is missing from computer error, any suggetstions to get this to work? when trying to point out the drivers manually the system won't except them
  2. how_do_i_do_that

    how_do_i_do_that Blue Wizard is about to die.

    May 16, 2008
    You have insufficient posts to view user location.
    You can't load those 32bit XP drivers in win7, thats because the driver structures are different, same thing in vista. If you got the 64bit version of vista/win7, your 100% SOL trying to load 32bit drivers on a 64bit system. There is also NO SUCH thing as compatibility mode for drivers, that is only for programs.

    Your only suggestion is to use a real XP box. It does work on a XP netbook, if you want to spend some cash for one.
  3. tucsonsduke

    tucsonsduke Newbie

    Jan 12, 2010
    United States
    I got it working under XP mode in windows 7. First download XP mode (http://www.microsoft.com/windows/virtual-pc/download.aspx). When I booted XP mode I looked at the drop down at the top, chose usb, and selected Unknown device. I then installed the drivers on the XP box, followed the normal procedure, and was able to flash the games to my F2A
  4. disc_over

    disc_over Newbie

    Mar 2, 2011
  5. Dinges

    Dinges Newbie

    Jan 24, 2012
    I got the same problem, but found out that the hardware ID of the driver wasn't right.
    Maby you could try the driver from this rar file, it worked at my windows 7 x86 pc.

    Leave as message if it workes and good luck. :yaynds:

  6. eAL

    eAL Member

    Oct 7, 2018
    basically on campus
    Hey Guys,
    i tried running the drivers from the last link from 6 yrs ago on my win10 desktop,
    the installation went through with no errors, but the usb linker isn't recognized by windows.
    i tried installing the driver's software in compatibility mode, but the linker wasn't recognized either.
    trying to install the driver manually wont work, telling me it's not an x64 driver.
    is there a way to implement the driver by hand into the system, what folder should i put it in? any clues? thx in advance