EZVi Stopped working

Discussion in 'EZ-Flash' started by darkbillie, Jun 7, 2011.

Jun 7, 2011

EZVi Stopped working by darkbillie at 12:06 AM (620 Views / 0 Likes) 2 replies

  1. darkbillie
    OP

    Newcomer darkbillie Advanced Member

    Joined:
    Jul 11, 2008
    Messages:
    94
    Country:
    Netherlands
    just tried to play with the EZVi again, and for some reason the thing whont boot up. meaning the DS doesnt reconize the card..the first time i did boot it up it says there wasnt a kernel on it (wich was on it). and after i plugged it in again it whont reconize anymore, i think it might be busted...tbh im pretty sure it is...anyone here have another idea what might have happend?..also if it is what card shall i buy next? i can remember there was a card wich runs GBA games
     
  2. KidIce

    Member KidIce Smart Ass

    Joined:
    Dec 22, 2005
    Messages:
    935
    Country:
    United States
    I take it was sitting unused for some time? It's probably just dirty/corroded, clean the contacts w/ a soft eraser and if you have access to some some electrical contact cleaner (keep it off the plastic though, it can melt it). Don't use alcohol, it will leave a film. Not much you can do about the SD slot but but insert and remove the microSD a few times and then take some compressed air to it.

    As far as a new cart is a concern, I only have an EZV and a Super Card DS2. The SCDS2 is the cart you're thinking of that can play GBA w/o a slot 2 device. It's a nice cart but I actually prefer my EZ5 for most things because I prefer it's interface. Not to suggest that I don't like the SCDS2, I'm very happy w/ it, I just prefer the EZ5 for day to day typical running "back ups" usage. I could safely recommend either cart.
     
  3. darkbillie
    OP

    Newcomer darkbillie Advanced Member

    Joined:
    Jul 11, 2008
    Messages:
    94
    Country:
    Netherlands
    nop it was still used every day..

    as for the new card i just orderd an old R4

    but still i would like to know what could have broken the card..i doubt it was ''overused''
     

Share This Page