EZ4 mini stuck on 2.0 (update screen doesn't show up)

Discussion in 'GBA - Flashing Hardware and Software' started by Artur_Filho, Jun 26, 2017.

  1. Artur_Filho
    OP

    Artur_Filho Newbie

    Newcomer
    8
    1
    Oct 8, 2016
    Brazil
    So, I know I had put the ezfla_up.bin file in the root of the SD. But holding R on startup acomplishes absolutely nothing, it doesn't even enter the black update screen it just boots straight into the menu

    I tested the R button and it's working. Anyone has any clue on what's going on?
     
  2. Dnilo

    Dnilo Member

    Newcomer
    22
    6
    Dec 3, 2013
    Mexico
    This happened to me with 1.76, my mini sd card had a bad formatting that time, plus it used to give me problems getting files (Roms) damaged from time to time.

    I would suggest you to re-format your sd card to FAT16 (or simply FAT) in case it's formatted as FAT32.
     
  3. Bart Lemming

    Bart Lemming Gēmu Bōi mikuro

    Member
    337
    21
    Feb 25, 2004
    United Kingdom
    Mute City
    Since 1.76 there seem to be a few problems with the mini SD iteration of the cart.

    I eventually gave in and bought a new micro SD model (£20). It's not expensive and has saved me a lot of headaches. I've got all the benefits of simple updating and a bigger capacity SD card too. Mini SD cards are hard to find and bloody expensive these days!
     
  4. Dnilo

    Dnilo Member

    Newcomer
    22
    6
    Dec 3, 2013
    Mexico
    Tell me about it! I got my EZflash IV just 4-5 years ago, I'm relatively new to the flashcard scene hehe. When I did I made sure I was getting the best and most 'compatible' stuff, so I went and got my miniSD for 4 times the regular price. It never worked flawlessly for long periods.

    I just got a microSD with a miniSD adapter two weeks ago, no problems at all. Plus, it's now easier to read it on my computer without adapters on top of adapters.
     
  5. Localhorst86

    Localhorst86 GBAtemp Advanced Fan

    Member
    950
    486
    Jul 17, 2014
    Germany
    My Nintendo works for Dad
    I have a theory about the miniSD card, I can not verify this though:

    The bootloader (the black screen that flashes the firmware) is never touched in an update. So whichever bootloader your EZIV came with is the bootloader you have now. For the microSD models this means the bootloader is SDHC compatible, the miniSD version however still needs a non-SDHC card for the flashing process.

    Furthermore, the kernel that runs the menu has been SDHC Compatible from release 1.75 onwards which drastically reduced the compatibility with non-SDHC. For miniSD users this results in this seemingly erratic behaviour that you can't use your SDHC Card to update the kernel or your non-SDHC Card to run games.
     
    zfreeman likes this.
  6. Dnilo

    Dnilo Member

    Newcomer
    22
    6
    Dec 3, 2013
    Mexico
    That could be the case, however I fixed that issue by formatting my miniSD, and now that I got a microSD (non-SDHC) it's working flawlessly. I think it's a FAT problem rather than on the kernel side, fragile old file system.. or, bad SD cards.

    I mention this because I did have problems prior to the 1.75
     
  7. Bart Lemming

    Bart Lemming Gēmu Bōi mikuro

    Member
    337
    21
    Feb 25, 2004
    United Kingdom
    Mute City
    @Localhorst86: I think you might be onto something there. I tried formatting my mini SD card and still had no luck. The mini SD card works in other devices and I can't find any corruption on it. Perhaps Dnilo and I had slightly different issues...
     
  8. Artur_Filho
    OP

    Artur_Filho Newbie

    Newcomer
    8
    1
    Oct 8, 2016
    Brazil
    Thanks, guys! I actually tried it with different SD cards, even tried to reformat some of them to FAT16. I saw a new update is out so I might try that once I get back to uni (I'm on vacation)

    EDIT: Worst case scenario, I at least have the update that does the auto S-RAM patching. :yaysp:
     
    Last edited by Artur_Filho, Jul 17, 2017
  9. nero99

    nero99 GBAtemp Addict

    Member
    2,021
    935
    Sep 18, 2014
    United States
    Why not update to the 2015 version ez iv? Best upgrade i made in years
     
  10. Artur_Filho
    OP

    Artur_Filho Newbie

    Newcomer
    8
    1
    Oct 8, 2016
    Brazil
    I'd really like to but US dollars are expensive here, so it would be a costly upgrade for not that much of a benefit unfortunately :P