Error 002 on REAL Super Mario Galaxy 2 disc?

Discussion in 'Wii - Hacking' started by nintendoman562, May 23, 2010.

  1. nintendoman562
    OP

    nintendoman562 Member

    Newcomer
    15
    0
    Mar 14, 2009
    Canada
    Okay so I burned Super Mario Galaxy 2 and i got Error 002. So instead of trying to softmod my Wii (I have a hardmod) I decided to trade in a couple games and get the legit disc. To my dismay, when I put the disc inside I get the same error. I'm playing off of the disc channel. So can ANYONE help me here?

    All my other real/burned games work. I'm on version 4.1u
     


  2. Blue-K

    Blue-K No right of appeal.

    Member
    2,572
    1
    Jun 21, 2008
    Swaziland
    Helvetica
    Do some research.

    Obviously you're blocking your Wii from Updating from the Disc, and now an IOS is missing. Run the game through GeckoOS and it should work afterwards.
     
  3. nintendoman562
    OP

    nintendoman562 Member

    Newcomer
    15
    0
    Mar 14, 2009
    Canada
    What's GeckoOS? Or is there a way of installing that missing IOS?
     
  4. XFlak

    XFlak Wiitired but still kicking

    Member
    9,127
    533
    Sep 12, 2009
    Canada
    Ontario
    use neogamma instead of gecko OS to play backup discs

    or if u want to use the original disc channel, u can update your IOSs using NUS Auto Downloader... or if u want to play backup discs from the disc channel u can grab dark corp
     
  5. nintendoman562
    OP

    nintendoman562 Member

    Newcomer
    15
    0
    Mar 14, 2009
    Canada
    Which version of Neogamma should I use?
     
  6. XFlak

    XFlak Wiitired but still kicking

    Member
    9,127
    533
    Sep 12, 2009
    Canada
    Ontario
    either the last official release, which is rev 8

    or the latest beta, which is rev9beta11(i think, could be higher now)
     
  7. nintendoman562
    OP

    nintendoman562 Member

    Newcomer
    15
    0
    Mar 14, 2009
    Canada
    Can you link me to a tutorial for either please?
     
  8. XFlak

    XFlak Wiitired but still kicking

    Member
    9,127
    533
    Sep 12, 2009
    Canada
    Ontario
    not much to know

    here's my autoboot mod, install the wad for the CHANNEL (not the forwarder), then just put the disc in and start the channel and it will boot the game. If u need to manage the options, hit any button after starting the channel
    http://gbatemp.net/index.php?showtopic=205141
     
  9. WiiPower

    WiiPower GBAtemp Guru

    Member
    8,165
    72
    Oct 17, 2008
    Gambia, The
    I heard the game is using IOS56. Get the latest IOS56 and install it. That should fix 002 errors you could possibly get in disc channel and/or Gecko OS. Maybe you need to extract the IOS56 wad from the disc itself, which can be done with WiiScrubber on a pc or with wufe with the wii itself if you have a retail disc, but no .iso file.
     
  10. Rajahten

    Rajahten Member

    Newcomer
    40
    0
    Jan 6, 2010
    Canada
    Is the update from the game updating the IOS56? I have a wiikey 1, with 4.1U, and getting error #002 right after I hit start to boot the game from the channel. From what I've read, it's because you're blocking the game from performing its update, which is true because I used brickblocker before I ran it. I am just afraid to update to 4.2.
     
  11. pepxl

    pepxl GFX W!Z4RD

    Member
    3,263
    108
    Jun 19, 2009
    i opened the ISO up in WiiScrubber and SMG2 does indeed come with 4.2 but updating/installing IOS56 should be enough to run the game from the Disc Channel without updating to SM4.2, Brickblocker could be patching the game in a way its erroring out, use Priiloader or equivalent to block disk updates
     
  12. Rajahten

    Rajahten Member

    Newcomer
    40
    0
    Jan 6, 2010
    Canada
    Alright. I have no experience with priiloader or any idea how to update IOS56. I've never tried because I don't want to brick. =(
     
  13. Krestent

    Krestent What to post?

    Member
    3,953
    33
    Mar 31, 2009
    United States
    Install the Homebrew Channel and run Dop-Mii to install IOS56. There's no risk in trying to install IOS56.
     
  14. Rajahten

    Rajahten Member

    Newcomer
    40
    0
    Jan 6, 2010
    Canada
    And doing this would render my wiikey useless? Homebrew, that is. I'm a noob when it comes to homebrew/neogamma/priiloader/latin/latin/latin
     
  15. C.S.I.

    C.S.I. GBAtemp Fan

    Member
    410
    0
    Mar 8, 2010
    Down under
  16. Sanfransexstar

    Sanfransexstar Member

    Newcomer
    36
    0
    May 22, 2010
    United States
    The easiest solution to this in my eyes would be to go ahead and just try neogamma r8 final. At least if it doesn't work after trying this, you will know if you need an IOS or not. http://www.mediafire.com/?zjytnnjryyn inside of that file is a readme.txt that will explain all of the steps to installing neogamma. Basically you are going to put the neogamma folder inside of the apps folder on your sd card. Then just run the homebrew channel and you will see neogamma on the main screen. then just pop in your disc and tell it to load from dvd. Hopefully that will work. Try it and let us know how it goes.
     
  17. Centrix

    Centrix Stop Poking the Moogle!

    Member
    888
    77
    Aug 28, 2008
    United States
    Seattle,WA
    Thats weird, my system is soft modded and I'm running 4.2 firmware...I recently downloaded and burnt Mario galaxy 2 three days before it's release and it works 100% with no problems...maybe it has something to do with your burner of burning software? but if it's doing the same thing with a actual copy of the game, well then that there is another problem with in it's self!
     
  18. Rajahten

    Rajahten Member

    Newcomer
    40
    0
    Jan 6, 2010
    Canada
    That's because the 4.2 firmware comes with the updated IOS56 file I believe. I don't want to go to 4.2 because then I can't run out of region games =P

    Also, will a microSD card with an SD adapter work for all of these homebrew things?

    Alright, thanks for breaking it down for me. I can understand that. But first I need to install homebrew. Is this guide ----> http://sites.google.com/site/completesg/ha...uide/the-basics a good one to use for installing homebrew?
     
  19. Sanfransexstar

    Sanfransexstar Member

    Newcomer
    36
    0
    May 22, 2010
    United States
    If you just go ahead and softmod update to 4.2 then you will be able to play region free by using priiloader. I would reccomend updating, being that there is a fabulous guide at the top of the forum for updating ANY wii to 4.2. You really can't go wrong, and I would guarantee that your smbg2 disk will work fine after that.
     
  20. Sanfransexstar

    Sanfransexstar Member

    Newcomer
    36
    0
    May 22, 2010
    United States

    http://gbatemp.net/t171901-modify-any-wii-4-2-below

    Use this guide and you will have everything you are needing to be up to date and play smg2.

    EDIT: I say use this guide because all you have to do is email the guy and it auto-respond with everything you will need. after downloading the files from the email. simply put the contents of update.zip onto your sd card and begin to follow his instructions. I literally just did this yesterday and it got me completely up to date on everything. I am now playing new super mario bros and smg2 hassle free.