DS Profile exploit on 6.1

Discussion in '3DS - Homebrew Development and Emulators' started by funkybeat, Jan 25, 2016.

  1. funkybeat
    OP

    funkybeat Newbie

    Newcomer
    8
    0
    Jan 25, 2016
    Gambia, The
    Hi, I'm on 6.1 and would like to load rxTools without Web Browser Exploit.

    On this vid it seems to work:


    Is there any way to launch emuNAND and/or rxTools without the browser on 6.1?

    Thanks!
     
  2. FenrirWolf

    FenrirWolf GBAtemp Psycho!

    Member
    4,347
    329
    Nov 19, 2008
    United States
    Sandy, UT
    I'd just update to 9.2 and use Menuhax
     
  3. A_Random_Guy

    A_Random_Guy Officially That Dev

    Member
    862
    460
    May 22, 2015
    Malaysia
    Smea's closet
    You need to use a DS flashcard to install MSET however
    EDIT 4 BELOW: Didn't read it properly :/

    He doesn't even have a browser! How can he even use RxTools if the OP can't use Rxtools


     
    Last edited by A_Random_Guy, Jan 25, 2016
  4. mid-kid

    mid-kid GBAtemp spamBOT

    Member
    879
    962
    Aug 2, 2012
    OR you use the web browser with a code.bin.
    https://gbatemp.net/threads/beta-spider-ds-profile-roploader-4-x-only.380725/page-14#post-5434311
    This should work for rxTools up until 2.6.

    EDIT: Nevermind, this is only for 4.x
    If you want it on 6.x, get an rxTools version compatible with the newer versions of CakeHax (any recent 3.0 nightly will do), get the code.bin, put a file named ropCustom.txt on your SD card with the following contents: "rxTools/sys/code.bin" (Without the "), and load this page: http://dukesrg.no-ip.org/3ds/cakes?code.bin
     
    Last edited by mid-kid, Jan 25, 2016
  5. peteruk

    peteruk GBAtemp Advanced Maniac

    Member
    1,515
    715
    Jun 26, 2015
    you can use the web browser as well

    — Posts automatically merged - Please don't double post! —

    ninja'd bu mid-kid :ninja:
     
  6. funkybeat
    OP

    funkybeat Newbie

    Newcomer
    8
    0
    Jan 25, 2016
    Gambia, The
    Thanks for the speedy reply. I'll try it with cakehax. I want to avoid to update the console and stay on the original firmware.

    So I thought profile exploit would be a good alternative if I have no internet access.

    Thanks
     
  7. funkybeat
    OP

    funkybeat Newbie

    Newcomer
    8
    0
    Jan 25, 2016
    Gambia, The
    It seems I'm not able to run rxTools later than the first Alpha Build of 3.0 When I load the new rxTools/sys/code.bin structure... it runs the initial ry-setup. when its done and I'm beeing asked to press any key... rxtools freezes with 2 black screens. Maybe its not compatible with a 6.1 sysnand?
     
  8. VaiCorunthians

    VaiCorunthians GBAtemp Fan

    Member
    457
    214
    Oct 7, 2014
    Brazil
    why use ds profile exploit, when we can autoboot?

     
  9. mid-kid

    mid-kid GBAtemp spamBOT

    Member
    879
    962
    Aug 2, 2012
    That's an rxTools issue, not CakeHax, since you've been able to get the initial setup thing.
    I haven't used rxTools since 2.4 so I can't really help you here. Detail your current setup and explain the problem, try a few more things, and maybe someone is able to help (try asking in different places if this forum can't help).
     
  10. SmashedDan

    SmashedDan Newbie

    Newcomer
    5
    4
    Jan 1, 2016
    United States
    This is a simple thing to do Update your rxtools version to the latest nightly from lavanoid.github.io (if site is down get the one from the second link at the bottom from december 5th) launch it and then turn your 3ds off. Then, follow the part of the guide below that says something like

    Launch RXTools through MSET (DS Profiles exploit)!

    (do the whole thing in normal sysnand) pick the 6.x option and skip to step 2. After following the tutorial when the web browser crashes, go straight (do not turn off/sleep the ds) into system settings and if you go to ds profile, rxtools should launch

    Note: if you play any ds(i) games on sysnand or emunand you will have to reinject the rxinstaller.bin from the tutorial to keep the exploit working.

    Thread:

    https://gbatemp.net/threads/tutorial-installing-rxtools-custom-firmware-3ds-and-2ds.390867/

    build

    https://drive.google.com/file/d/0B5HEA8LwWnOhX2JDU0F2RUVZTGc/view?usp=sharing


    Hope it helped
     
    Last edited by SmashedDan, Jan 31, 2016
    funkybeat likes this.
  11. Juiss

    Juiss GBAtemp Regular

    Member
    180
    52
    Jan 3, 2016
    France
    He's on 6.1 meaning he can't install menuhax.
     
  12. VaiCorunthians

    VaiCorunthians GBAtemp Fan

    Member
    457
    214
    Oct 7, 2014
    Brazil
    Of course. To get menuhax and coldboot, update to 9.0 or 9.2

    why stay on 6.1 or 4.x 5.x when on 9.0 9.2 is better? (my opinion)
     
    Wellington2k likes this.
  13. funkybeat
    OP

    funkybeat Newbie

    Newcomer
    8
    0
    Jan 25, 2016
    Gambia, The
    I know there is the option to update the Ds. However It runs very well on 6.1 and I did not want to risk to brick it with an update. i do not have a cartridge with 9.2 so I would have to use sysupdater and install it on sysnand.

    The spider exploit works fine but only if Im online. The mset install also starts but neither cake cfw nor the later rxtools will boot my emunand for some reason. I even tried to run customrop and link to the old rxtools.dat but it did not load as well.
     
  14. funkybeat
    OP

    funkybeat Newbie

    Newcomer
    8
    0
    Jan 25, 2016
    Gambia, The
    Just to complete this Thread: I managed to use the MSET boot. The only thing I need to do is to press the L button as soon as rxtools boots via Profile Exploit. It does not boot automatically as usual but its fine for me. thanks for your help
     
  15. urherenow

    urherenow GBAtemp Psycho!

    Member
    3,040
    903
    Mar 8, 2009
    United States
    Japan
    Looks like I'm late to the party, but FBI has all of the ROP loaders built in... for both old and new rxTools versions. And you can use a custom one if you need MSET for something else.