Dolphin Emulator not working anymore. Need some help!

Discussion in 'Computer Programming, Emulation, and Game Modding' started by Drud1995, Jun 30, 2016.

  1. Drud1995
    OP

    Drud1995 GBAtemp Regular

    Member
    117
    31
    Apr 18, 2012
    United States
    Magicant
    Hello, for some reason, my gaming laptop is struggling to smoothly play Wii games on the Dolphin emulator. My laptop has an Intel i7-3630 quad core processor, 16GB of RAM, and a Geforce GTX 670MX processor. About a year or two ago, I could run just about any game with upscaled internal resolution and more. Now, it doesn't even work smoothly at native resolution. Please help me figure out what's going on. Attached are my current Dolphin settings. Thank you!
     

    Attached Files:

  2. TehCupcakes

    TehCupcakes GBAtemp Regular

    Member
    252
    141
    Apr 5, 2013
    United States
    Well for one, you didn't actually attach your settings. If I were to take a guess, here are a few settings that have been revamped in some way and could impact performance:

    Options -> Configure -> General -> CPU Emulator Engine
    Select JIT Recompiler (Recommended)

    Options -> Configure -> Audio -> DSP Emulator Engine
    Select DSP HLE emulation (fast)

    Options -> Graphics -> General -> Backend
    Try switching between OpenGL and Direct3D11. Performance varies based on the graphics card, and even somewhat depending on the game.

    Options -> Graphics -> Enhancements -> Anti-aliasing
    Try switching this to None if it's not already. Anti-aliasing can be really slow.


    There's a good chance you're already aware of these options and have tried them. I'm just taking a stab at it because you didn't give much else to go off of. Generally I don't think you should have much trouble with poor framerate, as I have a similar set-up and Dolphin performs very well with Gamecube games. (Haven't really tested a lot of Wii games, but when I did I got pretty good performance out of those as well.)
     
  3. Drud1995
    OP

    Drud1995 GBAtemp Regular

    Member
    117
    31
    Apr 18, 2012
    United States
    Magicant
    Settings should be attached now on my post. Sorry about that! Even so though, I had all of my settings already tweaked that way.