1. Apb2282

    OP Apb2282 Newbie
    Newcomer

    Joined:
    Jan 17, 2020
    Messages:
    3
    Country:
    United States
    I recently replaced my digitizer and am having an issue. When in hekate it works fine, after booting to system, be it emu or system, only the edges work and the left side about 2 inches in. I have read that others have had this problem and that a fix might be to replace game cartridge reader? Anyone here have this issue, and can anyone confirm that replacing the cartridge reader fixes the issue? I know the cable is in correctly, and I have tried 2 different digitizer's. When I put my original back in it works fine, just scratched to hell!
     
  2. ModderFokker619

    ModderFokker619 GBAtemp Maniac
    Member

    Joined:
    Oct 2, 2015
    Messages:
    1,002
    Country:
    United States
    I've been trying to figure this out as Ive been replacing broken screens lately.

    Here's what I found out:

    Replacement digitizers only work on the dark green game card reader.

    I have yet to find digitizers that work with the light green game card reader.

    Anyone have a source of digitizers that work with all game card readers?
     
  3. Agilato

    Agilato GBAtemp Fan
    Member

    Joined:
    Jun 21, 2019
    Messages:
    321
    Country:
    United States
    It's a bit different. I have seen different revisions in different colors.

    All of this elements before connector should be populated in order to replacement Digitizer work properly.
    New revision doesn't have those elements, so only old slots will work with replacement digitizer.
    We had this conversation here few times, there is guys who tried to populate missing elements, didn't work.
    Looks like IC programmed to do the job.
     

    Attached Files:

    Last edited: Jan 17, 2020
    Apb2282 likes this.
  4. ModderFokker619

    ModderFokker619 GBAtemp Maniac
    Member

    Joined:
    Oct 2, 2015
    Messages:
    1,002
    Country:
    United States

    I only get 2 colors in San Diego Cali

    Only dark green boards work here

    Light green never work without original tizer

    Anyone figure this out yet?

    Did about 10 then stopped due to this hassle
     
  5. Agilato

    Agilato GBAtemp Fan
    Member

    Joined:
    Jun 21, 2019
    Messages:
    321
    Country:
    United States
    I replaced about 30+ Digitizers last year, all comes down to this 2 elements on the board being populated.
    I had Switches multiply revisions with different board colors and from different factories.
    They just cut expanse on elements and circuit optimization and we got f*ed with new stuff...
     
    Last edited: Jan 17, 2020
  6. Apb2282

    OP Apb2282 Newbie
    Newcomer

    Joined:
    Jan 17, 2020
    Messages:
    3
    Country:
    United States
    Anyone got a link to the old ones that will work?
     
  7. Agilato

    Agilato GBAtemp Fan
    Member

    Joined:
    Jun 21, 2019
    Messages:
    321
    Country:
    United States
    Go eBay find an item, check picture i included earlier, before buying contact seller and make sure seller will ship what you want, you can even use my picture. Because it's very common issue market filled with NEW versions... old one will take some effort to find.
     
    Last edited: Jan 17, 2020
    Apb2282 likes this.
  8. ModderFokker619

    ModderFokker619 GBAtemp Maniac
    Member

    Joined:
    Oct 2, 2015
    Messages:
    1,002
    Country:
    United States

    Ok I just remembered the light green almost light brownish boards are the ones that work and the dark green ones dont work. The IC thing is probably the best way to distinguish the 2.

    So the newer green ones have the extra ic and thats whats blocking replacment digis

    Has anyone tried removing the ic?
     
    Last edited: Jan 17, 2020
  9. Agilato

    Agilato GBAtemp Fan
    Member

    Joined:
    Jun 21, 2019
    Messages:
    321
    Country:
    United States
    From all donor boards and consoles i have, i noticed that color of the PCB doesn't matter that much.
    I have first revisions of the actual boards (HAC-CPU-01) made with dark mask and same (HAC-CPU-01) with more lighter mask. I think it's just what they had in stock. Also there are reports that Switch has been made on 4th different factories over time, so color of the mask also can mirror place they were made on.

    I don't think those changes aimed to block replacement of digis, they just trying to find most efficient and cheapest ways to make this product. I think they get rid of few lines out of array touch, because it doesn't make sense to make that quality touch which is barely used in a console.

    Can you please provide a picture of IC you are talking about?
    If we are talking about those i circled, it's just a diode and resistor, if i am not mistaking.
    And also "NEW" one have less elements on the board.
     
    Last edited: Jan 17, 2020
  10. Apb2282

    OP Apb2282 Newbie
    Newcomer

    Joined:
    Jan 17, 2020
    Messages:
    3
    Country:
    United States
    So I purchased the older style cartridge reader and thought all was good, then I realized that the bottom inch is not working. It is much better than before, but still having issues. Have you experienced this?

     
    Last edited: Jan 30, 2020
  11. Agilato

    Agilato GBAtemp Fan
    Member

    Joined:
    Jun 21, 2019
    Messages:
    321
    Country:
    United States
    I had this issue when for some reason connector was not able to provide much pressure.
    When you press on touch cable by finger is it works?
    Clean cable with ipa, make sure connector clean.
    Are the board to cartridge connector is ok?
    Also check it with your original digi, they usually comparable with the original stuff.
     
    Last edited: Jan 30, 2020
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - replacement, Digitizer, issues