Differences/benefits between 3.18 webroot and 3.35 "hello world" exploit

Discussion in 'PS Vita - Hacking & Homebrew' started by Bonovox40, Nov 11, 2014.

  1. Bonovox40
    OP

    Bonovox40 GBAtemp Fan

    Member
    410
    25
    Apr 2, 2003
    United States
    Basically what the topic says. I'm looking at picking up a 3.18 (or less) fw Vita and just leaving it alone.

    HOWEVER...I REALLY want to buy Binding of Isaac for Vita and that requires 3.35 fw. I'm kinda confused by the scene developments and the exploit variants.

    So my question is, does the 3.35 "Hello" bubble exploit allow for the same things (theoretically when possible future CFW happens, and I know we're just guessing atm) as the 3.18 webroot hack?

    If it's MUCH more likely that 3.18 will allow progress vs some partial/limited access w the 3.35 exploit, then I will just stay on the 3.18fw and play card games until things happen.

    And along those lines, I get that there's a PS3 transfer option to buy ps vita ps store games and transfer over to a lower fw vita, but can you do this with a CFW ps3 (rebug)? I've never gone online with my ps3 and I don't even think I have a psn account anymore.

    Thanks for any guidance temp members!
     
    Margen67 likes this.
  2. yifan_lu

    yifan_lu @yifanlu

    Member
    642
    1,325
    Apr 28, 2007
    United States
    3.35 hello bubble is just another PSP emulator hack.
    3.18 webkit is a userland vita hack.
    Both are very limited and cannot directly help with any cfw hackings. IMO, webkit hacking is trivial compared to kernel hacking, so any kernel hack that works on 3.18 would likely be ported to the latest FW with a new webkit hack or something else. but don't take my word for it, upgrade at your own risk.
     
    Margen67 and SLiV3R like this.
  3. Bonovox40
    OP

    Bonovox40 GBAtemp Fan

    Member
    410
    25
    Apr 2, 2003
    United States
    Ok. I'll stay on 3.18 if I can help it. Thanks for the reply.

    So i picked up a refurb Vita on 3.08 fw. I'll just leave it alone for now, or if I have to have it bumped up to 3.18 to install the exploit, I will.

    I noticed from images online, that mine has the vertical lines that so many do. When the screen fades out (like that welcome app thingy that comes with it) or it's a dark brown to black background, you can see it very well. Looks like a jagged tooth monster mouth kinda. The lines run from maybe 1/4th inch, to 1.5 inches high and spaced out about 5-10 centimeters apart on both the top and bottom of the screen.
    No horizontal lines or discoloration blobs, but I haven't tested it or have any games as of yet to test.

    Does my description sound like a normal issue or bad enough to return?
     
  4. Cinnamon

    Cinnamon GBAtemp Regular

    Member
    257
    69
    May 2, 2014
    Norway
    Congratulations, you have got a normal OLED screen. Maybe a good one since you got no mura(?).
     
  5. Bonovox40
    OP

    Bonovox40 GBAtemp Fan

    Member
    410
    25
    Apr 2, 2003
    United States
    Dang. Guess it got too used to retina screens and IPS monitors. lol

    btw, Is there a way to transfer psn content (that is cross play on vita) from my ps3 to the vita without connecting to the PSN, (like using multiman,etc) or it can ONLY be done that way?

    Or I can't on a cfw ps3 and have to use a OFW ps3? If I use a friends ps3 that is on OFW, I take it I have to set up a new matching account on both his and my vita?
     
  6. mech

    mech ♥️♥️♥️♥️♥️♥️♥️♥️

    Member
    4,396
    2,710
    Oct 26, 2014
    Tonga
    you need OFW ps3 and a connection to psn
     
  7. Bonovox40
    OP

    Bonovox40 GBAtemp Fan

    Member
    410
    25
    Apr 2, 2003
    United States
    Just as a follow up:

    At this stage of development, if I do NOT need to run psp/psx stuff on my vita, is there any real reason to go and get the 3.18 webroot hack on it?
    Basically, if I sit around and do nothing and play retail games under my current FW (so no accidental updating) could that screw up things down the pipe?

    If say in a couple months some big psn/vita ISO backup exploit/hack/cfw is released, and I don't have the webroot hack already on my vita, am I somehow stuck from being able to implement the new/big hack? Or likely, i'll just have to first apply the old hack before getting the new one installed. (or the new one will make the 3.18 webroot defunct and unnecessary anyway)

    Just don't want to shoot myself in the foot for choosing to NOT actually doing anything at this time. ;-)

    Thanks!
     
  8. mech

    mech ♥️♥️♥️♥️♥️♥️♥️♥️

    Member
    4,396
    2,710
    Oct 26, 2014
    Tonga
    3.08 has no advantage over 3.18 at all, in fact 3.18 runs the websploit also ps1 games run better at 3.18. if you were on firmware 2.0 and below maybe worth keeping it there if you have it as a 2nd vita and don't mind it collecting dust for the time being.
     
  9. Nathan Drake

    Nathan Drake Obligations fulfilled, now I depart.

    Member
    6,192
    2,151
    Jan 2, 2011
    Okay, so a summary of progress so far:
    - The webkit exploit is moving along pretty well. There are some very dedicated hackers that have been digging further and further in using it, though, I personally can't understand half the jargon being used to describe the different things they've accomplished. The gist of it is that there are decent chances that the webkit exploit may lead to something, but as people have been saying, don't hold your breath thinking that it will inevitably lead to a deeper exploit.

    - The custom bubbles: this is basically something that can be used to trick the Vita into installing content so that it shows up as an actual bubble on your Vita. They've managed to insert TN-V, VHBL, PSP games, and will be testing the installation of PS1 games. This worked for content that both has been sold on PSN, and content that has never been sold on PSN (ex: they installed an english patched version of FF Type-0). They did verify that, at least at the time of reporting, there was no way to get official Vita content working with the custom bubbles. It seems to be the one limitation of this exploit.

    Although they mentioned something about the custom bubbles at least being possible on 3.35, they still mentioned that they couldn't get TN-V working for it, and the best option is to simply stay on 3.18.

    So if you're interested in seeing how the webkit exploit continues to develop, and if the custom bubbles are of interest to you, just follow the progress on wololo. It's where all the Vita hacking news is reported first, and this past week in particular has been an interesting one for the Vita scene.

    Edit: And to give a general answer to your last question, it doesn't matter what you do with your Vita while it's on 3.18 as long as you don't do a firmware update. If you want to keep buying retail cartridges and they keep working just fine without the latest firmware, then you'll be okay.
     
  10. mech

    mech ♥️♥️♥️♥️♥️♥️♥️♥️

    Member
    4,396
    2,710
    Oct 26, 2014
    Tonga
    yup, aslong as your new carts dont need somthing above 3.18 you are good to go.
     
  11. Bonovox40
    OP

    Bonovox40 GBAtemp Fan

    Member
    410
    25
    Apr 2, 2003
    United States
    Actually from what I ended up researching, the vertical lines was quite severe. There was some small mura splotches, but when playing a game with any gray - dark black, I could EASILY see lines running up and down.

    And after I saw them I could not unsee where they were and they were everywhere on the screen.

    Did an even exchange at Fry's without question, and this one is MUCH better. Few tiny black dots here and there, one little cigarette burn shaped circle, and only one sorta vertical line in the upper right border.

    Nothing really noticeable at all except during a loading screen when the game starts. Can't even see any of the mudra during gameplay like the previous unit.
    Funny enough it came w a lower fw than the last one: 3.01
     
  12. Bonovox40
    OP

    Bonovox40 GBAtemp Fan

    Member
    410
    25
    Apr 2, 2003
    United States
    One more situational idea:

    Let's say in a few months, a new exploit game comes out for 3.35 fw or higher.....
    At that point, is there any legit reason to not update to 3.35, and be able to grab that game (and the digital psn stuff I want also) INSTEAD of holding back on pre 3.18 fw?

    Will a (hypothetical) 4.00 fw exploit game not allow something that the 3.18 webkit exploit allows? (or probably could allow) And if this happens, do I still need a ps3 or if the "new" game is in the psn store, I can grab it after updating the fw, and should be fine to install the exploit?

    Thanks!
     
  13. mech

    mech ♥️♥️♥️♥️♥️♥️♥️♥️

    Member
    4,396
    2,710
    Oct 26, 2014
    Tonga
    you will always need a PS3 on Official firmware to send games over, you can use a proxy method for around a week after a new patch is released if you are on the one before it. Anything over 3.18 will have no webkit exploit, well i say no what i mean to say is all the development is being done for 3.18 and under... i would not go above 3.18.
     
  14. KSP

    KSP GBAtemp Fan

    Member
    335
    247
    Jan 7, 2015
    United States
    There is no such thing as a Mura free OLED display, its the way the technology is.
     
    mech likes this.