devkitpro installation problems when compiling USB Loader GX

Discussion in 'Wii - Emulation and Homebrew' started by KitMikro, Nov 19, 2019.

  1. KitMikro
    OP

    KitMikro Newbie

    Newcomer
    1
    Feb 3, 2019
    Belgium
    Hi everyone,

    Today I decided I'd have a go at editing USB Loader GX just to get familiar with programming for Wii. So I installed devkitpro following instructions from the wiki.

    I've installed devkitpro on my Mac OSX version 10.14.5 & also tried Windows 10

    In short
    when I compile on my Mac I get an error :
    fatal error: ft2build.h: No such file or directory

    when I compile on Windows I get an error :
    fatal error: wupc/wupc.h: No such file or directory

    Strange thing is the files are there. at /opt/devkitpro/portlibs/ppc/include

    also when I try to MAKE any of the examples on my Mac I get a "Permission denied error" if I "sudo make" I get a
    "Please set DEVKITPPC in your environment" error.

    edit 0: Off course, because you use "sudo" you change the environment variables and path are not working correctly. So copied the example file to a different directory and now they compile. So it seems devkitpro is setup properly and working.

    edit 1: So added the missing files to the SOURCE directory. now let's compile......nope.....

    edit 2: while looking to the makefile it seems first error is within the bash script "filelist.sh" it generates an error "find: -printf: unknown primary or operator" it seems the option -printf is not available under OSX

    edit 3: So back to my Windows machine. It builds the file list but stops on 2 errors: "strcasestr was not declared in this scope" & "vasprintf was not declared in this scope"

    edit 4: Still not working. I've found a post by @Cyan telling the steps to compile usbloader from 10 years ago (sorry cannot post links). So I've setup a Virtual Machine with a clean install of windows 7 Ultimate SP 1 and did the following.

    A) compiler installation :
    1. install sliksvn and tortoisesvn
    2. Download Devkitpro and update to the latest revision.
    3. Replace "include" and "lib" folder in your c:/devkitpro/libogc/ folder with the provided zip from usbloaderGX website.
    Attention: this version of libogc will work only for compiling USBloaderGX. keep a copy of your original libogc folder if you want to compile other homebrew.
    4. Reboot your computer to register the environment variables correctly.

    Now then I created a new directory c:/homebrew
    and used svn checkout url provided by sourceforge to download the source
    when I try make
    it fails with the following error:
    Fatal error gd.h no such file or directory

    edit 5:Got it to work after replacing the complete devkitPPC directory with the content of devkitppc_r29-1 hurray!
     
    Last edited by KitMikro, Nov 26, 2019
Quick Reply
Draft saved Draft deleted
Loading...