Decrypt9WIP won't load

Discussion in '3DS - Homebrew Development and Emulators' started by DerRaecherMitDemBecher, Mar 20, 2016.

  1. DerRaecherMitDemBecher
    OP

    DerRaecherMitDemBecher Member

    Newcomer
    10
    0
    Mar 19, 2016
    Gambia, The
    N3DS sysNAND 9.2 with arm9loaderhax
    __

    Trying to load Decrypt9WIP through the homebrew launcher through sysNAND but I just see a red screen, a black screen and after a red one again. Then it reboots to the homebrew launcher. Any idea?
     
  2. ihaveamac

    ihaveamac GBAtemp Guru

    Member
    5,339
    5,752
    Apr 20, 2015
    United States
    Tigard, OR
    are you sure you are going into sysnand with 9.0 firmlaunch? what custom firmware are you currently using?
     
  3. DerRaecherMitDemBecher
    OP

    DerRaecherMitDemBecher Member

    Newcomer
    10
    0
    Mar 19, 2016
    Gambia, The
    I had a setup of sysNAND 9.2 and emuNAND 10.6 and for some reason I couldn't update my emuNAND, see here:
    Well I downgraded to 9.2 on emuNAND and tried to update again, this time I get a splashscreen "an error occured" while the statusbar was at 10% or so. My N3DS is acting really weird, I wanted to flash a backup of my emuNAND with Decrypt9WIP, but this doesn't load as stated. So I was thinking maybe the 9.2 was kinda a frankenfirm so I put a working 9.2 NAND.bin into the root as I'm using a9hl - guess what: it didn't work! The hell is going on, I'm really impressed by how much can go wrong xD Any idea where to start?
     
  4. ihaveamac

    ihaveamac GBAtemp Guru

    Member
    5,339
    5,752
    Apr 20, 2015
    United States
    Tigard, OR
    you can run Decrypt9 from arm9loaderhax, if you put "Decrypt9WIP.bin" as "arm9loaderhax.bin"; or if you're using a boot manager, add that to it.
     
  5. liomajor

    liomajor GBAtemp Maniac

    Member
    1,463
    1,065
    Jun 10, 2008
    United States
    If using AuReiNand, try booting up with holding ' L ' or setup Decrypt9WIP.bin as alternate payload. (i'm using ctr bootmanager to have all tools before booting any nand.)
     
  6. DerRaecherMitDemBecher
    OP

    DerRaecherMitDemBecher Member

    Newcomer
    10
    0
    Mar 19, 2016
    Gambia, The
    Loading Decrypt9WIP.bin worked, but couldn't restore the backup. "Not a proper NAND backup for this 3DS! Picture: https://www.dropbox.com/s/2pw6je4jvvowirx/IMG_20160320_034354.jpg?dl=0
     
  7. ihaveamac

    ihaveamac GBAtemp Guru

    Member
    5,339
    5,752
    Apr 20, 2015
    United States
    Tigard, OR
  8. liomajor

    liomajor GBAtemp Maniac

    Member
    1,463
    1,065
    Jun 10, 2008
    United States
    Indeed, 0x5 works only with the correct slot file.
     
  9. DerRaecherMitDemBecher
    OP

    DerRaecherMitDemBecher Member

    Newcomer
    10
    0
    Mar 19, 2016
    Gambia, The
    It worked, yay! Downgraded my emuNAND to 9.2 and checked if the NANDs were linked. Updated my emuNAND finally to 10.7, but I'm wondering why Decrypt9WIP runs via arm9loaderhax but not via sysNAND 9.2 - So I will restore the sysNAND too with the same emuNAND backup (clean 9.2), but do I have to reinstall arm9loaderhax or are FIRM0 and FIRM1 not being affected which are, if I'm correct, not being affected by the restore?
     
  10. liomajor

    liomajor GBAtemp Maniac

    Member
    1,463
    1,065
    Jun 10, 2008
    United States
    Uhm, hope you didn't downgrade using gateway.
     
  11. DerRaecherMitDemBecher
    OP

    DerRaecherMitDemBecher Member

    Newcomer
    10
    0
    Mar 19, 2016
    Gambia, The
    Don't worry, for downgrades I always used SysUpdater so far
     
  12. DerRaecherMitDemBecher
    OP

    DerRaecherMitDemBecher Member

    Newcomer
    10
    0
    Mar 19, 2016
    Gambia, The
    Maybe you guys can quickly help me again. Trying to inject the fbi.cia OR the hbl.cia into the hs.app but after. The app stops loading at the "3ds" screen on my emunand. any idea? Damn..

    Another try injecting hs.app (hbl.cia):
    Code:
    No usable file found
    Health&Safety Injection: failed!
     
    Last edited by DerRaecherMitDemBecher, Mar 20, 2016
  13. FenrirWolf

    FenrirWolf GBAtemp Psycho!

    Member
    4,347
    328
    Nov 19, 2008
    United States
    Sandy, UT
    needa have the generated hs.app file on the root of the sd card
     
  14. DerRaecherMitDemBecher
    OP

    DerRaecherMitDemBecher Member

    Newcomer
    10
    0
    Mar 19, 2016
    Gambia, The
    Yup, didn't load. After deleting and copying again it worked. But the injected file doesn't load up, hangs at "Nintendo 3DS"! Seems like I'm very blessed today :P
     
  15. liomajor

    liomajor GBAtemp Maniac

    Member
    1,463
    1,065
    Jun 10, 2008
    United States
    1. Don't use donor files, use decrypt9 to export your own hs.app.
    2. Take latest build from fbi.cia https://github.com/Steveice10/FBI/releases
    3. Use https://github.com/d0k3/Universal-Inject-Generator/archive/master.zip
    4. Use decrypt9 to inject this (file including banner)

    H&S Icon will only be displayed when sign is deactivated (start a cfw of your choice).
     
  16. gbatemplloyd

    gbatemplloyd Advanced Member

    Newcomer
    80
    8
    Mar 29, 2016
    Italy
    guys need help! i install a9lh last march. i switch from cakes to luma, all ok except decrypt9 here is a photo
     

    Attached Files: