ctr-httpwn

Discussion in '3DS - Homebrew Development and Emulators' started by Salamencizer, Mar 24, 2016.

  1. Salamencizer
    OP

    Salamencizer Handsome Computer Nerd

    Member
    795
    647
    Oct 3, 2015
    India
    Below
    https://github.com/yellows8/ctr-httpwn
    This allows bypassing update nags, like that which comes on eShop when you're on a lower FW.
    This doesn't work with dummy browser though.
    What expectations do you have with this?
     
    Last edited by Salamencizer, Mar 24, 2016
    Kvnrdrguez and proflayton123 like this.


  2. Glyptofane

    Glyptofane GBAtemp Advanced Fan

    Member
    540
    266
    Feb 12, 2009
    United States
    So far we have used this on my wife's 10.3 N3DS (she won't let me downgrade it) to access eshop for repairing a legit Yo-Kai Watch CIA installed through NASA so it actually boots now, loading Badge Arcade, and restoring online functions to Pokemon AS to get the current promos (Mew and Celebi).
     
    Last edited by Glyptofane, Mar 24, 2016
  3. LSolrac

    LSolrac Member

    Newcomer
    28
    5
    Oct 26, 2015
    Pikasack likes this.
  4. MsMidnight

    MsMidnight part time fe modder

    Member
    1,753
    1,308
    Oct 12, 2015
    kys
  5. Salamencizer
    OP

    Salamencizer Handsome Computer Nerd

    Member
    795
    647
    Oct 3, 2015
    India
    Below
    Oh thnx :P
    Yes we can :D but with so many people downgrading, seems like it's useless...
     
    CeeDee likes this.
  6. Yardape8000

    Yardape8000 GBAtemp Regular

    Member
    289
    279
    Feb 26, 2011
    United States
    I was hoping that this would allow me to permanently fix games that say they need an update on the home menu, but then error if you try upgrading.
    But it doesn't.
    Hopefully it is useful to those on older versions. Don't know if it does anything for 10.7 users.
     
  7. FenrirWolf

    FenrirWolf GBAtemp Psycho!

    Member
    4,347
    329
    Nov 19, 2008
    United States
    Sandy, UT
    Why not just run the latest version if you're on an emunand?
     
  8. Yardape8000

    Yardape8000 GBAtemp Regular

    Member
    289
    279
    Feb 26, 2011
    United States
    I'm on Al9h sysNAND 10.7. Far as I know the games (eg Cube Creator) are the latest, but they still say they need an update. Then if you do, it errors at the end and blanks out the game. You have to delete and reinstall.
    I was hoping that it would allow it to finish as the updates always get to 100% before erroring.
     
  9. FenrirWolf

    FenrirWolf GBAtemp Psycho!

    Member
    4,347
    329
    Nov 19, 2008
    United States
    Sandy, UT
    That might be a separate issue. I was talking to someone else who ran into a similar problem, and apparently what was wrong is that the game was looking for an update that didn't actually exist on Nintendo's servers. So they had to fix it either by getting a different CIA or by finding an update CIA elsewhere, or something along those lines.
     
    emuashui likes this.
  10. MuscleMuscleHust

    MuscleMuscleHust Advanced Member

    Newcomer
    92
    12
    Apr 12, 2016
    United States
    .cia version?
     
  11. Salamencizer
    OP

    Salamencizer Handsome Computer Nerd

    Member
    795
    647
    Oct 3, 2015
    India
    Below
    we'll get that when someone builds it.
     
  12. Xiphiidae

    Xiphiidae ξίφος εἶδος

    Member
    2,080
    1,016
    Sep 13, 2009
    Australia
    If you had access to installing .cias, why would you even need httpwn?
     
  13. Hopalongtom

    Hopalongtom GBAtemp Regular

    Member
    233
    33
    Mar 14, 2009
    Works great installing updates and dlc for FE Fates and Hyrule Warriors legends, however it is relient on a 3rd party sever which I assume won't be around forever!
     
  14. Soulsilve2010

    Soulsilve2010 GBAtemp Regular

    Member
    282
    60
    Sep 3, 2016
    United States
    United States,Indiana
    Edit:Wrong thread,didn't mean to comment on an old one.
     
    Last edited by Soulsilve2010, Dec 2, 2016
  15. amiibohound

    amiibohound Member

    Newcomer
    16
    1
    Mar 4, 2017
    United States
    Does ctr-httpwn still work?
     
  16. NTE78

    NTE78 Member

    Newcomer
    33
    4
    Mar 20, 2017
    United States
    Memelord City
    Yeah.
     
  17. amiibohound

    amiibohound Member

    Newcomer
    16
    1
    Mar 4, 2017
    United States
    Thanks!
     
  18. ChicagoMel

    ChicagoMel GBAtemp Regular

    Member
    242
    5
    Sep 1, 2015
    United States
    Is this useful with some of the stuff being broken on the new 11.4 update even on al9H? And was a CIA ever made?
     
  19. AyanamiRei

    AyanamiRei GBAtemp Fan

    Member
    380
    64
    Sep 24, 2015
    France
    There is no CIA.
    I don't know about it being useful or not under 11.4. But until today, it prevented my 11.2 n3DS (and o2DS) to download the system updates and its browser to be blocked (by receiving the nintendo signal of outdated browser version).

    If someone knows what to do, I would like to get rid of the browser nag who prevents me from using my main internet device ^^". Is ctr httpwn permanently nable to block this thing ? Did Nintendo change something?
     
  20. Darksabre72

    Darksabre72 Advanced Member

    Newcomer
    82
    7
    Nov 26, 2016
    United States
    umm i am having errors with ctr-httpwn and its saying that the haxx setup failed.