NULL

Configurable USB Loader

Discussion in 'Wii - Backup Loaders' started by oggzee, Apr 11, 2009.

  1. ModdingBird

    ModdingBird Advanced Member

    Newcomer
    2
    Jul 31, 2013
    Canada
    Planet Earth

    WOOT! Problem resolved after upgrading to Cfg70 r65 ! :grog:
     
  2. Tenzen

    Tenzen Advanced Member

    Banned
    1
    Aug 18, 2013
    Switzerland
    I have everything on a FAT USB Drive, no WBFS Partition, everything on FAT, including all my homebrew stuff, WADs, NANDs, etc..

    I've also disabled Write Playstats since i read thats incompatible with getting back to a Channel

    Thanks
     
  3. Tenzen

    Tenzen Advanced Member

    Banned
    1
    Aug 18, 2013
    Switzerland
    hmm.. I'd use WiiBackupManager to turn them into wbfs then throw them on an old laptop harddrive reformatted to FAT with a USB case, just for playing

    Have you thought about maybe connecting a DVD Drive from SATA to USB and then burning wbfs files to disks, that might work

    Otherwise, do you have more than one game on a dual layer? or else why do u need dual layer? can you just burn it to a normal Disk?
     
  4. Brosus

    Brosus Newbie

    Newcomer
    1
    Aug 18, 2013
    United States

    Hm... Those might work, but I try to use my USB slot as little as possible. My wii is an old one, and the USB slots act up a lot, so I'd like to try to get the dual layer discs working...
    I'm only using Dual Layer discs for the games that require 8 GB, like Xenoblade. I'm pretty certain they wouldn't work split up on two regular discs...
     
  5. oggzee
    OP

    oggzee GBAtemp Addict

    Member
    2
    Apr 11, 2009
    Slovenia
    Wow, that is a lot of new stuff!
    Great job guys! B-) :bow:
    I guess you could just start calling this cfg-mod-71 or cfg71 or something, as it is clear that you have taken over the development and it is also very very unlikely that I will make any new releases, and even if i would I would probably use your code as a base since it contains so much new stuff.
     
  6. AbdallahTerro

    AbdallahTerro da KiNG

    Member
    11
    Jan 14, 2012
    Ideas factory :)
    +1 for 71 when that neek2o launching bug and more get cleaned :)
     
  7. antking3806

    antking3806 Newbie

    Newcomer
    2
    Aug 12, 2007
    United States
    First I've been using cfg loader for years...Now I'm getting into Rockband 2 and 3 (I know I'm late) but I wanted to use the eumnand for the additional save space and it works great with Rockband 2 but when I start Rockband 3 it locks up.
    The feature I would like added is per-game emunand so I could select a different emunand for rockband 3 to run off of.
    I'm not sure how hard it would be to add in but it doesn't hurt to ask right?
     
  8. Xavi

    Xavi Newbie

    Newcomer
    1
    Aug 20, 2013
    I don't seem to be able to run games from an emulated NAND. I run with a USB with 3 partitions: WBFS, NTFS (unused) and a FAT partition for the emulated NAND. I've set emu_nand_path=usb3:/nand, and the titles appear in the loader properly (I've even downloaded covers for them).

    Whenever running a WiiWare title, the loader stays stuck with the following:

    Code:
    Starting game...
    Setting game info...
    GameID: 57413250
    Check savegame...
    Reading TMD...Reading TMD failed
    .dol loading failed
    Don't know if it might have something to do, but the title I'm running has got a saved game on the emuNand. The same happens with titles without saved games.

    I've also noticed what someone mentioned above about sneek2o not working. I've tried renaming neek2o.dol to mighty.dol, but doing so results in a DSI exception.

    Tried running with d2xv8 (base 56) and 222 (Hermes). Also tried with r50 (console resets back to SM) and with r51 (same results as with r65). Also tried setting the working partition in the loader to the third one (FAT).

    The titles run fine from USB Loader GX and Mighty Channels.

    I'd really enjoy running all games from my favourite loader! Has anybody experiencied this before, or have an idea why this might be happening?
     
  9. Maxternal

    Maxternal Peanut Gallery Spokesman

    Member
    9
    Nov 15, 2011
    Deep in GBAtemp addiction
    I think the problem here is that neek2o unfortunately only knows how to look at your first partition.
     
    Xavi likes this.
  10. Xavi

    Xavi Newbie

    Newcomer
    1
    Aug 20, 2013

    That is perfectly reasonable, thanks for the info. The mighty plugin should, however?

    Also, would neek2o read the emuNand if it's in a first NTFS partition? I could consider moving the wbfs partition to the ntfs with WiiBackupManager and delete it, then put the NAND in it.
     
  11. Maxternal

    Maxternal Peanut Gallery Spokesman

    Member
    9
    Nov 15, 2011
    Deep in GBAtemp addiction
    Actually, not sure. Never tried. It seems like it should.
    Unfortunately, both methods of emuNAND loading can only be done with a FAT32 partition.
     
    Xavi likes this.
  12. Fishaman P

    Fishaman P Speedrunner

    Member
    7
    Jan 2, 2010
    United States
    Wisconsin
    I'm having issues with my new Wii I just hacked. On my old Wii, which is a Frankenstein's Monster of hacks, I ran Wii games with IOS222 and GC games with DIOS MIOS 2.10, from CFG Loader v70r51. It worked just fine.

    On my new Wii, loading Wii games via IOS222 works fine, like normal. However, when I try to run any GC game, CFG tells me that "Devolution only accepts clean dumps." I'm not trying to use Devolution. I would switch to Devolution since I have a working disc drive now, but I need to use trimmed dumps for space reasons.

    So, why isn't CFG recognizing/using DIOS MIOS? I installed it over itself 3 times, with no luck. Updating to v70r65 had no effect.
     
  13. Xavi

    Xavi Newbie

    Newcomer
    1
    Aug 20, 2013
    It seems clear the error posted above when launching emuNand titles from a non-first partition is occurring while trying to read the title from the emuNand. Mighty plugin probably doesn't support it. I've taken a look at the source code and the log traces seem to indicate clearly that ISFS_Open returns < 0 (must be passing through this commented printf). Don't know if it's a limitation of libogc (maybe not likely given this works with mighty channels and usb loader gx), or maybe it's just the mighty plugin not allowing reading emuNand from a non-first partition.

    Anyway, I've started moving my HD to ditch the wbfs partition and prepare a primary active FAT32 partition with 32Kb blocks to put there the emuNand. Wii backups will be moved to a second NTFS partition. Don't know if it's worth to move them to the FAT partition. Hopefully CFG will be able to launch the titles, with the mighty plugin or neek2o. I'll confirm when I test it.
     
  14. Xavi

    Xavi Newbie

    Newcomer
    1
    Aug 20, 2013

    Ater moving all Wii backups and WiiWare titles to the first FAT32 partition of the drive, and setting emu_nand_path=usb0:/NAND, I observe the very same behavior. DSI Exception with neek2o, and Reading TMD...Reading TMD Failed! with mighty plugin.

    Ater moving all Wii backups and WiiWare titles to the first FAT32 partition of the drive, and setting emu_nand_path=usb:/NAND, mighty plugin is loading the titles! neek2o, however, keeps throwing a DSI Exception.

    Somewhere I read that specifying partitions on emu_nand_path (usb2:/nand) was possible, but not tested. I think this could confirm it doesn't work at this point.
     
  15. Jabe

    Jabe GBAtemp Regular

    Member
    2
    Aug 28, 2009
    France
    Hi!

    I'm glad to see that CFG-MOD has been updated and I have several questions:

    1) Will it be possible to update translations? (Particularly to translate new genres & game types)
    I'm official French translator and was used to translate based on this topic (click)

    2) Is there any way to play video banner like WiiFlow & USB Loader GX ?

    3) Is there any step-by-step tutorial to play VC or WiiWare Games with CFG?

    Let me know!
     
  16. Floating Seal

    Floating Seal Member

    Newcomer
    5
    Oct 29, 2012
    United States
    I have a problem with CFG not finding either of my nand backups. I've set the nand emu path to both usb1:/nand and usb1:/nands/pln2o but when I filter my game list to all channels it says no games found, and clicking on a blank entry gives me the Wii Sports banner music for some reason. :blink:
     
  17. gthirst

    gthirst Newbie

    Newcomer
    1
    Sep 1, 2013
    United States
    So I was working all fine and dandy on an older version of CFG. I think v70. Then I installed DML and put all my GC games on my SD card. I then updated CFG to v70 r65. I get a freeze now any time I have a USB Drive plugged in. If I keep it unplugged, I can see and play GC games just fine. But if I try to use anything from USB it freezes.

    So I decided to try the latest versions of some other loaders to see if it was a CFG bug. I put on WiiFlow and USB Loader GX. WiiFlow, everything seems to be working fine until I load a game. Then it freezes. USB Loader GX freezes when initializing USB Drive.

    I tried 3 different USB drives, which have all worked in the past. A 64gb San Disk Cruzer, which was my primary for months until I upgraded to a 128gb PNY Attache. I also tried a Seagate Freeagent GoFlex 1 TB, which I had used a long time ago before I bought flash drives. None worked in multiple format types.

    Originally, they were NTFS w/ wbfs folders. Currently, my 128gb is FAT32 with a wbfs folder. I reformated the 128 from NTFS to WBFS to FAT32 and still no luck.

    Could it be a certain game is causing it? The drive reads fine in Wii Backup Manager and windows.

    Could it be the USB port is burned out? I tried switching to USB Port 1 in USB Loader GX but it didn't find anything.

    A little lost here and would like some help.

    Thanks guys!



    sysCheck v2.1.0b19 by Double_A and R2-D2199 Nano
    ...runs on IOS58 (rev 6176).

    Region: NTSC-U
    System Menu 4.3U (v513)
    Priiloader installed
    Drive date: 2006.05.26
    Homebrew Channel 1.1.2 running on IOS58
    HomebrewFilter ist nicht installiert
    Hollywood v0x11
    Console ID: 68098372
    Boot2 v4
    Found 116 titles.
    Found 55 IOS on this console. 3 of them are stub.

    IOS4 (rev 65280): Stub
    IOS9 (rev 1034): No Patches
    IOS10 (rev 768): Stub
    IOS11 (rev 16174): Trucha Bug NAND Access
    IOS12 (rev 526): No Patches
    IOS13 (rev 1032): No Patches
    IOS14 (rev 1032): No Patches
    IOS15 (rev 1032): No Patches
    IOS16 (rev 54321): Trucha Bug ES Identify Flash Access NAND Access
    IOS17 (rev 1032): No Patches
    IOS20 (rev 16174): Trucha Bug NAND Access
    IOS21 (rev 1039): No Patches
    IOS22 (rev 1294): No Patches
    IOS28 (rev 1807): No Patches
    IOS30 (rev 16174): Trucha Bug NAND Access
    IOS31 (rev 3608): No Patches
    IOS33 (rev 3608): No Patches
    IOS34 (rev 3608): No Patches
    IOS35 (rev 3608): No Patches
    IOS36 (rev 3608): No Patches
    IOS37 (rev 5663): No Patches
    IOS38 (rev 4124): No Patches
    IOS40 (rev 16174): Trucha Bug NAND Access
    IOS41 (rev 3607): No Patches
    IOS43 (rev 3607): No Patches
    IOS45 (rev 3607): No Patches
    IOS46 (rev 3607): No Patches
    IOS48 (rev 4124): No Patches
    IOS50 (rev 16174): Trucha Bug NAND Access
    IOS51 (rev 4864): Stub
    IOS52 (rev 16174): Trucha Bug NAND Access
    IOS53 (rev 5663): No Patches
    IOS55 (rev 5663): No Patches
    IOS56 (rev 5662): No Patches
    IOS57 (rev 5919): No Patches
    IOS58 (rev 6176): USB 2.0
    IOS60 (rev 16174): Trucha Bug NAND Access
    IOS61 (rev 5662): No Patches
    IOS62 (rev 6430): No Patches
    IOS70 (rev 16174): Trucha Bug NAND Access
    IOS80 (rev 16174): Trucha Bug NAND Access
    IOS90 (rev 54321): Trucha Bug
    IOS202[60] (rev 65535 Info: hermesrodries-v6): Trucha Bug NAND Access USB 2.0
    IOS222[38] (rev 4 Info: hermes-v4): Trucha Bug ES Identify NAND Access USB 2.0
    IOS223[38+37] (rev 4 Info: hermes-v4): Trucha Bug ES Identify NAND Access USB 2.0
    IOS224[57] (rev 65535 Info: hermesrodries-v6): Trucha Bug NAND Access USB 2.0
    IOS236[36] (rev 65535 Info: rev 3351): Trucha Bug ES Identify NAND Access
    IOS245[37] (rev 21008 Info: d2x-v8final): Trucha Bug NAND Access USB 2.0
    IOS246[38] (rev 21008 Info: d2x-v8final): Trucha Bug ES Identify NAND Access
    IOS247[53] (rev 21008 Info: d2x-v8final): Trucha Bug NAND Access USB 2.0
    IOS248[55] (rev 21008 Info: d2x-v8final): Trucha Bug NAND Access USB 2.0
    IOS249[56] (rev 21008 Info: d2x-v8final): Trucha Bug NAND Access USB 2.0
    IOS250[57] (rev 21008 Info: d2x-v8final): Trucha Bug NAND Access USB 2.0
    IOS251[58] (rev 21008 Info: d2x-v8final): Trucha Bug NAND Access USB 2.0
    IOS254 (rev 65281): BootMii
    BC v6
    MIOS v10 (DIOS MIOS Lite 2.6+)

    Report generated on 2013/09/01.

    edit: Just reinstalled all WAD. Same problems. Gonna try modding the vWii on my Wii U. Maybe my Wii will turn in to a Gamecube backuploader only. Only thing I can think of now is it could be an SD card problem.

    edit 2: Very strange. Installed homebrew channel and hacks into my Wii U. Everything was going smoothly, downloaded covers for all the games, etc. Clicked a game, bam, CRASH. If I delete the config.txt file on my wii or wii U, I'm able to get into the games list at least. When I select a game, it then crashes. So, where does this leave me? I honestly have no idea since I have tried multiple USB devices, two different systems, etc. Could a USB flash drive be not getting enough power and I need to use a y Cable? I never needed it before.

    I really am confused now.
     
  18. icebrg5

    icebrg5 GBAtemp Addict

    Member
    3
    Apr 1, 2007
    United States

    Try starting with a fresh install of the latest cfg. Delete your config.txt file and delete all the covers you have downloaded.
    I've had it happen to me in the past where a corrupt cover jpg/png file would cause dsi errors while scrolling through the list of covers.

    Also it could be the sd card your using causing the issues. Make sure that the card isn't in the locked position and also make sure that cfg loader
    didn't make and config files on the sd card itself. It could be a conflict of config.txt files being on both the sd card and the usb drive.

    It could also be the brand of sd card itself your using. DML is picky when it comes to sd cards and I've had cards that fail every time when trying
    to load a GC game but if i switch it to a different brand sd card that has known working compatibility it works flawlessly. So try another sd card if you can and see if the issues go away.

    Also make sure you have the proper settings enabled with cfg settings options. You should be able to select from DML,DM,and Devolution.
    You could also try DM and get rid of the sd card all together and just try to see if the GC work from the usb drive you already have rather then the sd card.
     
  19. Toziko

    Toziko Newbie

    Newcomer
    1
    Sep 2, 2013
    United States
    Hello everyone here. I don't know what else to do but I'm having some trouble with cfg, believe me this was the last thing I wanted to do (make an account to just ask a question). Anyways I think this is the right place for this. Here's the deal.
    I have cfg 70r65 and I just put in Dios Mios v2.10
    my gc games work fine but every time I try to save or play one it says the save file is corrupted. I want to try and use NMM through my usb but idrk the directory for it, I've tried putting the NMM converted file (from .gci) into folders named saves and gcsaves but nothing works. I read that you aren't suppose to have a MC in while you use NMM either but the games say there is no MC in slot A. So I don't know if it's actually reading saves from the SD
    If anyone who wants to help me has any questions I'll try my best to answer. Thank you.

    Side questions:
    Twilight princess goes black screen right before title screen.
    sometimes when I load a GC game with dios mios it either works, turns off, or black screens.

    Thank you again.
     
    Brian Howard likes this.
  20. gthirst

    gthirst Newbie

    Newcomer
    1
    Sep 1, 2013
    United States
    Hey thanks for the advice. I think you could have been spot on about the covers. I'm now using a hard drive with a Y Cable on my Wii U with no covers downloaded and so far so good. I'm going to see what happens when I put my 128gb flash drive back on with no covers. Then I'll probably download a few games worth of covers to see which one is causing the problem.

    I'll edit with an update and try to see if it works with my standard wii as well. Was trying to keep my Wii U Legit, but seems like my Wii just turned into a Gamecube loader.

    edit: So with no covers, I still get a crash using my flash drives, I'm thinking it is actually a corrupt game on the drives. I'll keep testing when I get time throughout the week.
     
Loading...
NULL