Compatibility with the Trainer Toolkit

Discussion in 'Acekard' started by hawkeye2777, Mar 24, 2009.

  1. hawkeye2777
    OP

    hawkeye2777 Newbie

    Newcomer
    2
    0
    Mar 12, 2009
    United States
    Ok, I want to get the Acekard 2 for my DS. After mass searching, I have decided on this card. However, that searching (both Google and this site) did not provide any information regarding compatibility with the Trainer Toolkit.

    So simply, all I'm asking for is a simple confirmation on if Datel's Trainer Toolkit will work with the AK2 using kenobi's Trainer Toolkit rom patcher. I do not want to get the card if it doesn't work with the Trainer Toolkit, as part of my whole reason for getting a flashcard in the first place is so I can hack games with it.
     
  2. Another World

    Another World Emulate the Planet!

    Former Staff
    10,490
    1,630
    Jan 3, 2008
    Colombia
    From Where???
    i honestly have never heard of that, and before i use google, what is it? if it simply alters the rom image in some way then you only need to give the rom a valid header to have it work on the acekard. you can use ndstools to do this. c:> ndstool -f file.nds.

    -another world
     
  3. hawkeye2777
    OP

    hawkeye2777 Newbie

    Newcomer
    2
    0
    Mar 12, 2009
    United States
    Since I wouldn't be able to describe it myself, here's an excerpt from the readme which describes the program:

    Basically, as I understand it, it simply inserts the hooks for the Trainer Toolkit into the rom. If you know if the AK2 disables the DS's ARM7 GBA access, then I'll know that the Trainer Toolkit won't work with the AK2.
     
  4. Another World

    Another World Emulate the Planet!

    Former Staff
    10,490
    1,630
    Jan 3, 2008
    Colombia
    From Where???
    this should work just fine, it's just patching to the gba rom. you will need a valid header on the gba rom after you "hack" it. i would suggest gbata

    give it a shot and let us know if it all works out.

    -another world
     
  5. Normmatt

    Normmatt Former AKAIO Programmer

    Member
    2,142
    543
    Dec 14, 2004
    New Zealand
    There is no reason to disable the GBA slot on the arm7 so of course it will work. But there might be a problem with the compressed arm7, If i remember correctly that was replaced in a newer version of the game with something else so it should work fine.