Can't update Luma due to update failed

Discussion in '3DS - Flashcards & Custom Firmwares' started by Realxabbynip09, Jul 11, 2017.

  1. Realxabbynip09
    OP

    Realxabbynip09 Member

    Newcomer
    13
    1
    Apr 23, 2017
    United States
    I keep hearing about the Rosalina HBL thing, and I decide to update it for Nintendo's update for the 3ds due to the new 2ds xl. However, once I pick or press A for download that build, I get the update failed and it's reason for it is Download fail. I think I need help for this one. If I were correct, I haven't test the hourly build update download yet, but I'll let you know about that through edit, got that? Okay, thanks!
    Edit: It looks like they didn't find arm9loader.bin and didn't find the payload. Maybe the reason for it is I was trying to download Miitopia JAP version with region free. Since it didn't have room, I literary delete some stuff I don't need, but tdidn't think about the arms9 stuff. Does anyone have the folder for arms9loader because I already install the things I needed for my games.
    EX: Tomodachi life save editor. (Tell Brion I said thanks!)
    Anyway please any thank you.
     
    Last edited by Realxabbynip09, Jul 11, 2017
  2. Lacius

    Lacius GBAtemp Guru

    Member
    6,125
    2,450
    May 11, 2008
    United States
    Are you using A9LH, or are you using B9S? All new versions of Luma3DS require B9S. If you haven't already updated from A9LH to B9S, follow this guide: https://3ds.guide/a9lh-to-b9s

    The guide will also walk you through installing a new version of Luma3DS Updater that is compatible with B9S boot.firm files.
     
  3. KunoichiZ

    KunoichiZ GBAtemp Guru

    Member
    8,130
    3,300
    Mar 16, 2012
    United States
    Do you have b9s? If not, follow https://3ds.guide/a9lh-to-b9s. Download failed likely suggests that A) you still have A9LH and B) Rosalina is only usable on Luma 8.0+, which requires boot9strap (b9s).

    Edit: Ninja'd by Lacius.
     
  4. Lacius

    Lacius GBAtemp Guru

    Member
    6,125
    2,450
    May 11, 2008
    United States
    Based on the edit just done by OP, she's still using A9LH and an outdated version of Luma3DS Updater. Follow the above guide to update to B9S.
     
  5. Realxabbynip09
    OP

    Realxabbynip09 Member

    Newcomer
    13
    1
    Apr 23, 2017
    United States
    read the edit please. I saw the alert while typing the edit, but in case of a another error, I'll do it.
     
  6. KunoichiZ

    KunoichiZ GBAtemp Guru

    Member
    8,130
    3,300
    Mar 16, 2012
    United States
    No, you need to follow the guide we linked in order to update Luma. There is no other way. We did read the edit. :/
     
  7. Lacius

    Lacius GBAtemp Guru

    Member
    6,125
    2,450
    May 11, 2008
    United States
    See above for my response to your edit. You are apparently using an old version of Luma3DS Updater that wants to download the arm9loaderhax.bin file for the newest version of Luma3DS. However, all new versions of Luma3DS don't support A9LH anymore, which means there are no arm9loaderhax.bin files to download. You need to follow the above guide to update to B9S. The guide will walk you through the following:
    • Installing B9S
    • Installing the Luma3DS 8.1 boot.firm file
    • Installing a new version of Luma3DS Updater that knows to download the latest boot.firm files (instead of arm9loaderhax.bin files) for future versions of Luma3DS
     
  8. Realxabbynip09
    OP

    Realxabbynip09 Member

    Newcomer
    13
    1
    Apr 23, 2017
    United States
    I did. :/
     
  9. KunoichiZ

    KunoichiZ GBAtemp Guru

    Member
    8,130
    3,300
    Mar 16, 2012
    United States
    If you did follow the guide already, then you should be using the new fork of Luma Updater to update Luma instead of the old one.
     
  10. Lacius

    Lacius GBAtemp Guru

    Member
    6,125
    2,450
    May 11, 2008
    United States
    You did what? Are you saying you followed the above guide to install B9S? Did you follow the entire guide and install the new version of Luma3DS Updater? You shouldn't be receiving any errors about arm9loaderhax.bin, because that's outdated.
     
  11. Realxabbynip09
    OP

    Realxabbynip09 Member

    Newcomer
    13
    1
    Apr 23, 2017
    United States
    For the first one in the quote, I was talking about B9S. the last two, I'm not finish yet, but I'm on the second part of installing Boot9strap.
     
  12. Lacius

    Lacius GBAtemp Guru

    Member
    6,125
    2,450
    May 11, 2008
    United States
    As we've mentioned several times, following the guide should solve your problem. Finish the guide first.
     
  13. Realxabbynip09
    OP

    Realxabbynip09 Member

    Newcomer
    13
    1
    Apr 23, 2017
    United States
    Okay, I follow the guide and it works. Now, can someone tell me about the homebrew Rosalina 2.0 stuff so that way I can still use the jstr save manger.
     
  14. Lacius

    Lacius GBAtemp Guru

    Member
    6,125
    2,450
    May 11, 2008
    United States
    You can always install the JKSM CIA file using FBI so you don't even need to enter the homebrew launcher to use JKSM.

    If you would rather use the homebrew application, then you can do the following:
    1. Make sure you have this boot.3dsx on the root of your SD card
    2. Make sure you have the JKSM 3dsx homebrew application in the 3ds folder on your SD card
    3. Launch the Download Play application
    4. Press (L) + (Down) + (Select) at the same time to open the Rosalina menu
    5. Select “Miscellaneous options”
    6. Select “Switch the hb. title to the current app.”
    7. Press (B) to continue
    8. Press (B) to return to the Rosalina main menu
    9. Press (B) to exit the Rosalina menu
    10. Press (Home), then close Download Play
    11. Launch the Download Play application
    12. Your device should load the Homebrew Launcher, where you can launch JKSM
     
  15. Realxabbynip09
    OP

    Realxabbynip09 Member

    Newcomer
    13
    1
    Apr 23, 2017
    United States
    Thank you. If I have a hat, I would tip you.