Can't build HANS from source

Discussion in '3DS - Homebrew Development and Emulators' started by TuxSH, Nov 19, 2015.

  1. TuxSH
    OP

    TuxSH GBAtemp Advanced Fan

    Member
    612
    993
    Oct 19, 2015
    France
    I've installed the latest version of ctrulib from source, but can't manage to build HANS from source.

    It seems to be using a different SDK (missing files and functions / different names) that the libctru version available on Github. It could be an older version of ctrulib.

    Thanks in advance.
     
    Last edited by TuxSH, Nov 19, 2015
  2. ihaveamac

    ihaveamac GBAtemp Guru

    Member
    5,467
    5,961
    Apr 20, 2015
    United States
    Tigard, OR
  3. Shadowtrance

    Shadowtrance GBAtemp Addict

    Member
    2,488
    1,517
    May 9, 2014
    Hervey Bay, Queensland
    Nope that isn't it.
    The "loader" part of HANS indeed DOES use an old version of libctru. The main part doesn't though.
    Here's my semi standalone hans source folder after i figured out everything to get it to build. :)

    For some reason it won't load my Neo Y romfs though... I don't know why. :(
     

    Attached Files:

    Last edited by Shadowtrance, Nov 20, 2015
    ihaveamac likes this.
  4. MasterLel

    MasterLel /x69/x73/x73/x6f/x75

    Member
    1,244
    450
    Mar 14, 2015
    France
    France
    The .3dsx files checksums are the same ?