Burn PSX Games

Discussion in 'Sony PlayStation 1 & 2' started by GentleFist, May 13, 2010.

May 13, 2010

Burn PSX Games by GentleFist at 9:51 PM (875 Views / 0 Likes) 4 replies

  1. GentleFist

    GentleFist Newbie


    I have a PS1 - PAL Version - SCPH 7502

    and it has a modchip (don't know the name seems there were only 1 modchip for the PS1~?)

    I wan't to burn a game but it gets stuck at the playstation logo~

    the ps isn't faulty because ive tried other games both original and copied and they did work~

    are there some special rules when you are burning ps games?

  2. OSW

    Former Staff OSW Wii King

    Oct 30, 2006
    Theres no special way to burn afaik.

    I'd put it down to one of two things...
    1. Game does not match your console region. IIRC there are region patchers out there (google).
    2. Bad burns. Try different disks or something? (Not an expert on good burning strategies, but I've never had any problems with any disks)

    Leaning towards the region problem... let us know [​IMG]
  3. devilworld

    Newcomer devilworld Advanced Member

    Apr 12, 2010
    United Kingdom
    hi, im erm, uk,
    id like to help you as recently iv been doing alot of psx burning, but LOL iv had a drink so much of what ill say might not make sense or be missing spelling [​IMG] so ill try as much as i can in this state XD

    erm, best programmes i would say will help will be
    IMG burn (witch is freee yaaay XD [​IMG] for burning of the games)
    a site call something!!!!!!!!!! (**DERRRRR**)) **A LATION** SEARCH IT >,> GODD! lol!
    will give you usa games
    now .................

    tell you what, if youd like my help, message me, then i can try, im a bit **Drunk atm** to succsesfully help
    ill see your message tomorow etc, and if i can id gladly help

    p.s iv done around 100-150 over the last 3 months, i think i cuold help XD haha
  4. GentleFist

    GentleFist Newbie

    okay i tried all that but came to the conclusion that the region isn't the problem

    the way i burn isnt the problem either (tried at 1x too)

    it seems my lense is too old~ because i noticed it had problems loading on my retail games too, it does work with the retail games but no matter how much i clean it didnt work on my new copys

    one of my old copies worked but the other that worked a few years ago didnt

    conclusion: --> i need different media since my old lense cant read too well anymore
    or a new lense

    solution: --> too much of trouble to deal with~ i rather emulate on pc have hdmi cable too
    also i can play my retail disks on my ps2 anyway~

    lesson learnt: trying to revive old consoles is bad idea~ basics of alchemy console transmutation is forbidden
  5. Ultratech87

    Newcomer Ultratech87 Advanced Member

    Mar 14, 2009
    United States
    First off, download a PSX emulator and try to run the game from the disk. If it doesn't work, then it's likely a bad burn. Some games are really prone to bad burning (re: Valkyrie Profile).
    However, the lens may be messed up as you mentioned, and may need to be recalibrated or replaced. In that case, either attempt to fix the problem, buy another PS, or play on PC.
    Modchip could be giving you issues as well, but I don't know enough about that to elaborate on it.

Share This Page