Browser Stuff

Discussion in '3DS - Flashcards & Custom Firmwares' started by MarioMasta64, Mar 14, 2017.

  1. MarioMasta64
    OP

    MarioMasta64 hi. i make batch stuff and portable shiz

    Member
    1,914
    411
    Dec 21, 2016
    United States
    anyone know which browser version did the 3ds start saying "The Internet browser cannot be used at this time." if you could give the version number this would be wonderful (i.e. 0004000blablabla vblah) but a browser version is fine too
     
  2. MarioMasta64
    OP

    MarioMasta64 hi. i make batch stuff and portable shiz

    Member
    1,914
    411
    Dec 21, 2016
    United States
    -snip-
     
    Last edited by MarioMasta64, Mar 14, 2017
  3. Alex658

    Alex658 GBAtemp Maniac

    Member
    1,152
    340
    Jun 4, 2010
    Venezuela
    Venezuela
    If I remember correctly the browser started checking for a minimum version against the server on 10.5 (old 3ds), 10.2 (n3ds).

    To quote @zoogie's post from last year:


    EDIT: It's officially on 9.9 that the browser started checking for updates and disabling itself if it found there was a newer one.
     
    Last edited by Alex658, Mar 14, 2017
  4. MarioMasta64
    OP

    MarioMasta64 hi. i make batch stuff and portable shiz

    Member
    1,914
    411
    Dec 21, 2016
    United States
    oh wow this is extremely helpful. thanks. so imma install me a 10.2 browser now
     
  5. Alex658

    Alex658 GBAtemp Maniac

    Member
    1,152
    340
    Jun 4, 2010
    Venezuela
    Venezuela
    Read my edited post. It's on 9.9 that the browser became self aware of updates.
    You would need to install a <9.9 browser. Butttt, i don't know if the home menu would boot with a lowered browser, as it may (or may not) be included in the minimum version checklist that was introduced in 11.0+
     
  6. MarioMasta64
    OP

    MarioMasta64 hi. i make batch stuff and portable shiz

    Member
    1,914
    411
    Dec 21, 2016
    United States
    so less than 9.9 or can it be exactly 9.9?

    — Posts automatically merged - Please don't double post! —

    so basically it became self aware on firm v9.6.0-24

    — Posts automatically merged - Please don't double post! —

    9.3 browser it is? @~@

    — Posts automatically merged - Please don't double post! —

    upload_2017-3-14_10-27-28.png
    seems they took it down from NUS
     
  7. Alex658

    Alex658 GBAtemp Maniac

    Member
    1,152
    340
    Jun 4, 2010
    Venezuela
    Venezuela
    Well, according to 3dbrew:

    Spider would be the o3ds's browser if i recall correctly.
    You can do a NAND backup if you have a9lh and try to see if it boots. I mean, up to 11.2 booted with a 9.6 Native_FIRM, which is why RXtools kept working. I assume as a wild guess that up to 11.2 the minimum version list was on 9.6's modules. But i can't be sure on that. What I know for sure is that 11.3 requires 11.3's NATIVE_FIRM (and probably?) 11.3 versions of the other modules.
     
    Last edited by Alex658, Mar 14, 2017
  8. MarioMasta64
    OP

    MarioMasta64 hi. i make batch stuff and portable shiz

    Member
    1,914
    411
    Dec 21, 2016
    United States
    0004003000009402 v5121 works fine
     
    Last edited by MarioMasta64, Mar 14, 2017
  9. Alex658

    Alex658 GBAtemp Maniac

    Member
    1,152
    340
    Jun 4, 2010
    Venezuela
    Venezuela
    Isn't that 2.1.0-4's browser? WTF XD
    You'd have a very outdated browser... Then again, did they EVER update the browser to add any user-end functionality? 3dbrew obviously talks mainly about security patches.
     
  10. MarioMasta64
    OP

    MarioMasta64 hi. i make batch stuff and portable shiz

    Member
    1,914
    411
    Dec 21, 2016
    United States
    sorry sorry lol 3dbrew apparently has a few things messed up. i fixed it (adn apparently yes)

    — Posts automatically merged - Please don't double post! —

    oops im about to install a o3ds browser xD
     
  11. Alex658

    Alex658 GBAtemp Maniac

    Member
    1,152
    340
    Jun 4, 2010
    Venezuela
    Venezuela
    Exactly. 2.1 should not work on n3ds as it's SPIDER and not SKATER (n3ds's browser)
    Maybe v2051 (9.6.0-24's browser for n3ds) would work for you? The check was added in 9.9, so you'd need something lower than that and see if it boots. But again, do a NAND backup first.

    Honestly, it's easier to get up to 11.3 to have a functional browser if you have a9lh. Is there a specific reason why you wish to stay on 11.2 or lower while frankenfirmware-ing your browser?
     
    Last edited by Alex658, Mar 14, 2017
  12. MarioMasta64
    OP

    MarioMasta64 hi. i make batch stuff and portable shiz

    Member
    1,914
    411
    Dec 21, 2016
    United States
    v2051 is the one for 9.6 n3ds but it wont download D:

    — Posts automatically merged - Please don't double post! —

    it wont download using 3dnus re: ill try to download with 3dnus original

    — Posts automatically merged - Please don't double post! —

    maybe 3ds nus servers dont allow downloading 3ds browser @~@

    — Posts automatically merged - Please don't double post! —

    figured it out 0004003020009402 v2051 n3ds has a different browser so different title id (duh )