Broken A button or odd glitch? Faulty wiring?

Discussion in '3DS - Console, Accessories and Hardware' started by Zaaninja, May 12, 2016.

  1. Zaaninja
    OP

    Zaaninja Newbie

    Newcomer
    1
    0
    May 12, 2016
    Canada
    I'm having an odd issue with my original 3DS. This happened a few years ago now, but i've been wanting to give it away to someone. ( I've since replaced it. ) The 3DS is in alright condition, though the charger doesn't work unless you use a charging station.
    This happened one day while I was just casually playing a DS game. The A button stopped working all of a sudden. Now, it's very strange, because every hour or so, if I turn the system back on, the A button works for one press, and if I wait for say, a few months, it works for longer periods of time before stopping again. It's even more strange, because the "Home" button works perfectly for the majority of the time, but if I press the power button and go to the "In sleep mode, the system can..." screen, it doesn't work at all, just like the A button. I've tried formatting it, to no avail, and right now I'm stumped besides possibly opening it up.
    ( I would appreciate any help, and I just joined here. )

    EDIT: I just tried it again, and it seems to press the A Button if I close the system while on the Home Menu for some odd reason.
     
    Last edited by Zaaninja, May 12, 2016
  2. Avalynn

    Avalynn I'm here to help poeple out as I can.

    Member
    407
    205
    Feb 23, 2014
    United States
    San Jose, CA
    Doesn't sounds odd, depends on age, use, and condition but every electro-mechanical contractor has a lifespan. They typically can only be used for a range of presses or uses. Also as you use it, you ware away some of the contractors as they come into contact with each other. Over time, depending on the environment the contacts can oxide a bit based on the material. Every metal will oxidize at different rates but if it's pure gold it can take a very long time.

    Sounds like your button is over used and may just need to be replaced at this point. If you have reformatted, I doubt it is a software issue.

    Anyways things you can try is to clean the buttons but you have to clean in between the two contacts with something like DeoxIT. However getting button apart and back together can be challenge since these are SMT buttons and last I re-call they.

    Pressing them down more or harder will not usually help the situation but you may get lucky and if it's oxidized then pressing down can more can ware though that layer.
     
    Last edited by Avalynn, May 12, 2016
  3. astrangeone

    astrangeone GBAtemp Addict

    Member
    2,029
    586
    Dec 1, 2009
    Canada
    Canada
    Yup, I had that issue with an old 3DS. If you are brave, take it apart and get the motherboard contacts exposed. Take rubbing alcohol (the stuff for cleaning wounds) and a white eraser to the metal contacts. I had to do this for my debit card the other day and it annoyed the piss out of me.