boot9strap update, what about Luma ?

Discussion in '3DS - Flashcards & Custom Firmwares' started by Arck, Jun 4, 2017.

  1. Arck
    OP

    Arck GBAtemp Advanced Fan

    Member
    803
    390
    Mar 13, 2016
    So boot9strap got an update but what about Luma ?

    If there is a possible way to be banned, using Luma atm it would not be recommanded if we care about playing online, no ?

    Just asking because it seem that using installed homebrew is as dangerous as playing online with a public header on a flashcard.

    (not waiting answer like "Luma developper won't add a way to bypass ban", but if it's better to go back to OFW to wait a solution for those ban.

    Edit:
    I think you all misunderstood, everything work fine, I meant, will Luma be revelant since the banwave ?

    Since Nintendo can press a button to ban cfw people when they want...
     
    Last edited by Arck, Jun 4, 2017
  2. Quantumcat

    Quantumcat Dead and alive

    Member
    11,916
    6,410
    Nov 23, 2014
    Australia
    Canberra, Australia
    There's no point going OFW at this point. Homebrew use has already been logged and you may or may not get a future ban because of it. Going OFW is a bad idea because then you'd just have a banned console and have no way to unban. At least if you keep CFW you can unban after being banned.
     
  3. sp3off

    sp3off One male shadow.

    Member
    917
    258
    Apr 17, 2013
    France
    Hell's Lair
    Take the latest nightly, it works.
     
  4. Lilith Valentine

    Lilith Valentine GBATemp's Wolfdog™ ☠️Grunt☠️

    Member
    20,197
    21,577
    Sep 13, 2009
    Antarctica
    Between insane and insecure
    Luma3DS should actually work on 1.1 without an issue.
    As for the risk of being banned. Currently the banwave appears to have ended Friday 5/26. So if your system wasn't banned before that date, you should be good.
     
  5. MelonGx

    MelonGx GBAtemp Advanced Maniac

    Member
    1,634
    439
    Jan 8, 2009
    China
    Only B9S-NEXT branch of Luma nightly works.
    Every other Luma should have Unsupported launcher (argc = 0) error.
    However, TWL/AGB dies again currently.
     
  6. Lilith Valentine

    Lilith Valentine GBATemp's Wolfdog™ ☠️Grunt☠️

    Member
    20,197
    21,577
    Sep 13, 2009
    Antarctica
    Between insane and insecure
    Interesting, I will take note of that for reasons.
     
  7. MelonGx

    MelonGx GBAtemp Advanced Maniac

    Member
    1,634
    439
    Jan 8, 2009
    China
    It seems that TWL/AGB's death is caused by Internet builds.
    Compiling it yourself can fix it.
     
  8. Yepi69

    Yepi69 Vivid and busy gamer

    Member
    2,470
    1,056
    Nov 29, 2010
    Portugal
    Behind you
    Is it safe to update? I remember Scires saying that it isn't.

    Sent from my Vodafone Smart ultra 6 using Tapatalk
     
  9. adrifcastr

    adrifcastr GBAtemp Advanced Maniac

    Member
    1,801
    842
    Sep 12, 2016
    Germany
    you need the latest nightly of luma if you do update to 1.1
     
  10. linuxares

    linuxares GBAtemp Psycho!

    Member
    3,285
    1,409
    Aug 5, 2007
    It isn't safe to update. I did it before I read it wasn't xD
    All applications doesn't work except the latest Luma3DS nightly works. They throw errors at you, so I guess either a new boot9strap or updated .firm files for Safeboot9strap installer and godmode9 needs to be installed.
     
  11. Reecey

    Reecey Mario 64 (favorite game of all time)

    Member
    4,362
    1,130
    Mar 7, 2010
    At Home :)
    What is the easiest method to update from v1.0 to v1.1 of B9S, can you just use luma updater to do it? I have got v2.1.1 luma updater already installed on my n3dsxl. Is it actually necessary to update to v1.1 also I have read that it breaks your apps in luma/payload... like for example Decrypt9 etc..? so how would you solve that problem.
     
    Last edited by Reecey, Jun 4, 2017
  12. Yepi69

    Yepi69 Vivid and busy gamer

    Member
    2,470
    1,056
    Nov 29, 2010
    Portugal
    Behind you
    Waiting for a decent final release

    Sent from my Vodafone Smart ultra 6 using Tapatalk
     
    Reecey likes this.
  13. linuxares

    linuxares GBAtemp Psycho!

    Member
    3,285
    1,409
    Aug 5, 2007
    wait until the payloads come out that are updated. You don't have to be on 1.1 yet.
     
    Reecey likes this.
  14. Chrisssj2

    Chrisssj2 GBAtemp Maniac

    Member
    1,364
    116
    Feb 12, 2008
    Netherlands
    Bootstrap got update? where
     
  15. Reecey

    Reecey Mario 64 (favorite game of all time)

    Member
    4,362
    1,130
    Mar 7, 2010
    At Home :)
    Thanks. So this v1.1 is not a rush update I will wait for better instructions. I read so many members here seem to be updating to v1.1 already I thought it was something that was important to go ahead and do.
     
    Yepi69 likes this.
  16. linuxares

    linuxares GBAtemp Psycho!

    Member
    3,285
    1,409
    Aug 5, 2007
    Chrisssj2 likes this.
  17. Yepi69

    Yepi69 Vivid and busy gamer

    Member
    2,470
    1,056
    Nov 29, 2010
    Portugal
    Behind you
    You gain nothing from updating and it breaks a lot of stuff, you're better off waiting :)

    Sent from my Vodafone Smart ultra 6 using Tapatalk
     
    Quantumcat and retrofan_k like this.
  18. linuxares

    linuxares GBAtemp Psycho!

    Member
    3,285
    1,409
    Aug 5, 2007
    It's probably a lot of fixes for sure, like sometimes my 3DS won't turn off and I have to force it. Probably fixed in 1.1, but don't rush update this since you need latest hourly of Luma3DS and Godmode9 and Safeboot9strap installer won't work at the moment with boot9strap 1.1 since they need an update.

    My guess is that D0k3 already updated them but haven't made a precompiled packaged on the gits yet.
     
    Last edited by linuxares, Jun 4, 2017
  19. retrofan_k

    retrofan_k GBAtemp Advanced Maniac

    Member
    1,818
    1,114
    May 31, 2013
    Belarus
    Caves
    Seriously, don't fix if it ain't broken. No need to update to 1.1 b9s right now and using nightlies of Luma, you gain nothing at all.
     
    Last edited by retrofan_k, Jun 4, 2017
    elBenyo likes this.
  20. Bullseye

    Bullseye GBAtemp Fan

    Member
    303
    120
    Feb 22, 2016
    More like "no need" is that you shouldn't update until a new Luma official release comes out, unless you want to go with nightlies, because if you don't you end up with an error on startup.