Hacking Black screen issues with some titles only...

Todd265

Member
OP
Newcomer
Joined
Dec 4, 2017
Messages
17
Trophies
0
Age
52
XP
54
Country
United Kingdom
Hi all,

I'm new to this, but hoping someone might be able to help me out. I recently did a soft mod on my wii and installed USB Loader GX and put a bunch of titles on an wbfs formatted external hard drive using wii backup manager.

Everything went well, but only about half the titles load and run fully. The other half show a working menu for the title but as soon as you click the start button on the screen, the title either returns me to the USB Loader GX menu or it produces a black screen.

I'd be really grateful if anyone can help me work out why these other titles won't load - some examples of titles that aren't running are:

  • BeachFun
  • Littlest Pet Shop
  • Metal Slug Anthology
  • Rayman Raving Rabids 2
  • Super Monkey Ball Banana Splitz

I used Wii Backup manager to run a MD5 verification and it looks like all the titles are ok.

Below is my system log (hope that's the right terminology).

Thank you for reading and be grateful for any help you can offer!

Todd


SysCheck HDE v2.4.0 HacksDen Edition by JoostinOnline, Double_A, R2-D2199, and Nano
...runs on IOS58 (rev 6176).

Region: PAL
System Menu 4.3E (v514)

Drive date: 02.13.2007
Homebrew Channel 1.1.2 running on IOS58

Hollywood v0x11
Console ID: 81008369
Console Type: Wii
Shop Channel Country: Sweden (107)
Boot2 v4
Found 93 titles.
Found 46 IOS on this console. 17 of them are stubs.

IOS3 (rev 65280): Stub
IOS4 (rev 65280): Stub
IOS9 (rev 1034): No Patches
IOS10 (rev 768): Stub
IOS11 (rev 256): Stub
IOS12 (rev 526): No Patches
IOS13 (rev 1032): No Patches
IOS14 (rev 1032): No Patches
IOS15 (rev 1032): No Patches
IOS16 (rev 512): Stub
IOS17 (rev 1032): No Patches
IOS20 (rev 256): Stub
IOS21 (rev 1039): No Patches
IOS22 (rev 1294): No Patches
IOS28 (rev 1807): No Patches
IOS30 (rev 2816): Stub
IOS31 (rev 3608): No Patches
IOS33 (rev 3608): No Patches
IOS34 (rev 3608): No Patches
IOS35 (rev 3608): No Patches
IOS36 (rev 3608): No Patches
IOS37 (rev 5663): No Patches
IOS38 (rev 4124): No Patches
IOS40 (rev 3072): Stub
IOS41 (rev 3607): No Patches
IOS43 (rev 3607): No Patches
IOS45 (rev 3607): No Patches
IOS46 (rev 3607): No Patches
IOS48 (rev 4124): No Patches
IOS50 (rev 5120): Stub
IOS51 (rev 4864): Stub
IOS52 (rev 5888): Stub
IOS53 (rev 5663): No Patches
IOS55 (rev 5663): No Patches
IOS56 (rev 5662): No Patches
IOS57 (rev 5919): No Patches
IOS58 (rev 6176): USB 2.0
IOS60 (rev 6400): Stub
IOS61 (rev 5662): No Patches
IOS70 (rev 6912): Stub
IOS80 (rev 6944): No Patches
IOS222 (rev 65280): Stub
IOS223 (rev 65280): Stub
IOS249 (rev 65280): Stub
IOS250[57] (rev 65535, Info: d2x-v10beta52): Trucha Bug, NAND Access, USB 2.0
IOS254 (rev 65280): Stub
BC v6
MIOS v10
Report generated on 12/04/2017.
 

Todd265

Member
OP
Newcomer
Joined
Dec 4, 2017
Messages
17
Trophies
0
Age
52
XP
54
Country
United Kingdom
What region are the titles that are not running? I know I downloaded everything PAL just to make sure it worked.

I thought that might be the issue too, but they are all various regions. So for example, from the working titles, there are both PAL and NTSC as far as I am aware. So I don't think the region is the issue. From what I've understood from researching this, I think USB Loader deals with the region compatibility upon loading the title, so there's no need to make your wii region free (if I understood correctly)...

From the titles that are not working, I can't see any common link, but it's true some of them are NTSC...

Thanks

T
 

Cyan

GBATemp's lurking knight
Former Staff
Joined
Oct 27, 2002
Messages
23,723
Trophies
4
Age
44
Location
Engine room, learning
XP
15,464
Country
France
metal slug always worked for me, same for raving rabbids 2.
I think metal slug is a dol reloading game, but IOS250[57] (rev 65535, Info: d2x-v10beta52) is good and taking care of the reloading issue.

if you use a different region than your console, be sure you set the video mode to "disc default" to set the video mode to the one used by the game.
if not working, enable the "dol video patching" option with "all" and try again.

some game are not compatible in other region (like the sega game, in black&white that I always forget the name :P)
 
  • Like
Reactions: Todd265

Todd265

Member
OP
Newcomer
Joined
Dec 4, 2017
Messages
17
Trophies
0
Age
52
XP
54
Country
United Kingdom
I just checked at home and Metalslug is not working with me as I have NTSC... so that title is PAL only for me...

Thanks so much for looking into this for me. I really appreciate it!

Todd

--------------------- MERGED ---------------------------

metal slug always worked for me, same for raving rabbids 2.
I think metal slug is a dol reloading game, but IOS250[57] (rev 65535, Info: d2x-v10beta52) is good and taking care of the reloading issue.

if you use a different region than your console, be sure you set the video mode to "disc default" to set the video mode to the one used by the game.
if not working, enable the "dol video patching" option with "all" and try again.

some game are not compatible in other region (like the sega game, in black&white that I always forget the name :P)

Thanks for this Cyan. I checked and;

  • video mode was set to disc default already.
  • dol video patching was off but I changed it to all.

Despite doing that, I still can't play these titles - they still go to black screen...

Anything else you can think of?

Thanks again

Todd
 

Cyan

GBATemp's lurking knight
Former Staff
Joined
Oct 27, 2002
Messages
23,723
Trophies
4
Age
44
Location
Engine room, learning
XP
15,464
Country
France
maybe it's one of the very few games not working with a base 57?
could you try installing the same d2x cIOS (v10 r52) but with base 56 in slot 249, and set that slot for these two problematic games.

as most games are working fine with 57, we tend to only recommend this base for games. Most games were used to run on 56 but also work on 57, but some old games are not tested with 57 so maybe they need the 56.


So far, only Spyro is known to require base56 instead of 57.
 
Last edited by Cyan,
  • Like
Reactions: Todd265

Todd265

Member
OP
Newcomer
Joined
Dec 4, 2017
Messages
17
Trophies
0
Age
52
XP
54
Country
United Kingdom
maybe it's one of the very few games not working with a base 57?
could you try installing the same d2x cIOS (v10 r52) but with base 56 in slot 249, and set that slot for these two problematic games.

as most games are working fine with 57, we tend to only recommend this base for games. Most games were used to run on 56 but also work on 57, but some old games are not tested with 57 so maybe they need the 56.


So far, only Spyro is known to require base56 instead of 57.


Hi Cyan, so this was interesting...

I changed the settings to 56 like you said and here's what happened:

  • Metal Slug Anthology - worked at first, then got kicked out of the game (loss of connection to wii remote). Then got a message to do a disc update. After that got a black screen and then back to usb loader menu for this title.
  • Super Monkey Ball Banana Blitz - now fully working (wasn't previously)
  • Littlest Pet Shop - black screen
  • Who wants to be a Millionaire - Black Screen
  • TMNT Turtle Smash Up - Black Screen
  • Tak & Guardians of the Gross - Black Screen
So a bit of a change, but most titles that were problematic are still problematic. Maybe there's something up with these titles but then the Wii Backup Manager seemed to verify them (as much as it can). Not sure if there's anything else I can try?

Oh, by the way, I also set that dol video patching to all...

Again, thanks so much for all your help.

Should I set the base back to 57 now?

Todd
 

Cyan

GBATemp's lurking knight
Former Staff
Joined
Oct 27, 2002
Messages
23,723
Trophies
4
Age
44
Location
Engine room, learning
XP
15,464
Country
France
please, don't give that link to "help".
it will only cause more problems.

The setup this guide is providing is bad, and people always come back here for help.
If you follow this guide, please, only use v10 r52, NEVER r53 !

249 : r52 base 56
250 : r52 base 57
that's all you need.

Do NOT mix the version without understanding the reason and if you really need it (because, you don't).

Madworld only works if it's the same region as your wii? Really? Any clue why patching region doesn't work?
I'm not sure why. the resolution/video output is maybe hardcoded by the developers instead of letting the game choose based on the console's setting.
I think I didn't try this game with the "dol video patch" option, as I added it recently (after I played this game).

  • Metal Slug Anthology - worked at first, then got kicked out of the game (loss of connection to wii remote). Then got a message to do a disc update. After that got a black screen and then back to usb loader menu for this title.
  • Super Monkey Ball Banana Blitz - now fully working (wasn't previously)
Thanks for testing. so this is the second game we know that requires base56 (spyro and monkey ball)
Not sure if metal slug requires base56 or not, but at least it launched once. I never heard of games needed a disc update when launched from a loader.

wiimote loss of sync is usually a bad cIOS installation, but you said monkey ball is working so the install is done correctly.
I would need more info. more setting info maybe (emunand enabled or not?). which region is your game? did you touch another settings (block dol reloading for example). Did you try to reset the settings of the loader and games ?
I know this game work(ed), so it should work on your console too. we just need to find why you have this error.


For the other games still not working, I think it's a game issue too.

Are you sure the games are good dumps? I don't have them and never tested them.
did you check their "sha1" (not md5) within WiiBackupManager to verify the ISO on your drive? (not on your computer)
Maybe the games are corrupted on your HDD but not on your computer.

Should I set the base back to 57 now?
set the base to 57 in the loader's setting (globally)
and set to 56 in the individual game setting for monkey ball only. (and maybe metal slug too)

base57 is better and has more game compatibility.
if you set base56 as default (global settings) you'll have more games not working and requiring you to set an individual setting to 57.
 
Last edited by Cyan,
  • Like
Reactions: Todd265

Todd265

Member
OP
Newcomer
Joined
Dec 4, 2017
Messages
17
Trophies
0
Age
52
XP
54
Country
United Kingdom
please, don't give that link to "help".
it will only cause more problems.

The setup this guide is providing is bad, and people always come back here for help.
If you follow this guide, please, only use v10 r52, NEVER r53 !

249 : r52 base 56
250 : r52 base 57
that's all you need.

Do NOT mix the version without understanding the reason and if you really need it (because, you don't).


I'm not sure why. the resolution/video output is maybe hardcoded by the developers instead of letting the game choose based on the console's setting.
I think I didn't try this game with the "dol video patch" option, as I added it recently (after I played this game).


Thanks for testing. so this is the second game we know that requires base56 (spyro and monkey ball)
Not sure if metal slug requires base56 or not, but at least it launched once. I never heard of games needed a disc update when launched from a loader.

wiimote loss of sync is usually a bad cIOS installation, but you said monkey ball is working so the install is done correctly.
I would need more info. more setting info maybe (emunand enabled or not?). which region is your game? did you touch another settings (block dol reloading for example). Did you try to reset the settings of the loader and games ?
I know this game work(ed), so it should work on your console too. we just need to find why you have this error.


For the other games still not working, I think it's a game issue too.

Are you sure the games are good dumps? I don't have them and never tested them.
did you check their "sha1" (not md5) within WiiBackupManager to verify the ISO on your drive? (not on your computer)
Maybe the games are corrupted on your HDD but not on your computer.


set the base to 57 in the loader's setting (globally)
and set to 56 in the individual game setting for monkey ball only. (and maybe metal slug too)

base57 is better and has more game compatibility.
if you set base56 as default (global settings) you'll have more games not working and requiring you to set an individual setting to 57.

Thanks Cyan, I will try to look at your questions and suggestions when home this evening and report back with what I can.

I know I'm starting to repeat myself, but thank you again for the help!

T
 

Todd265

Member
OP
Newcomer
Joined
Dec 4, 2017
Messages
17
Trophies
0
Age
52
XP
54
Country
United Kingdom
I didn't provide a lot of help this time, they are mostly random thoughts because I don't understand what could be the problem.

Well I'm a total newbie so wouldn't have a clue how to troubleshoot this without your help, so it's really appreciated... ok so here's my answers below:

YOU: Not sure if metal slug requires base56 or not, but at least it launched once. I never heard of games needed a disc update when launched from a loader.

wiimote loss of sync is usually a bad cIOS installation, but you said monkey ball is working so the install is done correctly.
I would need more info. more setting info maybe (emunand enabled or not?). which region is your game? did you touch another settings (block dol reloading for example). Did you try to reset the settings of the loader and games ?


ME: Maybe I did this wrong, but what I did was I used the CIOS installer and repeated the steps I did to do the wii softmod to change the base to 56. After I did this restarted my Wii and tried to run Metal Slug. Like I say it worked, then I got a loss of controller error and I rebooted again. When my wii hit the home screen, it was showing that the disc channel needed an update which I just ran (like I did the first time I used the CIOS installer)... after that Metal Slug didn't work but not sure if the two are related. I didn't change any other settings apart from the dol patch thing...

I've taken some grabs of my USB loader settings in case this helps...


https://ibb.co/eh7oLG

https://ibb.co/gW14ub

https://ibb.co/iMfm7w

YOU: For the other games still not working, I think it's a game issue too.
iMfm7w
gW14ub
eh7oLG


Are you sure the games are good dumps? I don't have them and never tested them.
did you check their "sha1" (not md5) within WiiBackupManager to verify the ISO on your drive? (not on your computer)
Maybe the games are corrupted on your HDD but not on your computer.


ME: To be honest, they were downloads from the internet archive. They were downloaded in wbfs format not ISO. I tested them by connecting the hard drive to my PC and running the sha1 verification and I think they all checked out. When it was done all the files were green and it just said finished with no mention of any errors so I'm guessing they're ok? I don't know how to confirm what region they are...


You: set the base to 57 in the loader's setting (globally)
and set to 56 in the individual game setting for monkey ball only. (and maybe metal slug too)


ME: Sorry for being stupid, I thought you could only have one value for the base as it gets set via the CIOS installer - but maybe I got that completely wrong. Should I use the CIOS to set the value of 249 to 57 and then within the game options on USB loader choose a value of 56 for those two games?

Thanks

Todd
 
Last edited by Todd265,

Cyan

GBATemp's lurking knight
Former Staff
Joined
Oct 27, 2002
Messages
23,723
Trophies
4
Age
44
Location
Engine room, learning
XP
15,464
Country
France
if the game are tested on your HDD (not on your PC) and result is green, then all is fine.

I now understand your mistake and why it doesn't work anymore.


You console have different folders (called "slot") where you can install different IOS version.
up to 255 slots are usable.

What you did is install the d2x cIOS base56 in your slot249

So, you got your setup from this :
IOS249 (rev 65280): Stub (means there is something, but it's a dummy file from nintendo)
IOS250[57] (rev 65535, Info: d2x-v10beta52)

to this
IOS249[56] (rev 21010, info: d2x-v10beta52)
IOS250[57] (rev 65535, Info: d2x-v10beta52)


So, it worked, which means the issue was probably the missing "base56".
But the game crashed (another problem, we will find the solution later), and you returned to the main Wii system menu.

From there, you had a disc inserted in your console, and the disc contains a "update partition" with files that nintendo provide to update your console if it find outdated files.
You may notice that your "IOS249" had rev 65280 first. then you installed d2x which had rev21010.
your disc contains the nintendo's version 65280 which is higher than the one you installed, so it asked to update it and replaced your working d2x cIOS, with a dummy non working version from nintendo !

If you want to prevent a disc from replacing it, reinstall d2x base56, but choose "version 65535" when asked, instead of "21010".
this way, 65535 will be higher than the nintendo's version and the disc will never replace it with a fake cIOS to prevent piracy.




What you need is this :
IOS249[56] (rev 65535, info: d2x-v10beta52)
IOS250[57] (rev 65535, Info: d2x-v10beta52)


Then, inside the USBLoaderGX settings set this :
Settings > Loader settings > Loader's IOS : 250
This will tell the loader to ALWAYS use the slot 250 for ALL your games. that slot250 contains the "base57" which has the best compatibility.

Then, only for non working games :
Select the game > Option > Game option > IOS : 249
This will tell the loader to NOT use the default 250 for this game, but use the slot 249 only for this game! the slot 249 contains "base56". This is an individual setting used only for this game, all other games will still use the default setting : slot250.
 
Last edited by Cyan,
  • Like
Reactions: Todd265

Todd265

Member
OP
Newcomer
Joined
Dec 4, 2017
Messages
17
Trophies
0
Age
52
XP
54
Country
United Kingdom
if the game are tested on your HDD (not on your PC) and result is green, then all is fine.

I now understand your mistake and why it doesn't work anymore.


You console have different folders (called "slot") where you can install different IOS version.
up to 255 slots are usable.

What you did is install the d2x cIOS base56 in your slot249

So, you got your setup from this :
IOS249 (rev 65280): Stub (means there is something, but it's a dummy file from nintendo)
IOS250[57] (rev 65535, Info: d2x-v10beta52)

to this
IOS249[56] (rev 21010, info: d2x-v10beta52)
IOS250[57] (rev 65535, Info: d2x-v10beta52)


So, it worked, which means the issue was probably the missing "base56".
But the game crashed (another problem, we will find the solution later), and you returned to the main Wii system menu.

From there, you had a disc inserted in your console, and the disc contains a "update partition" with files that nintendo provide to update your console if it find outdated files.
You may notice that your "IOS249" had rev 65280 first. then you installed d2x which had rev21010.
your disc contains the nintendo's version 65280 which is higher than the one you installed, so it asked to update it and replaced your working d2x cIOS, with a dummy non working version from nintendo !

If you want to prevent a disc from replacing it, reinstall d2x base56, but choose "version 65535" when asked, instead of "21010".
this way, 65535 will be higher than the nintendo's version and the disc will never replace it with a fake cIOS to prevent piracy.




What you need is this :
IOS249[56] (rev 65535, info: d2x-v10beta52)
IOS250[57] (rev 65535, Info: d2x-v10beta52)


Then, inside the USBLoaderGX settings set this :
Settings > Loader settings > Loader's IOS : 250
This will tell the loader to ALWAYS use the slot 250 for ALL your games. that slot250 contains the "base57" which has the best compatibility.

Then, only for non working games :
Select the game > Option > Game option > IOS : 249
This will tell the loader to NOT use the default 250 for this game, but use the slot 249 only for this game! the slot 249 contains "base56". This is an individual setting used only for this game, all other games will still use the default setting : slot250.


Thanks so much for this. I can see where the problem with the disc update messed things up. I've done everything you said about setting up 249 and 250 in CIOS with the higher revision of 65535 etc. I just have one question:

Here you said:

Then, inside the USBLoaderGX settings set this :
Settings > Loader settings > Loader's IOS : 250


In this general loader settings page there are two things
Loader's IOS which I set to 250 like you said
Also in this screen is the Game's IOS - which is currently set to 249. Is that correct?

I know for individual problem games I can change the Game IOS to 249 like you explained, but I'm just wondering if it's ok for Game IOS to be 249 on that global setting. I hope I'm making sense?

Thanks

T
 

Cyan

GBATemp's lurking knight
Former Staff
Joined
Oct 27, 2002
Messages
23,723
Trophies
4
Age
44
Location
Engine room, learning
XP
15,464
Country
France
ah yes, sorry, I forgot and messed up my explanation :P
you are right, you need to set the "game's IOS" to 250 to make all games "globally using the slot 250".

the "loader's IOS" setting is used for something else, you can even set it to 58 if your HDD has detection issues. but keep it the same than the game's IOS for faster game launching.
so, set both to 250.
 
Last edited by Cyan,
  • Like
Reactions: Todd265

Todd265

Member
OP
Newcomer
Joined
Dec 4, 2017
Messages
17
Trophies
0
Age
52
XP
54
Country
United Kingdom
Hi Cyan, it WORKED!!!!!

I can't say thanks enough. I tried Metal Slug and it's now running properly. There were two other titles (Cooking Party and Cooking Mamma) which I added recently that weren't working and they are now working following your changes. THANK YOU SO MUCH!

I'd previously deleted some of the other titles like Teenage Mutant Ninja Turtles, Beachfun, Littlest Pet Shop so I haven't tested them yet. I'll add them back and test them, but I feel like things are working much better now.

Thanks so much for sticking with this. I'm super happy!!

I have a question about the general functionality of USB Loader so will post that seperately, but just wanted to let you know it's working now and of course to say a massive thanks! :-)

Best

Todd
 

Cyan

GBATemp's lurking knight
Former Staff
Joined
Oct 27, 2002
Messages
23,723
Trophies
4
Age
44
Location
Engine room, learning
XP
15,464
Country
France
could you confirm that Cooking Party and Cooking Mamma don't work with base57 (slot250) ?

Just to make a list of games which really require a base56.
that's not very important, just good to know to help other users in the future, as I've been suggested base57 to a lot of people in the last few months.


If you have more games NOT working with 57 than games not working with 56, you can do the contrary : set 249 as default, and only set 250 for games needing a base57.
 
Last edited by Cyan,

Todd265

Member
OP
Newcomer
Joined
Dec 4, 2017
Messages
17
Trophies
0
Age
52
XP
54
Country
United Kingdom
could you confirm that Cooking Party and Cooking Mamma don't work with base57 (slot250) ?

Just to make a list of games which really require a base56.
that's not very important, just good to know to help other users in the future, as I've been suggested base57 to a lot of people in the last few months.


If you have more games NOT working with 57 than games not working with 56, you can do the contrary : set 249 as default, and only set 250 for games needing a base57.

Thanks Cyan. And sure thing, once I've added the other titles back, I'll update you with which ones work with base56 only... (alongwith testing Cooking Party / Cooking Mamma...)

Speak soon

T
 

You may also like...

General chit-chat
Help Users
  • No one is chatting at the moment.
  • K3N1 @ K3N1:
    I'm calling dcf
  • M4x1mumReZ @ M4x1mumReZ:
    Now bend over for me lol
  • ZeroT21 @ ZeroT21:
    :ninja:time to skip
    +1
  • M4x1mumReZ @ M4x1mumReZ:
    Hahaha
    +1
  • M4x1mumReZ @ M4x1mumReZ:
    That kid's face
    +1
  • Metoroid0 @ Metoroid0:
    and thats how arcades where created.
    +1
  • ZeroT21 @ ZeroT21:
    so kinky

    :evil:
    +1
  • E1ite007 @ E1ite007:
    "And that kids, that's how I met your Sega"
    +1
  • ZeroT21 @ ZeroT21:
    more like, your 1st crush
    +2
  • L @ lulzhakkkkk:
    staff is just utter disgrace and waste of human space, just like this site is a waste of server resources, i wonder how much crypto i can mine by reformatting teh server for gbatemp and just running crypto miners on it...
  • L @ lulzhakkkkk:
    404 not found, clancy is mining money
  • K3N1 @ K3N1:
    404 clancy not found
  • Julie_Pilgrim @ Julie_Pilgrim:
    this website so weir
    d beucase
  • Julie_Pilgrim @ Julie_Pilgrim:
    you will see two mfs tear each other to shreds in the politics section
  • Julie_Pilgrim @ Julie_Pilgrim:
    and then 5 minutes later those same mfs are helping each other with cfw
  • Veho @ Veho:
    Can't say I ever saw that happen.
  • Julie_Pilgrim @ Julie_Pilgrim:
    let me believe
  • Veho @ Veho:
    I can't believe it's not butter.
  • Julie_Pilgrim @ Julie_Pilgrim:
    naw jokes aside i never saw it to like an extreme but i have seen two peope who partcipated in a arguement just chillin in a normal ass thread
  • K3N1 @ K3N1:
    Gotta waive epenises around somehow
  • K3N1 @ K3N1:
    lol uredumb nah udum aye bro help me out?
    K3N1 @ K3N1: lol uredumb nah udum aye bro help me out?