Belkin Router Support with Steam

Discussion in 'Computer Hardware, Devices and Accessories' started by BlazerX, Dec 12, 2012.

Dec 12, 2012
  1. BlazerX
    OP

    Member BlazerX GBAtemp Regular

    Joined:
    May 17, 2010
    Messages:
    101
    Country:
    United States
    Right now im at a different location then my normal one, Ive been trying to play Empire and Napoleon Total War on my desktop i recently had to bridge my router and modem together since i was getting a strict NAT on my ps3 now its NAT 2,when i try to play both ETW and NTW i can join 1outof 10 games,then weird part is Shogun 2 Total War works fine online.i had to open ports for my PS# to get NAT 2, Steam Connect fine to the net i can download from them and all any there anything i can do about this?

    my Router is a Belkin n150 hardware:
    F9K1001v4 (01A)

    EDIT: When i set my router as an access point i can join games but for some odd reason my ps3 or other laptops cant connect to the router
     
  2. marcus134

    Member marcus134 GBAtemp Advanced Fan

    Joined:
    May 7, 2011
    Messages:
    584
    Location:
    Québec
    Country:
    Canada
    bridge your router with your modem? you mean you connected a rj-45 (lan/ethernet) cable between them, from the wan port of the router?

    What's your modem's model?
     
  3. BlazerX
    OP

    Member BlazerX GBAtemp Regular

    Joined:
    May 17, 2010
    Messages:
    101
    Country:
    United States
    Yes My Router is a Belkin N150 F9K1001v4, I had to Bridge the router and modem as an PPoE Connection because my Net has a Private IP Address which my company tol me to bridge them both
     
  4. marcus134

    Member marcus134 GBAtemp Advanced Fan

    Joined:
    May 7, 2011
    Messages:
    584
    Location:
    Québec
    Country:
    Canada
    look like you got a couple of ports to forward or some firewall tinkering on your router firmware to do. make sure upnp is enabled.
    the lazy way would be to put your comp dmz and hope that the windows firewall is strong enough or that nobody try hard enough to get in.

    http://portforward.com/english/routers/port_forwarding/Belkin/F9K1001v1/Napoleon_-_Total_War.htm

    that isn't odd at all, when set in access point mode, NAT (network address translation) is disabled.
    NAT embed communication from different sources (ip addresses) into a single communication stream coming out of a single ip address.
    the reason NAT is useful is because ISP allow he connection of a single ip address per account. When nat is disabled, multiple ip will try to connect to your isp but your isp will only allow one.
     
  5. BlazerX
    OP

    Member BlazerX GBAtemp Regular

    Joined:
    May 17, 2010
    Messages:
    101
    Country:
    United States
    thanks i got it working now i can just games
     

Share This Page