1. cloudfe

    OP cloudfe GBAtemp Fan
    Member

    Joined:
    Feb 24, 2013
    Messages:
    365
    Country:
    Belgium
    I've recently installed a game that came out last summer, along with its day-one patch.
    Weirdly, the game asks me to update the system firmware. This does not happen if I only install the base game.
    Having the patch been released on the same date as the base game, I don't understand what is happening :blink:
    Any idea?
     
  2. caki883
    This message by caki883 has been removed from public view by porkiewpyne, May 4, 2021.
    May 3, 2021
  3. thesjaakspoiler

    thesjaakspoiler GBAtemp Fan
    Member

    Joined:
    Nov 20, 2018
    Messages:
    328
    Country:
    Afghanistan
    Base games and updates contain information about the required firmware.
    In many cases it is just set to the latest firmware without the actual need for anything in the particular new firmware.
    Base games can be made months in advance so it can happen that in between the finalization of the game and the build of the update, a new firmware was released.
     
  4. cloudfe

    OP cloudfe GBAtemp Fan
    Member

    Joined:
    Feb 24, 2013
    Messages:
    365
    Country:
    Belgium
    I understand this point.
    At the same time, the one-day update was released back in August - way before the release of the firmware I have currently installed.
    Isn't this strange?
     
  5. Draxzelex

    Draxzelex GBAtemp Legend
    Member

    Joined:
    Aug 6, 2017
    Messages:
    15,294
    Country:
    United States
    Strange? Yes. Impossible? No. On top of updates being able to be developed much faster than games, metadata in either of them can be made to artificially inflate the firmware requirements. Specifically, this is in the form of the .XML file when you unpack a .NSP file dumped straight from the CDN (after conversion) and this is what was initially used to bypass firmware restrictions.
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - require, system, update