Hacking Another request for help with usb loaders

lostone

Member
OP
Newcomer
Joined
Aug 20, 2021
Messages
10
Trophies
0
Age
21
XP
20
Country
United States
I'm looking for some suggestions after giving my best shot at getting this all work on an older (bootmii boot2 enabled) wii with one of the loader HW mods (this may not be needed anymore). I started with doing the upgrades: letterbomb, hackmii (HBC/bootmii), priiloader, cIOSes, usbloader/wiiflow but was unable to get the USB drive to work right. I tried modmii and had the same results, that the loaders can't "see" the drive (flash or HDD) on either port. I ran modmii on a newer systerm (no boot2 options and no hw mod) and found it worked perfect right out of the gate. With the newer wii the outside USB port could access the files and usbloader_gx had no problem with a 64GB micro card in an adapter. The same is not true for the older system. modwii sets both loader and game ios to 249 so that's been the base I've been testing with.

Troubleshooting the older system here's what I've done...
- Disassembled the system to check for obvious issues with the USB ports and found nothing
- Configured usbloader to use both ports and noticed the blue power LED on the micro adapter lights only on the inside port outside port never lights LED (so broken or never enabled).
- Checked wiiflow which was able to find the games, but not load the games on the inside port.
- Seeing another comment here about needing two devices plugged in I tried that and immediately saw the USB drive mounted in the usbloader settings, but I suspect this was likely do to the next change...
- Set loader IOS to 58 - loader can find games and download artwork.
- I tried the game loader: 249-251 (although looks like modmii puts the same version at all slots,so is there really a difference?) and 222 all loads quit back to menus (HBC/System)
- I've tried multiple tests with Wii Backup Manager on FAT32 and NTFS formatted drives, several uSD cards, USB flash adapters, WD USB hard disk (I'm concerned about it's power draw) and none can load games.

I haven't seen activity or power on the outside usb port and it doesn't appear to mount, and that's the only port loader found files on the newer system. I suspect there may be a USB port hardware issue but can't figure out how to test the ports. (I think I remember something about bad USB port and thinking that would never be a problem but that was years ago)
USB ports appear to be disabled by the OS until they are enabled in software... and I would like to confirm port power and coms. The microSD adapter does have a blue LED power/activity so I can see the inside port does light and flash when loader IOS is 58, but nothing when loading a game and I haven't ever seen the outside port get powered.

Any ideas on testing the USB ports? The pins all look clean and unbent.
I've got a USB power meter on the way and can replace the port if needed but I think the ports are passive components, so just wires so that won't likely help.

Couple of other semi-related questions:
-When WBM has put files on a drive can I move/copy the wbfs directory to another drive or do I need to rerun the WBM transfer?
-Since modmii puts the same image on ios249-251 are all three slots the same thing or are these patches to unique existing images? i.e. do you get the same result running 249, 250, or 251; or are there different behaviors?
 

CoolMe

.. Days'd & con'fused ..
Member
Joined
Apr 16, 2019
Messages
740
Trophies
0
Age
26
XP
654
Country
United States
AFAIK, the 3 of the ios's are needed for USB support. For WiiBackupManager, just put or copy the wbfs folder that contains your games to your new one, with the cover folder too if you care for them.
 

lostone

Member
OP
Newcomer
Joined
Aug 20, 2021
Messages
10
Trophies
0
Age
21
XP
20
Country
United States
AFAIK, the 3 of the ios's are needed for USB support. For WiiBackupManager, just put or copy the wbfs folder that contains your games to your new one, with the cover folder too if you care for them.

Thanks for the comment on wbfs directory, that makes sense and just wanted to confirm I wasn't creating other problems with a windows copy to other drives.

I have read and think I understood the "Ultimate IOS guide" by timicore so the same image in 3 slots really didn't make sense.... Sure 249 and 250 made sense with 250 is just a mirror of 249, but 251 I thought was to be used for something different. In any event I will assume that if it doesn't work for 249 it also won't work for 250 or 251 unless someone says that's incorrect.

My Wii was officially updated to 4.3U and I'm not clear how that will impact things. The rest of the cIOS patches included with modwii were installed so I think the system is a hack friendly as can be but I still really don't understand that process very well.

Hopefully the USB power meter arrives today or tomorrow so I can at least get an idea of if/when the ports get power. I suspect the USB controller may have been damaged and that's why I can't see the outside port. I've also got a wii keyboard and will test that in both ports.
 

XFlak

Wiitired but still kicking
Member
Joined
Sep 12, 2009
Messages
11,735
Trophies
2
Age
35
Location
Cyprus, originally from Toronto
Website
modmii.github.io
XP
5,179
Country
Cyprus
250 isn't just a mirror of 249. I mean, it could be done that way, but there's no point, and no self respecting guide would have u install the same CIOS to multiple slots (with the exception of a patched ios60 to other system menu slots)

Edit: normally 249 uses base IOS57, and 250 uses base ios56 (or vice versa)
 

lostone

Member
OP
Newcomer
Joined
Aug 20, 2021
Messages
10
Trophies
0
Age
21
XP
20
Country
United States
250 isn't just a mirror of 249. I mean, it could be done that way, but there's no point, and no self respecting guide would have u install the same CIOS to multiple slots (with the exception of a patched ios60 to other system menu slots)

Edit: normally 249 uses base IOS57, and 250 uses base ios56 (or vice versa)
Ah so this makes more sense now, and looking at what modwii does what you said, modified 57->slot249, modified 56->slot250, and modified 38->slot251. So all would be different. Thanks!
  1. cIOS249[57]-d2x-v10-beta52
  2. cIOS250[56]-d2x-v10-beta52
  3. cIOS251[38]-d2x-v10-beta52
Unfortunately I'm still in the same situation with interior slot showing the games with IOS58 but games won't load from that port with game loader 222, 249-251. If I use any other (c)IOS for the loader the inside slot isn't mounted so games aren't displayed and the disc settings of usbloader shows no mounted device.

I did confirm that both ports have 5V power but there's something preventing the drive from lighting its power/activity LED on the outside port. I think I need to find a schematic and understand how the two ports are different seems like a data line is not connected...
 
Last edited by lostone,

lostone

Member
OP
Newcomer
Joined
Aug 20, 2021
Messages
10
Trophies
0
Age
21
XP
20
Country
United States
Iirc there may be an option within some loaders to use the other USB port. D2x v10 beta53 may also be necessary, I don't recall
I have steered clear of beta53 for the noted reasons.

BTW, thank you for modMii, it was a fall back but came into play in a big way and got me past a deadline of getting loader to work!
 
  • Like
Reactions: XFlak

lostone

Member
OP
Newcomer
Joined
Aug 20, 2021
Messages
10
Trophies
0
Age
21
XP
20
Country
United States
I've been digging through the gigaleak files looking for the schematic but so far have come up empty.
Anyone know where they can be found?

Interesting discovery, I saw a snes game I worked on included in the roms dumps!
 
Joined
Mar 17, 2010
Messages
21,253
Trophies
3
Location
Space
XP
10,061
Country
Norway
I have steered clear of beta53 for the noted reasons.

BTW, thank you for modMii, it was a fall back but came into play in a big way and got me past a deadline of getting loader to work!
beta53 allows both USB ports, and also supports USB hotplugging (for game specific devices like Skylanders portal, instruments etc), other than that, supposedly it has lower compatibility with drives but for most it should still work fine. You could give it a try and use the other port and see if it works.
 
  • Like
Reactions: jeannotte

lostone

Member
OP
Newcomer
Joined
Aug 20, 2021
Messages
10
Trophies
0
Age
21
XP
20
Country
United States
beta53 allows both USB ports, and also supports USB hotplugging (for game specific devices like Skylanders portal, instruments etc), other than that, supposedly it has lower compatibility with drives but for most it should still work fine. You could give it a try and use the other port and see if it works.
I guess I could try and roll back if it doesn't work right?
Would it matter which slot or do them all 249-251?
 

lostone

Member
OP
Newcomer
Joined
Aug 20, 2021
Messages
10
Trophies
0
Age
21
XP
20
Country
United States
I tried 249 (IOS57 base) with beta53 mod and couldn't get it to work on either port.
Best I can tell port1 is the inside one, port0 is the outside one but I've seen conflicting info.
That's how I was able to get things working on the newer one, so I'll assume this is correct.

I tested power on the ports and found an interesting difference and it may explain what's happening:
Code:
      |    V-    |    V+    |    D-    |    D+    |
-----------------------------------------------------
  p0  |   0.00   |   5.03   |   0.78   |    1.04    |
  p1  |   0.00   |   5.03   |   0.09   |    3.23    |

It looks like port 0 has some funky power levels on the data lines. I'm guessing a blown FET, maybe someone hooked something up wrong, drew too much power or similar and blew a part.

I think I'll have to tear this apart, the schematics will be key from here out if I want to get port0 back!
 
Last edited by lostone,

lostone

Member
OP
Newcomer
Joined
Aug 20, 2021
Messages
10
Trophies
0
Age
21
XP
20
Country
United States
There's an option to change the port in the settings menu.

He should just need to use beta53, change the port in the settings and then restart the loader.
Thanks, I think that's what I did.

Started with modWii so had IOS57 modified with beta52 in slot 249, so changed that to IOS57 w/beta53 using d2x IOS loader (thanks again xFlak) into slot 249 (left 250 and 251 alone). Set gx loader and game to use slot 249. GX disk settings to no multi-partition, usb port 1 and load on startup but nothing loaded. Games didn't load in loader, enabling Wii games got the error USB was not mounted or similar. May have even got a hung black screen while running through some of the test configurations trying to get something to work.

Should that work, or did I do something wrong?

I'm currently installing beta53 on 250 and 251 to test out...
 
Last edited by lostone,

blackb0x

Well-Known Member
Member
Joined
Apr 22, 2019
Messages
390
Trophies
0
XP
1,497
Country
United Kingdom
Should that work, or did I do something wrong?
That's all correct.

Your voltage readings do look a little weird, but I'm not so sure if that's the problem.

You said that when you're using IOS 58 your games are listed, right? But prior to booting a game all loaders will reload to a cIOS and we already know that when you're using cIOS 249/250 your games aren't found. So it seems like your USB HDD isn't compatible with the d2x cIOS.
 

lostone

Member
OP
Newcomer
Joined
Aug 20, 2021
Messages
10
Trophies
0
Age
21
XP
20
Country
United States
That's correct, can "see" directory contents with IOS58 but try to load with any of the modified IOSes and nothing. Well, I get the config/start screen but after selecting start screen goes black before watchdog resets and return to HBC menu.
I just ran the gauntlet with retrying things... 4 different HDD (really only one HDD and 3 flash drives) but all fail to load the games (fail to even display the wrist strap screen) with GX.

I tried wiiflow too which does something different, wii flow does correctly identify the USB1 port as the one with a device connected but the contents of the drive appear to be cached, it doesn't show the same set of files that GX w/IOS58 showed.

I tried FAT32 and NTFS formats both produce the same results.

I'm getting really unsure about the USB controller (if unique part) or the parts on the USB data lines. I really need to find a schematic so I can find the two port's on the board and start testing parts. I've been digging through a million files but haven't found anything yet.
 

XFlak

Wiitired but still kicking
Member
Joined
Sep 12, 2009
Messages
11,735
Trophies
2
Age
35
Location
Cyprus, originally from Toronto
Website
modmii.github.io
XP
5,179
Country
Cyprus
Perhaps try hermes cios'? Plenty of options to try in ModMii classic's download page 4, or advanced downloads page.

I don't want to get your hopes up, switching to a different hdd may still be your best bet

Edit: or try formatting it as wbfs using wii backup manager. You forfeit some advantages of fat32 or ntfs, but it has improved compatibility
 
Last edited by XFlak,
General chit-chat
Help Users
    DinohScene @ DinohScene: congratz on surviving!