AK2i on new DSi 1.4 PLEASE HELP : )

Discussion in 'Acekard' started by dudeitscraig, Dec 26, 2009.

Dec 26, 2009
  1. dudeitscraig

    Newcomer dudeitscraig Newbie

    Dec 26, 2009
    United States
    Hello everyone, thanks for your help!

    I just got a DSi for christmas and it is 1.4 out of the box. I bought the AceKard 2i, because i was under the impression that it was start up no problem on a new DSi. All of the reviews i read were NOT updated, and did not warn me that it useless on a new DSi. ive read that you need to update the AceKard firmware on an older DS (in which may ruin your flashcard, as i have read in some posts). i dont know if i trust this process.

    Can anyone help me get this going. I have a friend who has a DSlite and is running an r4 chip on it, if that updating process works. To me, it seems like the AceKard is nothing but trouble, and i couldnt image going through this every few months, but i really like OS and i heard good reviews. Is there a better chip that i should have bought? im a bit of a noob, but id appreciate all of your opinions, and i hope i can play this DSi! (i have no games) : (

    Thanks again for your help!!
  2. scrtmstr

    Member scrtmstr GBAtemp Advanced Fan

    Aug 20, 2009
    the Netherregions!
    it's not a big risk to run the update like described in the reviews. You just put the update file on your microsd and put it in your ak2i. Then put it in the dslite and run the update. There is a very small change of bricking, but then you can unbrick it again.
    merry x-mas [​IMG]

Share This Page