Afraid to update to 10.1!

Discussion in '3DS - Homebrew Development and Emulators' started by 03bgood, Sep 27, 2015.

  1. 03bgood
    OP

    03bgood Banned

    Banned
    880
    134
    Aug 29, 2014
    United States
    Paris, Illinois
    I have a free version of OlliOilli on the 3DS eShop waiting for me (Thanks to the Curve discounts on the Wii U) and I bet 3D Sonic The Hedgehog 2 is coming out next Thursday but I'm afraid to update my 3DS. I'm currently playing Pokemon Yellow on GameYob and I'm at the part where you fight the ghost of Cubone's mother in Lavender Tower and I don't want to lose the ability to play GB/GBC ROMs and possibly NES and/or GBA. So what do I do?
     
    Last edited by 03bgood, Sep 27, 2015


  2. Seriel

    Seriel Worshipper of Skiddos

    Member
    2,705
    4,789
    Aug 18, 2015
    United Kingdom
    UK
    You can still use GameYob on 10.1.
     
  3. lemanuel

    lemanuel Maxconsole's All-Knowing Lurker

    Member
    2,095
    1,093
    Dec 11, 2014
    Portugal
    which firmware do you currently have anyway?
     
  4. 03bgood
    OP

    03bgood Banned

    Banned
    880
    134
    Aug 29, 2014
    United States
    Paris, Illinois
    9.9.0

    — Posts automatically merged - Please don't double post! —

    Will I have to do anything with TubeHax, like reconfigure the DNS?
     
  5. lemanuel

    lemanuel Maxconsole's All-Knowing Lurker

    Member
    2,095
    1,093
    Dec 11, 2014
    Portugal
    Then you'll still be able to do everything you currently do with 10.1
     
  6. Piluvr

    Piluvr Resident Masturbator

    Member
    645
    353
    Jul 27, 2015
    United States
    Behind you
    update, and update the payload for ironhax/whateverhax with tubehax and you are good.
     
  7. sweis12

    sweis12 GBAtemp Maniac

    Member
    1,242
    513
    Oct 20, 2013
    Saint Kitts and Nevis
    I would stay on 9.9, 10.1 still has homebrew supoort, but it appears to have patched some arm11 stuff(meaning possible kernel exploit on 9.9 or lower)
     
  8. Seriel

    Seriel Worshipper of Skiddos

    Member
    2,705
    4,789
    Aug 18, 2015
    United Kingdom
    UK
    if you're using tubehax just make sure to select your new firmware version and it should be fine.

    — Posts automatically merged - Please don't double post! —

    And there's that too. Which is why i'm staying on 9.9.
     
  9. Arras

    Arras GBAtemp Guru

    Member
    5,863
    2,679
    Sep 14, 2010
    Netherlands
    It an arm11 "exploit" that was completely useless, so it really doesn't matter.
     
  10. Gettwobirdsstone

    Gettwobirdsstone Triforce Guardian

    Member
    372
    61
    Jul 1, 2012
    Canada
    Behind you breathing heavily
    Do you want a possibly exploit or do you want new releases form the eshop? Think about which you'd kick yourself in the ass for more.
     
  11. Ericjwg

    Ericjwg Good

    Member
    2,866
    693
    Jul 2, 2015
    Canada
    just like what Jackus said
     
  12. 03bgood
    OP

    03bgood Banned

    Banned
    880
    134
    Aug 29, 2014
    United States
    Paris, Illinois
    Well, you can thank Nintendick for that one! Those morons haven't updated the 3DS Virtual Console since late February (At least in North America, that is).

    Were still missing these games and so far, only Japan has them:

    The Sword of Hope (GB)
    Double Dragon II (GB)
    Tetris Attack (GB)
    Nintendo World Cup (GB)
    Princess Tomato in The Salad Kingdom (NES)
    Adventures of Lolo 2 (NES) (They didn't get the first one, only this one instead)
    King's Knight (NES)
    Bubble Bobble (NES)
    Final Fantasy (NES)
    Elevator Action (NES)
    Ninja JaJa Maru-kun (NES)
    Bio Miracle Bokutte Upa (NES)
    Ufouria: The Saga (NES)
    Shadowgate (NES)
    Nintendo World Cup (NES)
     
    Last edited by 03bgood, Sep 27, 2015
  13. Megaben99

    Megaben99 I'm not an intern. I'm a messenger of the Gods!

    Member
    285
    97
    Mar 19, 2015
    United States
    Injection makes these possible. I've been enjoying Elevator Action for a while now.
     
    lemanuel likes this.
  14. 03bgood
    OP

    03bgood Banned

    Banned
    880
    134
    Aug 29, 2014
    United States
    Paris, Illinois
    But I'm not on 9.2 or lower, sadly! Someone need to make it to where 9.x and 10.x can use VC injections. I miss those from the Wii days! I heard that the 3DS can inject custom NES/GB/GBC/GBA Amb./3D Classics, much like how the Wii could with NES/SNES/N64/Genesis/TurboGrafx-16 VC games. The only games that cannot be injected are Game Gear VC games and not all 3D Classics work. Someone did get Sonic 3 & Knuckles working, I heard.

    If I ever get .CIA files installed once it's possible for 9.x or 10.x or I downgrade to 9.2 when it becomes possible. All of my NES and GBA games from my Wii U library (Even NES Wii Mode games) are getting injected. I can finally beat TMNT w/ save states and play StarTropics 1&2 on the go!
     
    Last edited by 03bgood, Sep 27, 2015
  15. Zephiroph

    Zephiroph Member

    Newcomer
    41
    25
    Sep 14, 2015
    I had to update to get plague knight...everything is back up and running as before...just get the updates.

    — Posts automatically merged - Please don't double post! —

    Yes in Europe too the VC has been abandoned by Nintendo...since about March.
     
  16. teampleb

    teampleb BAH! DED! X_X

    Banned
    2,066
    1,320
    Aug 26, 2015
    United States
    Pennsylvania
    3DBrew says nothing was patched in 10.1. They just changed how icons work. Source: http://3dbrew.org/wiki/10.1.0-27

     
    Last edited by teampleb, Sep 27, 2015
  17. BurningDesire

    BurningDesire GBAtemp Psycho!

    Member
    4,962
    5,811
    Jan 27, 2015
    United States
    Behind a screen reading news
    Note to self: If you have themehax installed: DO NOT UPDATE. It will corrupt your sd card. Today was a very sad day for me.
     
  18. teampleb

    teampleb BAH! DED! X_X

    Banned
    2,066
    1,320
    Aug 26, 2015
    United States
    Pennsylvania
    Well at least you're updated now so you can just redownload your games and reinstall themehax.
     
  19. BurningDesire

    BurningDesire GBAtemp Psycho!

    Member
    4,962
    5,811
    Jan 27, 2015
    United States
    Behind a screen reading news
    I did. Everything is fixed. It was a pain in the ass though. I won't be installing themehax for awhile!
     
  20. teampleb

    teampleb BAH! DED! X_X

    Banned
    2,066
    1,320
    Aug 26, 2015
    United States
    Pennsylvania
    Just make sure to uninstall before you update. It was probably loading the wrong payload because you updated.