A USB Loader GX Controller Question

Discussion in 'Wii - Backup Loaders' started by TheVinAnator, Apr 12, 2016.

  1. TheVinAnator
    OP

    TheVinAnator GBATemp's Greatest Vin

    Member
    3,620
    2,701
    Jan 10, 2016
    Canada
    NO COFFEI!
    Basically i have a "generic usb gamepad" according to my computer a.k.a its a usb gamecube controller so instead of the cylinder kind of plug it is straight up usb. now i have tested with smash on wii u and the wii u does not detect it and i know thats something totally different but just saying. So my question is will usb loader gx support it with gc games???
     
  2. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    4,284
    823
    Mar 2, 2015
    United States
    USB Loader GX doesn't run Gamecube games. You need something like Nintendont and if it's a HID-compliant controller it should work.
     
  3. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,770
    9,043
    Oct 27, 2002
    France
    Engine room, learning
    USBLoaderGX will not detect or use it as a Gamecube controller when inside the loader. (real controller can be used in the loader's interface, but not USB controllers).
    Like greywolf said, USBLoaderGX is not related with the controller compatibility when playing a gamecube game.

    what you need to verify, is if the Gamecube loader is compatible : Nintendont. (the homebrew responsible for interfacing the console hardware with the gamecube ISO in real time)
    Nintendont is compatible with "HID-USB" compliant USB controllers. What you need to know is if your controller is "HID" (Human Interface Device) or not.

    There's a homebrew you can launch to see if your controller is HID.
    you can find the link and help in Nintendont thread, first post.

    If it works, then you either are lucky and all the buttons are "the most commonly used" and it just work, or unlucky and you will have to create a button mapping file, to link each controller buttons to the gamecube button.
     
  4. TheVinAnator
    OP

    TheVinAnator GBATemp's Greatest Vin

    Member
    3,620
    2,701
    Jan 10, 2016
    Canada
    NO COFFEI!
    Thanks a lot guys I'll check out and just so you know I'm on a wii with version 4.3 U and d2x cios version 9
     
  5. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,770
    9,043
    Oct 27, 2002
    France
    Engine room, learning
    d2x version has no effect on gamecube games (nintendont use IOS58), unless you use dual USB Port inside USBLoaderGX.

    Dual port works only with v9 and v10-alt
    but it's not recommended to use dual HDD at the same time, it only creates issues if you don't know how cIOS and IOS and homebrew are working.

    If all is working, that's fine.
    If you have issues with compatibility (specially with EmuNAND), you might have to update to v10 (non alt) or go back to v8.