6.x.x.x firmware 2ds

Discussion in '3DS - Flashcards & Custom Firmwares' started by bbcali89, Nov 28, 2015.

  1. bbcali89
    OP

    bbcali89 GBAtemp Fan

    Member
    397
    68
    Sep 16, 2013
    United States
    Chicago
    Hi guys I'm going to try and lay out this the best way I can.

    I want to be able to play:

    homebrew
    backups
    mods
    and go online for games.

    I have 2ds 6.x firmware. I read a ton on rxtools but I'm still confused a bit.
    what's the best cfw?
    pasta/ cake etc?
    others?

    I'm still trying to understand all the ways I can upgrade my firmware to 9.2?
    should I upgrade?
    should I downgrade?
    I hear 4.x is the ideal fw
    how do I downgrade?
    So many things I don't see covered much and it confuses me :/

    can any of you guys help me out ?
    I'm sure once it's all setup I can figure out the minor stuff.
     
    Last edited by bbcali89, Nov 28, 2015
  2. Ericjwg

    Ericjwg GBAtemp Psycho!

    Member
    3,168
    856
    Jul 2, 2015
    Canada
    of course u should upgrade to 9.0-9.2
     
  3. Adeka

    Adeka Beta Tester

    Member
    4,149
    1,291
    Mar 19, 2013
    United States
    rxtools is currently the best cfw

    the ideal firmware to be on is 9.0 to 9.2

    you can upgrade to 9.2 using rxtools devmode or ssb4 rev2 cart
     
  4. lexluth0r

    lexluth0r GBAtemp Regular

    Member
    162
    79
    Aug 5, 2011
    United States
    Can I use a sky 3ds cart with smash bros onit to update a 2ds of the same firmware as this post?
     
  5. bbcali89
    OP

    bbcali89 GBAtemp Fan

    Member
    397
    68
    Sep 16, 2013
    United States
    Chicago
    how do I know if its the rev 2 cart ?
    and how to upgrade using rx ? don't I need to be on 9.2 before I install rx ?
     
  6. Adeka

    Adeka Beta Tester

    Member
    4,149
    1,291
    Mar 19, 2013
    United States
    you stick the cart in your 3ds and try to start it. It will prompt an update message along with the firmware it will update to (you get the option to click yes or no to do the update. if its not a rev2 cart, click no and try another cart)

    rev1 = 8.1
    rev2 = 9.2
    rev3 = 9.4
    rev4 = 9.5

    This is personally how I updated my 3ds to 9.2 as I didn't want to risk bricking my 3ds with rxtools devmode and sysupdater
    if you can find the rev2 rom then yes
     
    Last edited by Adeka, Nov 28, 2015
  7. bbcali89
    OP

    bbcali89 GBAtemp Fan

    Member
    397
    68
    Sep 16, 2013
    United States
    Chicago
    there's no way to know by serial or what not ? I have no way to run backups...
     
  8. Ammako

    Ammako GBAtemp Guru

    Member
    6,424
    3,547
    Dec 22, 2009
    Canada
    You don't want to downgrade to 4.5 regardless, because the 2DS only supports a minimum of 6.0 I'm pretty sure downgrading any further would cause problems.
     
  9. bbcali89
    OP

    bbcali89 GBAtemp Fan

    Member
    397
    68
    Sep 16, 2013
    United States
    Chicago
    Good thing to know. in theory couldn't I just go to rxtools at current fw. and then update using a rom and then go to 9.2 and reinstall rx ?
     
  10. MelonGx

    MelonGx GBAtemp Advanced Maniac

    Member
    1,634
    439
    Jan 8, 2009
    China
    Why don't you stay at 6.X and use MSET 6.X to boot rxTools/CakesFW?

    Sysupdater upgrading 9.2 is not so good for unskilled people.

    Cartridge upgrading 9.2 makes some problem on everything using Spider Hack entrypoint.
     
    Last edited by MelonGx, Nov 29, 2015
  11. blujay

    blujay GBATemp's Official Warthog

    Member
    GBAtemp Patron
    blujay is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    2,258
    2,141
    Nov 2, 2015
    United States
    Gilbert, Arizona
    Uh oh. The flame wars are about to begin. *Grabs popcorn and plays music with rxTools*
     
  12. bbcali89
    OP

    bbcali89 GBAtemp Fan

    Member
    397
    68
    Sep 16, 2013
    United States
    Chicago
    explain mset ? I'm not well knowledged in that. can you dumb it down for me a bit ? I assume it's another exploit to run rx ?

    the main reason I want 9.2 is to get a coldboot rx boot. you can't get that

    — Posts automatically merged - Please don't double post! —

    it's
    also that end paragraph I don't understand at all. but I want the most stable across the board. roms. homebrew etc.
    what is spider back ?
     
  13. MelonGx

    MelonGx GBAtemp Advanced Maniac

    Member
    1,634
    439
    Jan 8, 2009
    China
    MSET is System Setting's codename.
    Most of the things related to MSET are talking about "DS profile exploit".

    Spider Hack is one of the Browser exploit.
    It's using for booting Gateway, rxTools, etc.

    Since you say that you want the coldboot, go straight on upgrading SysNAND to 9.2.
     
  14. bbcali89
    OP

    bbcali89 GBAtemp Fan

    Member
    397
    68
    Sep 16, 2013
    United States
    Chicago
    I don't need the cold boot. it sounds like 6.x.x would be safer.
    and more stable. can my emunand by highest fw ? so I can play latest games ? or how does that work . I appreciate all the help !
     
  15. MelonGx

    MelonGx GBAtemp Advanced Maniac

    Member
    1,634
    439
    Jan 8, 2009
    China
    Latest emuNAND is OK.
     
  16. bbcali89
    OP

    bbcali89 GBAtemp Fan

    Member
    397
    68
    Sep 16, 2013
    United States
    Chicago
    What is the process of updating emunand ?

    and apparently if I'm lower than 7.x I have to use mset to install rx
     
  17. Ripper00420

    Ripper00420 GBAtemp Advanced Fan

    Member
    740
    224
    Nov 5, 2013
    United States
    how do you do the Mset exploit with no entry again....? I have a old3DS-Xl on 6.3.0.12U and I can't even get to homebrew because I have no flashcart, and Browserhax doesn't work on below 9.0. It just yellow screens every time, and then it kicks me to the homemenu with an error.
     
  18. Ammako

    Ammako GBAtemp Guru

    Member
    6,424
    3,547
    Dec 22, 2009
    Canada
    To install the MSET exploit, you should get a DS flashcard. Any one should work as long as it isn't blocked on 6.3.0-12U
    If you don't have one already, I personally recommend the R4i Gold 3DS from r4ids.cn (I believe this is the one) because of its low price. It also supports pretty much every DS game with Wood R4 so it's a nice addition if you'd like to play DS games. I believe nds-card is a good place to get them.
    That one should work on 3DS firmware up to 10.3, so you should be okay.

    (Someone correct me if I'm wrong and I'm not thinking of the correct R4, there's so many kinds of R4 clones out there.)

    It might need to have its firmware updated to run on your 3DS, but I think, at least depending on the place you buy it from, that they may be updating them before shipping them (or you might be able to ask their customer support, I'm not sure. Never used those websites.)

    If you're willing to spend a bit more, the DSTwo is also a very good choice. More expensive, but you have more features. If all you want to do is install the MSET exploit though, any DS flashcard will work as long as it's able to run on 6.3.0
     
  19. Mike Medtux

    Mike Medtux Newbie

    Newcomer
    9
    1
    Sep 27, 2015
    Mexico
    i have a 2ds version 7.2 with rxtools 2.6 and go exploit, is stable and easy to make it
     
  20. Ronhero

    Ronhero Too Weird to Live, Too Rare to Die

    Member
    3,053
    1,070
    Jun 28, 2014
    United States
    Arizona Bay
    Just throwing my two cents in the ring.

    Best setup for the o3ds is 9.0-9.2 sys nand auto booting to crt boot with the following options

    Rx emu
    Pasta gba / dsi
    Homebrew
     
    peteruk likes this.