Misc 3DS suddenly disconnecting itself from the Internet

  • Thread starter Deleted User
  • Start date
  • Views 12,605
  • Replies 8
D

Deleted User

Guest
OP
Since two or three days ago my 3DS has started acting strangely when I connect to the internet.

I'm using wifi on a smartphone as entry point, when I turn on wifi on my 3DS, it connects itself normally (streetpass green icon changes to blue and says internet) but then after a few seconds it disconnects for no apparent reason. Then it randomly connects itself, then disconnects, and the process repeats until it simply stops connecting and remains in streetpass mode. A few days before this didn't happen at all.

The strange thing is streetpass works and I can play local multiplayer with no problem, issue seems to be with internet only.

I have tried resetting the internet settings on my 3DS, tried resetting the phone's, disabled password protection temporarily, tried again, nothing seems to work. The phone doens't seem to be the problem either because I can connect to it with other devices without a hitch.

EDIT:

I tried on a different network (on my university), same problem. An odd thing is, I launched the Internet Browser and suddenly Internet icon went stable. I managed to do google search, check mail, and browse the internet perfectly from the 3DS. But then when I returned to home menu, it started flickering again. When I launch other apps that connect to the internet, it automatically disconnects, but the Internet Brower works just fine.

Any idea why is this happening and if there's some way to fix it?
 
Last edited by ,

MrMcTiller

GBATemp's Tiller
Member
Joined
Mar 7, 2017
Messages
1,181
Trophies
0
Age
19
Location
Iowa
XP
1,429
Country
United States
Since two or three days ago my 3DS has started acting strangely when I connect to the internet.

I'm using wifi on a smartphone as entry point, when I turn on wifi on my 3DS, it connects itself normally (streetpass green icon changes to blue and says internet) but then after a few seconds it disconnects for no apparent reason. Then it randomly connects itself, then disconnects, and the process repeats until it simply stops connecting and remains in streetpass mode. A few days before this didn't happen at all.

The strange thing is streetpass works and I can play local multiplayer with no problem, issue seems to be with internet only.

I have tried resetting the internet settings on my 3DS, tried resetting the phone's, disabled password protection temporarily, tried again, nothing seems to work. The phone doens't seem to be the problem either because I can connect to it with other devices without a hitch.

EDIT:

I tried on a different network (on my university), same problem. An odd thing is, I launched the Internet Browser and suddenly Internet icon went stable. I managed to do google search, check mail, and browse the internet perfectly from the 3DS. But then when I returned to home menu, it started flickering again. When I launch other apps that connect to the internet, it automatically disconnects, but the Internet Brower works just fine.

Any idea why is this happening and if there's some way to fix it?
I have no clue. Have you tried taking out the battery of the 3ds and letting it drain of all the power? IDK if that will help.
 
D

Deleted User

Guest
OP
I haven't tried that yet though I read about it somewhere, but might as well do since I don't know what else to do. Right now I don't desperately need to go online or anything, I'm just afraid sometime in the future Nintendo will launch another last minute update and a future game will need it to be played, and I won't be able to download the update. I also used to update some hb apps directly but I can just download the cias and install manually.

Anyways thanks for the suggestion, I'll keep it in mind.
 
  • Like
Reactions: MrMcTiller

MrMcTiller

GBATemp's Tiller
Member
Joined
Mar 7, 2017
Messages
1,181
Trophies
0
Age
19
Location
Iowa
XP
1,429
Country
United States
I haven't tried that yet though I read about it somewhere, but might as well do since I don't know what else to do. Right now I don't desperately need to go online or anything, I'm just afraid sometime in the future Nintendo will launch another last minute update and a future game will need it to be played, and I won't be able to download the update. I also used to update some hb apps directly but I can just download the cias and install manually.

Anyways thanks for the suggestion, I'll keep it in mind.
Good Luck!
 
D

Deleted User

Guest
OP
I tried the battery method and sadly the problem persists. When I tried last time it managed to stay connected for about half a minute (I almost thought it had been fixed), before it started disconnecting again. Well I guess I'm outta luck. Thanks anyway.
 

MrMcTiller

GBATemp's Tiller
Member
Joined
Mar 7, 2017
Messages
1,181
Trophies
0
Age
19
Location
Iowa
XP
1,429
Country
United States
I tried the battery method and sadly the problem persists. When I tried last time it managed to stay connected for about half a minute (I almost thought it had been fixed), before it started disconnecting again. Well I guess I'm outta luck. Thanks anyway.
Is it a N3ds or O3ds?
 
D

Deleted User

Guest
OP
Old USA, firmware 11.6. I'm using b9s 1.3 and luma 8.1.1. Was able to connect perfectly fine until about two weeks ago. I can still use internet browser without problem, so it's either a problem in cfw, wich I don't think I can unninstall, and I don't really want to, in some app in home menu or some strange conflict with IP adress or something. It's not my wifi antenna either because I also can play locally. I'm so confused :wacko:.
 
D

Deleted User

Guest
OP
Problem fixed!!!!!!! Days ago my SD started going crazy too, so I changed it. Afterwards I tried internet and it seems to be working OK again. No more icon flickering or anything. So I'm guessing that old SD card was the problem, dunno for sure. Anyway this can be closed, solved or wathever, thank you @MrMcTiller for your concern, everything is okay now.:toot::yay3ds:
 
  • Like
Reactions: MrMcTiller

MrMcTiller

GBATemp's Tiller
Member
Joined
Mar 7, 2017
Messages
1,181
Trophies
0
Age
19
Location
Iowa
XP
1,429
Country
United States
Problem fixed!!!!!!! Days ago my SD started going crazy too, so I changed it. Afterwards I tried internet and it seems to be working OK again. No more icon flickering or anything. So I'm guessing that old SD card was the problem, dunno for sure. Anyway this can be closed, solved or wathever, thank you @MrMcTiller for your concern, everything is okay now.:toot::yay3ds:
I am always willing to help.
 

You may also like...

General chit-chat
Help Users
  • No one is chatting at the moment.
  • Psionic Roshambo @ Psionic Roshambo:
    Amazon Is better lol
    +1
  • K3N1 @ K3N1:
    Hard to find a fast 2tb SSD for 130
    +1
  • Peretti @ Peretti:
    lately I downloaded super mario galaxy for wii, but in the first phase, right in the first cutscene of the game, the game freezes in that part, with the image appearing but completely frozen. I already had this problem with pikmin 2 but in the end I couldn't fix the problem. Has anyone had this problem, and if so, did you find a solution?
  • K3N1 @ K3N1:
    Moms spaghetti
  • Veho @ Veho:
    Why are republicans so desperate to see Hunter Biden's dick? I don't get it.
  • Maximumbeans @ Maximumbeans:
    They need to see it to prove he isn't a reptilian
  • Veho @ Veho:
    I thought they were trying to prove that he was a reptilian.
  • Maximumbeans @ Maximumbeans:
    Oh yeah :rofl2: then I have no idea!
  • K3N1 @ K3N1:
    @M4x1mumReZ chill on the likes man 15 different times on my profile
  • Veho @ Veho:
    LET ME LIKE YOU KEN
  • K3N1 @ K3N1:
    Emotional damage
  • Veho @ Veho:
    "Access Denied"
  • Veho @ Veho:
    Cool.
  • K3N1 @ K3N1:
    Is it actually coal tho
  • Veho @ Veho:
    Cool coal.
  • K3N1 @ K3N1:
    Sour patch dropplings
  • Veho @ Veho:
    Sour patch droppings :tpi:
  • K3N1 @ K3N1:
    The patches discovered taco bell and decided to sell off the after affects
  • Veho @ Veho:
    Reduce, reuse, regurgitate.
    Veho @ Veho: