10.5 error 22-2634

Discussion in '3DS - Nintendo Network' started by stefanoteco, Feb 2, 2016.

  1. stefanoteco
    OP

    stefanoteco Advanced Member

    Newcomer
    64
    5
    Jul 16, 2008
    Brazil
    São Paulo
    Hi guys, I'm currently using sysnand 10.5-30u and since I updated from 10.3 I cannot access online services getting this error. I saw some posts saying I needed to reset my system so I was going g to transfer my games and NNID to a 3DSXL so I could reset my 3DS but it deleted all my games and I got an error in the process of doing so (22-5540) I downloaded. I need to get my digital games back. What can I do to solve my problem? I really need your help :/

    Edit: forgot to mention I have a SD card backup since I installed rxtools witch I backed up before updating it back to 10.3 And that 3DSXL isn't mine. It's and old and empty 3ds a friend of mine has and forgot with me xD
     
    Last edited by stefanoteco, Feb 2, 2016
  2. daxtsu

    daxtsu GBAtemp Guru

    Member
    5,539
    3,929
    Jun 9, 2007
    Antarctica
    You probably ran into this: https://gbatemp.net/threads/warning-gbatemp-nintendo-forse-updates-online-play.413247/

    They changed the servers so that you need to be on the latest firmware to do anything now (aside from system formatting, maybe). You can either: A) downgrade and use CFW/emuNAND, B) update to 10.5, or C) possibly install the updated components that they're looking for with NASA/modded FBI, but this would create a franken-firmware on your system NAND, and I would highly recommend NOT doing that.


    Edit: Whoops, I need to read more carefully. I saw 10.3 first before 10.5. My mistake. So you're on 10.5 and still get that error? That's quite baffling. Did you ever mess with any system titles like nver/cver or anything like that?
     
    Last edited by daxtsu, Feb 2, 2016
  3. stefanoteco
    OP

    stefanoteco Advanced Member

    Newcomer
    64
    5
    Jul 16, 2008
    Brazil
    São Paulo
    Like I said. Already on 10.5-30, no emunand available neither downgrading if I am correct. I also have a NAND BACKUP from before installing rxTools. Is there any way I could flash it back?? I mean homebrew ways?

    — Posts automatically merged - Please don't double post! —

    No idea what that means but I remember installing something on system security health blablabla
     
  4. daxtsu

    daxtsu GBAtemp Guru

    Member
    5,539
    3,929
    Jun 9, 2007
    Antarctica
    Yeah, I saw afterward, I'm sorry about that. No, you'd need to get a hard mod installed if you wanted to restore a backup at this point. I'm just confused as to what would make that error show up if you didn't mess with anything. Maybe your 3DS didn't upgrade all the way to 10.5 correctly?
     
  5. stefanoteco
    OP

    stefanoteco Advanced Member

    Newcomer
    64
    5
    Jul 16, 2008
    Brazil
    São Paulo
    I updated normally vis system settings. But that's really weird. That's why I asked you guys xD
     
  6. daxtsu

    daxtsu GBAtemp Guru

    Member
    5,539
    3,929
    Jun 9, 2007
    Antarctica
    Hm. What does the system say if you try to update again? Maybe it missed something when it updated last time.
     
  7. stefanoteco
    OP

    stefanoteco Advanced Member

    Newcomer
    64
    5
    Jul 16, 2008
    Brazil
    São Paulo
    Didn't try updating again, since it updated yesterday. I'll try it as soon as I get WiFi


    Edit: just tried updating and it says it's already up to date
     
    Last edited by stefanoteco, Feb 2, 2016
  8. stefanoteco
    OP

    stefanoteco Advanced Member

    Newcomer
    64
    5
    Jul 16, 2008
    Brazil
    São Paulo
    I figured out what I did wrong! I was with the nand.bin backup but didn't restored it. Now I'm with a hacked H&S app that I can't restore because I can't downgrade yay! Maybe I should look for some hardmod guide? Or wait?

    Oh and all my games are still on the SD card but they are all x marked and grey.
     
  9. daxtsu

    daxtsu GBAtemp Guru

    Member
    5,539
    3,929
    Jun 9, 2007
    Antarctica
    I would probably look into getting a hard mod done/doing it yourself (if you're confident in soldering), as Nintendo doesn't often update the Health and Safety app. The last time it was updated was in firmware 6.0, which released back in 2013 I think. After you get your dump restored, you should be able to update safely back to 10.5 if that's what you want to do.

    Before making any decisions though, you might want to wait for others' opinions.
     
  10. stefanoteco
    OP

    stefanoteco Advanced Member

    Newcomer
    64
    5
    Jul 16, 2008
    Brazil
    São Paulo
    I will hahaha never solded anything in my life so that might not be a great idea
     
  11. TehVillylol

    TehVillylol Plant tree all day everyday

    Member
    219
    25
    Dec 6, 2015
    Smashvill
    Im getting this error on o3ds 10.5 rxtools emunand...
    Someone?
     
  12. stefanoteco
    OP

    stefanoteco Advanced Member

    Newcomer
    64
    5
    Jul 16, 2008
    Brazil
    São Paulo
    Updating my situation, the H&S app is missing, probably deleted but even so I cannot connect to the web. Maybe that is what is causing the problem. The real perfect way to fix it is really going to be downgrade do I could restore my nand

    The problem is how. Maybe I sould give my 3DS some vacations :/
     
  13. stefanoteco
    OP

    stefanoteco Advanced Member

    Newcomer
    64
    5
    Jul 16, 2008
    Brazil
    São Paulo
    Just tried formatting my system, it deleted all my SD card data (but I'll try restoring a backup I have later)

    I'm still without the H&S app but at least I can access online services and re-download my games :D

    And i was able to re-link my NNID so everything is fine. Store access miiverse all working and no H&S lol

    Accidentally posted so I'm edditing the rest of details
     
    Last edited by stefanoteco, Feb 3, 2016
  14. daxtsu

    daxtsu GBAtemp Guru

    Member
    5,539
    3,929
    Jun 9, 2007
    Antarctica
    So a system format cleared it up, aside from H&S being broken? Huh..good to know. I'm glad to hear you got it fixed, though.
     
  15. _Pro_Man_

    _Pro_Man_ GBAtemp Regular

    Member
    181
    74
    May 21, 2015
    United States
  16. daxtsu

    daxtsu GBAtemp Guru

    Member
    5,539
    3,929
    Jun 9, 2007
    Antarctica
    Except in Stefan's case, he was already on sysNAND 10.5, so he wouldn't be able to follow that. Nice job figuring out how to fix it on emuNAND though.
     
  17. stefanoteco
    OP

    stefanoteco Advanced Member

    Newcomer
    64
    5
    Jul 16, 2008
    Brazil
    São Paulo
    The bad thing is that my saves are lost, I'm searching for a way to transfer my old data back but I have no idea if its able. I mean, after formatting it generates a whole new NAND ID right? Have any of you had done something like that?? I mean... Save transfers?
     
  18. daxtsu

    daxtsu GBAtemp Guru

    Member
    5,539
    3,929
    Jun 9, 2007
    Antarctica
    Well, when you format, it generates a new "ID"/encryption key for your SD card's future contents, yeah. I think the only way to rescue the data would be to restore a NAND backup that used the same ID before the format, and then use SaveDataFiler or some other homebrew program to get your raw saves, then re-import them on 10.5 via homebrew. I could be wrong though, so I'd wait for other opinions.