need to fix priiloader.....

Discussion in 'Wii - Hacking' started by techker, Mar 31, 2011.

Thread Status:
Not open for further replies.
Mar 31, 2011

need to fix priiloader..... by techker at 2:48 PM (5,154 Views / 0 Likes) 43 Comments

    • Member

    techker New Member

    Member Since:
    Jun 2, 2009
    Message Count:
    147
    Country:
    Canada
    Hey guys,..im going nuts here!!

    i installed the updates for 4.3u on a wii that was updated by mistake..

    so i did it all wiihacks guide..

    but now i think idid a mistake by installing the part were you install the atched version of 4.1u..

    anyways so i got it ging but priiloader is not loading the menu hacks..

    i noticed in system check that it shows now..System Menu 0.0U (v54449)

    what a pain..

    is there a way to fix this??

    or in hack.ini is there a way to put System Menu 0.0U (v54449)

    just read about systeme menu x i think its the dark corp..how can i trick priiloader to read a systeme menu 0.0u


    • Member

    Hells Guardian New Member

    Member Since:
    Dec 25, 2008
    Message Count:
    1,110
    Country:
    United States
    Just install a new system menu 4.3U wad then reinstall priiloader. sounds like you are using a patched system menu.....
    • Member

    mauifrog DA KINE WiiHacker

    Member Since:
    Jan 21, 2010
    Message Count:
    1,534
    Country:
    United States
    Just leave it, that is how it should be. You need the hacks hash ini from the guide on your SD card
    • Member

    XFlak Considering Wii-tirement...

    Member Since:
    Sep 12, 2009
    Message Count:
    9,091
    Location:
    Ontario
    Country:
    Canada
    In theory it should be pretty easy, just open up your hacks.ini, and find the section with the hacks for your system menu version (ie. 4.1U = 449) then edit replace all instances of "version=449" with "version=54449" (or whatever version u have installed). Alternatively, u can copy and paste the revised 449 system menu hacks to the end of your hacks.ini file so that the same hacks.ini file will support the original 449 system menu as well as your modified 54449 system menu.

    Here's the 4.1U (v449) hacks with "version=449" replaced with "version=54449". Just copy and paste this to the end of your hacks.ini file (or, if u don't have 1, create a new file called hacks.ini on the root of your SD card and paste the following code in it and save it)

    Code:
    [Replace Health Screen with Backmenu]
    version=54449
    offset=0x81656084
    value=0x814093D4
    [Auto-Press A at Health Screen]
    version=54449
    offset=0x813BCCC0
    value=0x48000034
    [Block Disc Updates]
    version=54449
    offset=0x8137EEA8,0x8137EEAC,0x8137EE50,0x8137EE54
    value=0x60000000,0x60000000,0x60000000,0x60000000
    [Block Online Updates]
    version=54449
    offset=0x8168EE50
    value=0x6E756C6C
    [No System Menu Background Music]
    version=54449
    offset=0x8136ADC4
    value=0x4E800020
    [No System Menu sounds AT ALL]
    version=54449
    offset=0x8136AD98
    value=0x4E800020
    [Move Disc Channel]
    version=54449
    offset=0x813AF484
    value=0x60000000
    [Remove NoCopy Save File Protection]
    version=54449
    offset=0x813C4D88,0x813C4D8C,0x8134E1E0,0x815C1C70,0x81353DF0,0x8134E1F0,0x8134E
    1F4,0x8134E1F8,0x8134E1FC
    value=0x7C000000,0x4182001C,0x7C000000,0x38600001,0x3BE00000,0x801C0024,0x540000
    3C,0x901C0024,0x48000018
    [Recovery Mode (DISABLE below hack first)]
    version=54449
    offset=0x8137A854,0x813794A0
    value=0x48000020,0x60000000
    [Recovery Mode press Dpad-R on GC pad 4P]
    version=54449
    offset=0x8137A86C,0x813794A0
    value=0x2C000002,0x60000000
    [Region Free EVERYTHING]
    version=54449
    offset=0x8137D474,0x8137D47C,0x8137D480,0x8137D738,0x8137D758,0x8137F508,0x813B6
    0F0,0x8152D1C0,0x8152D6A8,0x8153066C
    value=0x38000001,0x900DA5D8,0x38000032,0x38000001,0x4800001C,0x38600001,0x480000
    28,0x60000000,0x38000001,0x4E800020
    [Force Wifi Connection Test Failure]
    version=54449
    offset=0x81650D00
    value=0x746C642F
    [Blackscreen at Wii System Menu startup!]
    version=54449
    offset=0x8137A87C
    value=0x60000000
    [Freeze Wii at Healthscreen!]
    version=54449
    offset=0x8136AE38
    value=0x4E800020
    that being said... darkcorp isn't for everyone, u may want to consider performing a fresh/clean softmod using ModMii (it will overwrite your current system menu, and supply u with all the hacks u will need without having to fiddle around with all the stuff I mentioned above, but to each his own)
    • Member

    techker New Member

    Member Since:
    Jun 2, 2009
    Message Count:
    147
    Country:
    Canada
    really help full answer dude thx..first one...

    as for darkcorp i have it running o my wii and it loads the disks now from the wi laucher..what i found cool..lol

    but you say a fresh install..how?
    • Member

    bazamuffin RESIDENT DILF

    Member Since:
    Feb 1, 2009
    Message Count:
    2,036
    Location:
    Shmashmortion Clinic
    Country:
    United Kingdom
    Hahaha, SM0.0U. That actually looks quite cool [IMG]
    • Member

    XFlak Considering Wii-tirement...

    Member Since:
    Sep 12, 2009
    Message Count:
    9,091
    Location:
    Ontario
    Country:
    Canada
    Download ModMii from my sig, from the main menu, enter "W", answer the questions truthfully except for when it asks if you wii is a virgin, answer yes even if it isn't. If you want to retain the ability to play backup discs from the disc channel, before launching the ModMii Wizard, go to modmii options ("O" from the main menu) and disable the "U"pdate active IOSs option.

    Then just follow custom guide the ModMii Wizard generated for u.

    edit: even though u are technically currently on 4.1, tell ModMii you are currently on "3.X", otherwise a proper 4.1 system menu will not be downloaded (unless you tell it u want to change from 4.1 to 4.2/4.3, in which case u can answer either "3.X" or "4.1")
    • Member

    techker New Member

    Member Since:
    Jun 2, 2009
    Message Count:
    147
    Country:
    Canada
    well your trick worked fine..now i blocked disk update..so no more worries about that..lol

    i seen once in a hack .ini block system updates?..

    as for the mod mii if there is no danger as is i will leave it like that..but it still does not read the copyed disks..lol

    thx!
    • Member

    mauifrog DA KINE WiiHacker

    Member Since:
    Jan 21, 2010
    Message Count:
    1,534
    Country:
    United States
    If you followed my guide you can only load disc from the disc loader, darkcorp is not installed following my guide. So just use the disc loader, or if you really want install darkcorp. There is no reason to mod your wii again, no reason to remove sm4.1 v545##
    • Member

    techker New Member

    Member Since:
    Jun 2, 2009
    Message Count:
    147
    Country:
    Canada
    ok cool i will leave it as is..i found the stop menu updates so i fixed that..it seems to be running good...

    thx for the help guys!!
    • Member

    lulwut New Member

    Member Since:
    Mar 19, 2010
    Message Count:
    331
    Country:
    Japan
    no it looks stupid

    and i dont even know why ppl would want to install a modded system menu that has a version like that.
    i really dont...
    • Member

    XFlak Considering Wii-tirement...

    Member Since:
    Sep 12, 2009
    Message Count:
    9,091
    Location:
    Ontario
    Country:
    Canada
    I can see why it would make sense for region changed Korean Wii's. One accidental update and u could be screwed (at least not without the help of an infectus or a wode or w/e to fix the 003 brick). But other than that, I don't see the point either.
    • Member

    lulwut New Member

    Member Since:
    Mar 19, 2010
    Message Count:
    331
    Country:
    Japan
    thats what starpatch/priiloader is for

    the only way to update such a wii(incase you want the SM updated for some functionality which isn't going to be made) would be with ANOTHER retarded update with a higher rev or by removing system menu which is a stupid thing to do AND can brick/screw up the wii even if you install the SM wad instantly again afterwards
    just saying [IMG]
    • Member

    XFlak Considering Wii-tirement...

    Member Since:
    Sep 12, 2009
    Message Count:
    9,091
    Location:
    Ontario
    Country:
    Canada
    true, with system menu hacks available it really doesn't add any value to have the system menu version # changed

    but FYI, if u have an IOS with the version patch installed (ie. IOS236) you can "downgrade" the system menu without issues
    • Member

    lulwut New Member

    Member Since:
    Mar 19, 2010
    Message Count:
    331
    Country:
    Japan
    true, but i have a few issues with what you said
    236? go back to retard land (i have never understood the use of that made up ios never will i ever understand cause it doesn't make sense). if you meant that as an example; then learn2english/latin (eg != ie)

    and if there is a patched ios; there is also the opening for system menu patching. sooooo....
    • Member

    XFlak Considering Wii-tirement...

    Member Since:
    Sep 12, 2009
    Message Count:
    9,091
    Location:
    Ontario
    Country:
    Canada
    dude, u can be a real pain in the ass u know that? Just because u usually have valid points doesn't give u the right to be so hostile. I'm not a noob, so don't talk to me like I am one. And even if I was, jeez, take it down a notch!

    Let me get more specific just to satisfy u... IOS236=patched IOS36 installed to slot 236... if u don't understand the point of doing this... I guess u've never had to softmod a freshly updated Wii since the 4.3B update of September 2010. If u don't see the point of installing a patched IOS, then u must be an advocate of ahbprot enabled priiloader installer or wad managers (or similar apps)... if that's the case, I don't think I'm the one who needs to go back to "retard land" (sorry to anyone who may be offended by the term) cuz those apps are f'ing dangerous with the HBC in its current state.

    Seriously man, I was agreeing with u before. All I was adding was that if someone has SM version 54XXX installed the ONLY way to update such a wii is NOT just to install "ANOTHER retarded update with a higher rev or by removing system menu". Instead they could overwrite/"downgrade" SM version 54XXX with 449 (or w/e) as long as they loaded a patched IOS with the version patch (eg. patched IOS36 installed to slot 236). Like I said, I agree with u that there's no point in installing SM version 54XXX cuz system menu hacks will prevent updates anyways (why do u think my app ModMii has been doing it that way for ages?)

    Get off your high horse, or at least contribute something before acting like a king... what have u done other than posting priiloader beta's? And the only reason u are doing that is cuz daco got banned way back in the day and can't do it himself. I may not be Wii legend like giantpune or team twiizers, but at least I don't treat people like pieces of shit and like I'm better than them.

    PS. I'm willing to forget this whole argument, all u gotta do is say sorry.
    • Member

    DeadlyFoez Want Hell? Get married!!

    Member Since:
    Apr 12, 2009
    Message Count:
    5,003
    Country:
    United States
    I did not read through this thread greatly, but I find 'retard' offending. I know Xflak would not ever say that himself, but who ever did say that needs a correction bc that is not cool to say. I don't care if someone say 'mentally handicapped', but where as I have 2 autistic children (that are still a lot smarter than most of everyone here), and I've heard people call them retards and that foul and far from acceptable. Respect ppl if you want respect towards yourself. Who ever says "retard" in even a joking manner, loses all respect from me.
    • Member

    mauifrog DA KINE WiiHacker

    Member Since:
    Jan 21, 2010
    Message Count:
    1,534
    Country:
    United States
    I doubt there will ever be a reason to update from 4.1. Version patching the SM has the same effect as version patching ios, no N updates to the system menu, period. It also had the advantage of allowing you to update everything else from N without updating the SM. May people fail when told to use priiloader, it should be used. Also the version patched SM is easily replaced using most cios. The risk of bricking is minimal, much less than using ABHPROT.

    Everyone had there opinion, I think you should patch the shit out of your wii. It has no proven I'll effects.

    Anyway if your looking to mod a wii keeping the wii pure, don't follow any of my guides, they are very far from the idea.
    • Member

    lulwut New Member

    Member Since:
    Mar 19, 2010
    Message Count:
    331
    Country:
    Japan
    you got me on the ahbprot.

    you use ahbprot in dop mii(which it can get from HBC) to enable trucha bug and just install anything you fucking want.
    ahbprot is a safe thing if the programmer of the app knows wtf he's doing (in which case dop mii seems to work fine on that front).
    ahbprot only had a bricking risk with priiloader because it was touching a fragile part of the system (and that seems to be 100% resolved by 0.7 BETA 1)
    ahbprot in something like dopmii wont kill your wii unless you are using ahbprot to install/patch the SM or HBC IOS and it screws up; in which case you are doing something so wtf worthy idk what you are thinking

    ahbprot->dopmii->delete a installed ios that isn't directly needed and is patchable in some version,and isn't used by a critical part of the system->use ahbprot in dopmii to install that ios patched->load that ios->enjoy


    (side note, why should i say sorry? the ways of workings here are just stupid, overcomplicated and just make 0 sense)
    • Member

    M1r0 New Member

    Member Since:
    Jun 25, 2010
    Message Count:
    354
    Country:
    United States
    lulwut: Wrong, AHBPROT still runs a risk, even if the coder knows what he is doing. There are bugs such as (i forget the exact wording) Network Initialization that can cause AHBPROT to pause and possibly cause a brick, if the NAND is being modified.
Thread Status:
Not open for further replies.

Share This Page