YSMenu for the R4SDHC - a cry for help

Discussion in 'R4 DS' started by Anthe, Jan 25, 2015.

  1. Anthe
    OP

    Anthe Member

    Newcomer
    27
    10
    Aug 17, 2013
    Belgium
    Hi there

    I'm not really a new member, I've been lurking around here for some time now, but this is my first time posting so I guess I'm still somewhat a GBATemp noob. I know helping newbies is not necessarily the most fun thing out there, but I would really appreciate it if you do ;)

    Last year in november, a friend of mine gave me an R4. She had two (???) and "this one only works on the DS Lite anyway". Since I have a wide variety of Nintendo DS systems, this wasn't really a problem for me. She gave the unit to me without an SD card, which was fine (she gave it to me for free anyway, woo!), but of course that meant I had to go hunt for firmware.

    (my flashcart looks like this)
    Warning: Spoilers inside!

    Because I had always been against flashcarts because of their reputation and piracy and stuff, I didn't really know much about them, so looking for firmware was quite a pain at first. I was unsure what model I actually had and I didn't really understand how these so called "kernels" worked. I finally found firmware which worked (spent an entire evening on finding one, a lot of sites have been taken down) and I tried my favourite DS games such as Mario Kart DS and Super Mario 64 DS. These worked fine on the official firmware. I'm pretty sure the card I'm using is a clone card however.

    (official firmware looks like this)
    Warning: Spoilers inside!

    Soon though, I discovered the limits of the official firmware. YSMenu (or TTMenu? I still don't really know what to officially call it) was the obvious choice. After a little tinkering with R4YSAUTO, this 'worked' as well, though limited. There are so many versions around, so many guides with different downloads. 2009/03/27 looks like the latest version, but again, there are so many unofficial libraries floating around I could be totally wrong.

    (this is how it looks like now, I don't know this helps :P)
    Warning: Spoilers inside!

    I actually just use my R4 to play rightfully owned games, modded versions of games and emulation. All emulators boot with the official firmware, have worked with YSMenu before, but currently my files are all screwed up. I get a very famous r4dldi.dat error when trying to boot homebrew. There's a lot of questions about this error on Google, but very few answers. Early commercial games work just fine, though very recent games (2012) really don't. Modded games are a disaster (sorry, my phone derped on this one).

    I have succeeded earlier on making YSMenu run homebrew and modded games, but then the commercial ones wouldn't run. It's all a really big confusing mess for me and I have no idea how to fix it. I'm not a complete noob with homebrew and programming (I've been involved in numerous projects), but the lack of documentation that's left on the internet makes it quite hard for me to actually learn how to fix it myself. I've come across an update thread with some DAT files for updates for recent games, but I can't find it anymore.

    So, tldr;
    - Where can I find the latest version of YSMenu, for real?
    - Is it technically possible to run AND every commercial game, AND homebrew AND mods? How do I do this?

    Any help would be greatly appreciated and a step towards finally ditching my official firmware.

    Thanks in advance,
    - Anthe
     
  2. Technicmaster0

    Technicmaster0 GBAtemp Addict

    Member
    2,998
    603
    Oct 22, 2011
    Gambia, The
  3. Anthe
    OP

    Anthe Member

    Newcomer
    27
    10
    Aug 17, 2013
    Belgium
    Thanks a bunch!