"you need to update this software before you can launch it"

Discussion in '3DS - Homebrew Development and Emulators' started by Mzrceh, Feb 3, 2017.

  1. Mzrceh
    OP

    Mzrceh Newbie

    Newcomer
    7
    0
    Jan 22, 2017
    United States
    Is there a way to bypass this on a game?
     
  2. Xiphiidae

    Xiphiidae

    Member
    2,084
    1,017
    Sep 13, 2009
    Australia
  3. ChiinoKaponii

    ChiinoKaponii Advanced Member

    Newcomer
    61
    3
    Oct 12, 2015
    Try using hans
     
    Xiphiidae likes this.
  4. Robz8

    Robz8 Coolest of TWL

    Member
    6,964
    2,953
    Oct 1, 2010
    United States
    Ironfall Invasion.
     
  5. Xiphiidae

    Xiphiidae

    Member
    2,084
    1,017
    Sep 13, 2009
    Australia
    Ironfall isn't the only game that can give this message.
     
  6. Mzrceh
    OP

    Mzrceh Newbie

    Newcomer
    7
    0
    Jan 22, 2017
    United States
    I'm trying to run a romfs for Animal Crossing: New Leaf. And hans does not work for me. I go to boot it and then it goes on the screen that says "invalidated icache" and then freezes.
     
  7. Xiphiidae

    Xiphiidae

    Member
    2,084
    1,017
    Sep 13, 2009
    Australia
    I'm afraid that you may just have to update the game. I believe that on 11.2 you can't play ACNL unless you have the Welcome Amiibo update. HANS has a lot of issues since the latest *hax update, using CFW would be your best bet.
     
  8. ihaveamac

    ihaveamac GBAtemp Guru

    Member
    5,481
    6,052
    Apr 20, 2015
    United States
    Tigard, OR
    delete the game's save. restore an older pre-'welcome amiibo' save if you want to keep the save.
     
  9. Xiphiidae

    Xiphiidae

    Member
    2,084
    1,017
    Sep 13, 2009
    Australia
    OP is getting a message that appears on the Home Menu, before the game even boots to begin with. I believe that if you're on 11.2, you won't be able to start up the game at all unless you have the Welcome Amiibo update. I don't think that the save has anything to do with it in this case, I'm afraid.
     
  10. ihaveamac

    ihaveamac GBAtemp Guru

    Member
    5,481
    6,052
    Apr 20, 2015
    United States
    Tigard, OR
    in the case of Animal Crossing: New Leaf, it checks for the existence of updated.dat in the game's savedata. this is to prevent running the game without updates, since the older version can't handle the updated save format. the older ver is not blocked if this file doesn't exist.
     
    Quantumcat likes this.
  11. Xiphiidae

    Xiphiidae

    Member
    2,084
    1,017
    Sep 13, 2009
    Australia
    The only way that this would be applicable is if OP had the update, and then later deleted it. If this is actually the case then I rescind what I said.
     
  12. ihaveamac

    ihaveamac GBAtemp Guru

    Member
    5,481
    6,052
    Apr 20, 2015
    United States
    Tigard, OR
    this is the only cause of this prompt on Animal Crossing: New Leaf: installing update, run the game so the save can be converted (which also creates updated.dat), delete update. deleting the save (and therefore updated.dat) will enable the original game to be started again.
     
  13. vinstage

    vinstage 00f

    Member
    548
    960
    Jan 24, 2017
    Korea, South
    부산
    May work for you, but search up the title's name in eShop, download the update (if it's avalible, if not this won't work as far as ik) then find your the game's ticket ID in FBI's Ticket menu, then import the seed.

    If you don't know the ticket ID you can search it on this database.

    Legit CIAs can be updated by pressing Y when prompted. (Correct me if I'm wrong, it worked for me the other day when I went to boot up the games.)